1. Download our Official Android App: Forums for Android!

Support Speech to text keeps blocking my swear words even though the appropriate box is unticked. Any ideas?

Discussion in 'Android Devices' started by sandwichpolice, Aug 19, 2013.

  1. sandwichpolice

    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Aug 19, 2013

    Aug 19, 2013
    2
    0
    5
    Galaxy S4

    Android 4.2.2

    Language and input screen: I have Google voice typing and Swiftkey checked. Under Google voice typing, I have unchecked the "block offensive words" box.


    It happens in both Handcent and the stock messaging app.
     

    Advertisement

  2. MoodyBlues

    MoodyBlues - Crazy peacock person -
    Rank:
    None
    Points:
    343
    Posts:
    3,353
    Joined:
    Jan 27, 2011

    Jan 27, 2011
    3,353
    1,580
    343
    Formerly UNIX/Linux programmer/sysadmin, now disab
    /home/LosAngeles
    Hi there, sandwichpolice. Welcome to Android Forums. :)

    I'm moving this to the Galaxy S4 forum; it'll get a lot more exposure there from people who are familiar with your same device.
     
  3. Podivin

    Podivin Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    3,679
    Joined:
    Nov 29, 2009

    Nov 29, 2009
    3,679
    881
    213
    Jacksonville, Fl
    My GUESS is that it won't speech-to-text words that are not in your dictionary. Try adding your favorite swear word to the dictionary and then see if it will recognize it.
     
  4. lotus49

    lotus49 Android Expert
    Rank:
    None
    Points:
    153
    Posts:
    1,513
    Joined:
    May 9, 2011

    May 9, 2011
    1,513
    232
    153
    Male
    Yorkshire
    I can't help but I've just spent a few entertaining minutes playing around with this.

    Strangely, while it blocks the common swear words, there are some such as "wanker" that it doesn't block even though that's pretty rude in English. I presume that Google's US centric view means that typical English swear words are not spotted whereas the American English ones are.

    I'm so childish tee hee hee.
     
  5. Benrx

    Benrx Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    171
    Joined:
    Dec 13, 2009

    Dec 13, 2009
    171
    21
    38
    It is a setting. Go to Settings > My Device> Language and Input> and then click on the setting icon (gear thing) beside Google Voice Typing

    I found it by mistake one time.
     
  6. Petrah

    Petrah Psychotic Female
    Rank:
    None
    Points:
    333
    Posts:
    4,086
    Joined:
    Jun 13, 2011

    Jun 13, 2011
    4,086
    1,468
    333
    Female
    Annoying my X-Husband
    Hanover Park, IL
    There's another swear filter in the Google Now settings. See if unticking that one helps.
     
  7. scott_

    scott_ Well-Known Member
    Rank:
    None
    Points:
    38
    Posts:
    100
    Joined:
    Jun 4, 2011

    Jun 4, 2011
    100
    11
    38
    electrician
    Central Iowa
    One sure fire solution is to not swear in the 1st place..............but to each their own.;)
     
  8. schpoink

    schpoink Newbie
    Rank:
    None
    Points:
    15
    Posts:
    10
    Joined:
    Mar 20, 2010

    Mar 20, 2010
    10
    0
    15
    Adding the salty words to the personal dictionary solved the problem for me
    on a Galaxy S4 using Google Voice Typing....

    Settings -> My device -> Language and Input -> Google Voice Typing (hit gear for those settings) -> Uncheck "Block Offensive Words"

    Then:

    Settings -> My device -> Language and Input ->Personal Dictionaries -> "English (United States)" [in my case] -> Click the Plus + sign on top bar -> Enter the phrase of your choice
     

Share This Page

Loading...