1. Are you ready for the Galaxy S20? Here is everything we know so far!

sporadic tethering/FTP issue

Discussion in 'Android Devices' started by glennn, Sep 2, 2011.

  1. glennn

    glennn Newbie
    Thread Starter

    i have a Cliq XT with 2.3 installed (if you have to ask, don't :eek:) and i'd installed PDANet (which works great, by the way).

    when my pc is connected i'd experienced transfer problems periodically when i'd attempt to FTP files, but all other types of connections (http, https, mail...) would cause NO problems at all. usually had a download rate of about 3 to 4.5 mbps. not shabby for a free connection...

    the other day my FTP transfer inability went from sporadic to constant, and has remained.

    *** i can connect to the remote server just fine, but ANY attempt at a file transfer stalls out AND kills the overall connection for a short while ***

    i've been assuming that this was likely a PDANet issue. BUT, i just found a WiFi Hotspot app that also works great (4.5 mbps down on my PC) and the problem persists. i can connect to my remote server fine, but any attempt to upload a file stalls everything. i think about 25k gets uploaded before the upload stalls.

    so anyway, i'm very frustrated, i've uninstalled half the stuff on my phone, i've uninstalled my Internet Security, i've done everything i can think of. i've rebooted both numerous times.

    is there anyone who has an idea what might be causing something like this? it almost certainly has to be phone related since it's happening with both a USB tether and a WiFi tether... and since it has been sporadic, i don't see how my carrier (Family Mobile/T-Mobile from WalMart) can be blocking just file transfers, and nothing else...


    1. Download the Forums for Android™ app!


  2. koppie

    koppie Lurker

    The problem is NAT filtering. FTP uses one port for logging in and sending commands, but it uses other (mostly random) ports for the actual file transfer. You may want to try switching between active and passive transfers to see if that helps; passive transfers are more likely to get through a NAT firewall (theoretically). The truth is, your carrier is probably to blame here. I'm guessing you're not paying for tethering so you won't get any support from them. I just hit the same problem and it's a shame because it means I can't do web design using my tether.

    Further reading:

    (I'm new here so they won't let me post links yet)
  3. glennn

    glennn Newbie
    Thread Starter

    this tells me what i expected, somewhat. thanks - the wild thing is, i went for days and even weeks with no problems - i'm a developer, too, and for quite a while was able to transfer via FTP at will. It was right after PDANet upgraded to 3.02, and i'd assumed that that had fixed it.

    Then it started again, and this time it's down for the count.

    But you're saying it basically picks a random port to upload and download thru, so perhaps if i keep rebooting - which, my phone or my pc...? - i might find it back in good shape?

    i use passive ftp by default, and yes, i've played around with that, too.

    I'm betting then that i just need to get it to find a good port? does that make sense? can i do that with a good firewall, maybe? i use Avast IS, which is REALLY customizable in this area...
  4. cazz

    cazz Lurker

    hi there,
    i'm a developer having the same problem - I used to use WiFi tethering through my Samsung Galaxy SII and that worked fine for all net and FTP needs. However the Wifi just packed it in on the phone, so I'm having to tether via USB instead. Net all works fine until I try to FTP a file up - and the connection falls in a heap.
    Just wondering if you found any solutions to the problem?
  5. cazz

    cazz Lurker

    i found a way around it, though it doesn't make any sense - I installed the app PdaNet+ and when I use it for my USB tethering, FTP works fine. net seems a lot faster too...

Motorola CLIQ XT Forum

The Motorola CLIQ XT release date was April 2010. Features and Specs include a 3.1" inch screen, 5MP camera, 256GB RAM, MSM7201A processor, and 1420mAh battery.

April 2010
Release Date

Share This Page