1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Sprint] Can anyone use the protect backups feature in Titanium Backup Pro?

Discussion in 'Android Devices' started by mycroftholmes, Jun 29, 2012.

  1. mycroftholmes

    mycroftholmes Lurker
    Thread Starter

    Not sure if this should go in Apps, Gnex, or Sprint Gnex. Please move if incorrect.

    I cannot use the protect backup feature (short press on a specific TiB backup, choose "protect"). Get "Sorry, the operation failed". Several hours of searching forums and the web only led me to one other user who tweeted problem to the developer. Nothing in forums. I emailed the developer a bug report and tweeted the same thing several weeks ago. No response and subsequent updates have the same problem.

    This leads me to believe no one else is having the problem or no one uses the feature. Any want to try and post results?

    It works on my Touchpad running CM9 (i.e. ICS). Trying to avoid doing another wipe and restore. The Google Wallet insecure element problem has me freaked out even with the preventative steps.

    Makes it a pain because I like to protect backups of certain apps that have gotten worse with an update. This keeps my "good" backup from being overwritten when my schedule runs.

    Stock Sprint ICS ROM, unlocked, rooted. Thanks.


  2. jackdubl

    jackdubl Android Expert

    Nope, hasn't worked for me on the Nexus. Says operation unsuccessful, or something like that. Very strange. AOKP.

    I asked this same question a while ago in the AOKP thread and no one even knew the feature existed.

    I have had to manually copy the backup file I want to protect and put it in another folder. Not very efficient.
  3. GandalfTehGray

    GandalfTehGray Android Expert

    I've never used this feature before, why not make a backup of the app on the computer and just not worry about it?
  4. mycroftholmes

    mycroftholmes Lurker
    Thread Starter

    Thanks jackdubl. Now I know it isn't something I did but a bug.

    That works and is what I do for a stopgap but as jackdubl said, once you have used this feature anything else just seems inefficient. TiB w/scheduled Dropbox sync yields local, PC, & cloud backups to all the app versions I want to keep w/o much thought or "manual" labor.

    If we still had ability to detach apps from the Play Store it wouldn't matter for me (TiB can't help that from what I've read). Really only have been using it to revert to the last GO SMS Pro version that allowed local SMS backup. Sometimes I forget and hit update all.

    On my old phone with little space, I protected smaller versions of apps for reversion.
  5. vicw

    vicw Lurker

    I have the same problem on my Nexus 7 and VZW Galaxy Nexus phone, both on 4.2.1, although I don't think the OS level is important. I queried support at Titanium Backup about it, and they quickly responded with a proposed solution, which offered some insight into the problem, but hasn't worked for me.

    I repeat it here only because I think they are right about the problem occurring on devices that have an "internal sdcard", and it might stimulate some more ideas leading to a real solution.

    Here is the core of their response, verbatim:

    "Some devices don't support the "read-only" attribute for files on their storage area, which is why you are getting this error. Its a filesystem limitation on some devices that have an "internal sd card" which emulates FAT filesystem, but without offering the "read-only" attributes for files.

    The simple solution, if you're rooted, is as follows:
    1. Using a root-enabled file manager, navigate to /system/etc/permissions and make sure you have mounted the file system r/w.
    2. Edit platform.xml and find the WRITE_EXTERNAL_STORAGE permission.
    3. Add an additional group definition for this permission...<group gid="media_rw" />
    4. Save the changes to the file.
    5. Restart your tablet."

    I carefully followed their instructions, but didn't see any change in behavior on my Nexus 7. I wrote to them again, and am awaiting another response. If anyone else tries it, I hope you will post back here with your results, good or bad.
    scary alien likes this.
  6. scary alien

    scary alien not really so scary

    Hey guys, I've moved your thread for you to the all-things-root area for Sprint (since the OP's phone is on Sprint).

  7. vicw

    vicw Lurker

    That's fine, but it should be noted, that this isn't a Sprint issue. I have the identical problem on my VZW Galaxy Nexus and my Nexus 7. It looks to be a problem with Android devices that have SDcard storage configured within internal memory vs. Titanium Backup.
    scary alien likes this.
  8. scary alien

    scary alien not really so scary

    Duly noted ;) :).

    Yeah, I had to move it somewhere and it was/is root-related and since the OP's device is on Sprint, that was my thought process.

    We might be getting a forum more appropriate to house non-device specific issues like this. I'll try to keep this thread in mind when/if that happens :).

  9. sally1999

    sally1999 Lurker

    I found a reason why you put the backup files on an internal memory.
    To protect the backup files, you need to change the place for backup to an external SD card.
  10. vicw

    vicw Lurker

    True, but many newer devices don't have an external SD card. That is the problem.
    sally1999 and scary alien like this.
  11. scary alien

    scary alien not really so scary

    Welcome to our AndroidForums, Sally!

    I think this is what you were talking about:

    (taken from this post http://androidforums.com/nexus-4-all-things-root/743801-titanium-backup-not-functioning-stock-rooted-4-3-a.html#post6010964)

    Also, see these threads for more info re. TiBu:




    sally1999 likes this.
  12. vicw

    vicw Lurker

    I think that suggestion was regarding a different issue - as I recall it had to do with difficulty getting TB working on 4.3, not about the problem of not being able to Protect a backup of an individual application - on devices that don't have an external SD Card slot, which was not a 4.3 related problem.

    I just tried it again, just to be sure, and it made no difference with protection. I'm not aware that a solution has been found for that one.
    scary alien likes this.
  13. sally1999

    sally1999 Lurker

    I see that my idea did not reach to there,sorry.
    scary alien likes this.
  14. sally1999

    sally1999 Lurker

    Hi,scary. I am glad to have you welcome.
    That's just a point. Thank you for having you supplement.

    Sorry for my poor English.
    scary alien likes this.
  15. 2anyone

    2anyone Newbie

    I come across here because I met same problem. :(

    Nexus 5 + CM11 + titanium 6.5

    did follow the instruction, but did not work. I found this fix changed the "WRITE_EXTERNAL_STORAGE" permission, but the actually problem is "WRITE_INTERNAL_STORAGE", I did try to find this section in the platform.xml, but had no lucky.

    Any body can give use a cure for this? Thank you.
  16. vicw

    vicw Lurker

    Just to clarify, the long quote attributed to me, is actually my quote of the response from support at Titanium Backup, and it didn't work for me either, as I indicated in that post.

    I finally just gave up on finding a fix for the problem. Sorry that I don't have a solution. Good luck.
  17. cdzo72

    cdzo72 Member

    Just as a fluke I landed here in this forum looking for an answer to why I couldn't protect a backup using TiBU... well after reading something about an internal SD which is what my Galaxy S4 i9505 has, I know several apps that have to have their paths to storage modified. On my S4, everything else (apps) uses storage/extSdCard/... but on letting TiBU detect where the backups were, it spit out THIS funky path... mnt/media_rw/extSdCard/ and even asked me if I wanted to copy the current backups to the new location. Well I hit cancel and using Root Explorer I navigated to that address and it's the same thing... so chose that in TiBU and I can now protect my backups.
    scary alien likes this.
  18. techmanc

    techmanc Well-Known Member

    I have this problem too but I cant get access the media_rw folder using TB to find folder without changing RW permission on the folder. Then it works until phone is rebooted and then I lose permissions the media_rw folder. This is a Galaxy S3 kitkat phone.
    Any way to make the folder read write permissions stick?
    I would love to get the protect feature working.
  19. DerDoktor

    DerDoktor Newbie

    Hi all, I have this same prob on my optimus zone 2, its rooted, stock rom on 4.4.2. I still dont have a problem on my good old president on 2.3. anyone found a solution?
  20. techmanc

    techmanc Well-Known Member

    I have a script I got at XDA Forums that finally fixed be able to access the media_rw folder and script is run at every bootup to solve the problem of not working after reboot.
    I dont have time to find the link atm as it was fixed a few months ago but if no one can find the link or post the instructions I will try to get the answer this weekend.

    here is the script I am using called "fix rw" I did a copy and paste of the file and also put the file in a zip to be able to d/l

    The app I used is the ROM Toolbox Pro and sure there are other apps but that the one I used link here so people have all the info



    busybox mount -o remount,rw /
    chmod 777 /mnt/media_rw

    Attached Files:

    #20 techmanc, Mar 20, 2015
    Last edited: Mar 20, 2015
    scary alien likes this.
  21. techmanc

    techmanc Well-Known Member

    surprised no one tried or commented on my fix post
  22. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    The Galaxy Nexus came out at the end of 2011.

    There are still plenty in service but most owners here have moved on.
    scary alien likes this.
  23. techmanc

    techmanc Well-Known Member

    I used this for my boost galaxy s3 using kitkat which they still sell so its relevant just was not even paying attention to where this post was made.
    EarlyMon likes this.
  24. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    OK, so if I may - how about our rooting forum if this is a general interest thing?

    But I hear you, the Boost forum for your phone is a great place too. :)

Share This Page