1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Sprint/Cricket] HELP

Discussion in 'Android Devices' started by 303emjr, Jul 18, 2013.

  1. 303emjr

    303emjr Lurker
    Thread Starter

    Hi guys,

    I am trying to root my GS3 for sprint SPH-L710I keep getting an error when trying to unzip in CWM recovery. I have tried formatting my sd card and tried different sd cards but I get e: can't mount sdcard error every single time. I have also tried using the internal SD card and no luck same error. I am using CWM-Recovery-LTE-SGS3-v5.tar(1).md5. Any help is appreciated thanks in advance.
     


  2. 303emjr

    303emjr Lurker
    Thread Starter

    I have also tried TWRP and it gives me the same problem.
    E: can't mount/cache/recovery/command
    E: can't mount/cache/recovery/log
    E: can't mount/sd card
     
  3. jonny wad

    jonny wad Well-Known Member

    Do not unzip the root.zip just install it.
     
  4. AARONONE

    AARONONE Android Enthusiast

    What type of computer are you using? If by chance you are on Mac using safari, the default settings unzip the files. Here is how you change it:


    Open Safari Click Safari (next to the apple icon in the upper right corner) Preferences General Tab At the very bottom of the general tab UNCHECK "Opensafe files automatically" Once you uncheck that, redownload the zip, put it on the sd card and then reflash.
     
    jonny wad likes this.
  5. 303emjr

    303emjr Lurker
    Thread Starter

    Thanks for replying...I am not unzipping the file my phone just does not read the sd card for some reason. I am following the steps as they show. Not sure what the problem is..

    I am using windows BTW. Hope I can figure this out. It is really fustrating
     
  6. jonny wad

    jonny wad Well-Known Member

    AARONONE likes this.
  7. 303emjr

    303emjr Lurker
    Thread Starter

    Hey thanks for your suggestion and sorry for not replying sooner, I just been busy with work. The format for the card is 32fat. It's fustrating because i know i am doing what the manual says, and for some reason the phone does not mount the internal or external sd card in TWRP or CWMR. I will give this a shot will let you know if I succeed! (fingers crossed)
     
  8. AARONONE

    AARONONE Android Enthusiast

    Have you tried from your internal sd card?
     
  9. 303emjr

    303emjr Lurker
    Thread Starter

    Johnny, I tried your suggestion but no luck. Everything that it says in the emulator goes through, but when I check the root it says it's not rooted.

    Aaronone, I am not able to. The CWMR or TWRP do not mount either the EXT-SD CARD or internal. I have tried different versions of each and no luck.
     
  10. meanmini1

    meanmini1 Well-Known Member

    did u try qbking77's rooting method? are u rooting with odin? i would try that way if u haven't. i've rooted two sgs3's both times using his method and worked both times. i also just recently unrooted (after some hair pulling and cursing) and rerooted using this method and good to go. when u download the CWM recovery thru odin and copy the .zip file onto ur phone, the "zip from internal sd card" should be on the list. that's where the .zip file will be.
     
    jonny wad likes this.
  11. jonny wad

    jonny wad Well-Known Member

    You could also backup your current ROM, use Odin to flash a prerooted stock .tar, then restore your data from your backup.
     
  12. 303emjr

    303emjr Lurker
    Thread Starter

    Thanks man, I have done everything that different methods of flashing say... And nothing roots the phone. I tried un-zipping the CF auto root in my computer and falshing through ODIN everything goes through as it shows in the video but.. When it reboots nothing is there. I am just fustrated. I just don't understand why in recovery mode weather it's CWMR or TWRP various versions, the ext-SD card, internal SD card or system will not mount.. I tried the emulator as well.
     
  13. imaconeheadXD

    imaconeheadXD Newbie

    I'm guessing you just got your phone recently? This seems to be an issue with all new S3 devices from sprint and virgin mobile, seems they must have done something with the bootloader or so to avoid flashing custom roms. You can still root though by using odin to flash a pre-rooted stock rom
     
  14. 303emjr

    303emjr Lurker
    Thread Starter

    Hi I figured it might be something the carrier did! do you know any good pre rooted stock roms?
    I'm not sure if this might be a problem as well: when I open supersu I get: ''there is no SU binary installed, and SuperSu cannot install it. This is a problem.''
    since I can't mount the internal or external sd card in recovery mode there is no way for me to intall the super user binary. Any suggestions.
     
  15. 303emjr

    303emjr Lurker
    Thread Starter

    :D Thanks Jhonny Wad finally was able to root! You saved me from pulling my hair out LOL!

    I followed the link: http://forum.xda-developers.com/showthread.php?p=44262749
    flashed:
    CWM Recovery Mod This is a tar file that can be flashed in odin

    downloaded
    CWM-Superuser-3.1.3.zip

    copied to ext sd card and installed through recovery.
    make sure it is the superuser-3.1.3 i tried a older version and the binary would not update.

    Hope this helps everyone with a new GS3 that would not mount sdcard in recovery mode. :thumb:




     

Samsung Galaxy S3 Forum

The Samsung Galaxy S3 release date was May 2012. Features and Specs include a 4.8" inch screen, 8MP camera, 1GB RAM, Exynos 4412 Quad processor, and 2100mAh battery.

May 2012
Release Date
0
Reviews
Loading...

Share This Page

Loading...