1. Check out our companion app, Forums for Android! Download from Google Play

Root [Sprint] Help installing Superuser

Discussion in 'Android Devices' started by Jwillvin, Jun 5, 2013.

  1. Jwillvin

    Jwillvin Member
    Thread Starter
    8

    Jun 29, 2012
    5
    10
    8
    Hi, I'm trying to root my One and I followed the directions laid out in the guide by Scotty85 step by step however, after flashing the superuser zip file when I go to reboot I get a message that says the phone is not rooted. In the same message it asks if I would like to install Super user in order to root?

    After installing the SU zip file from recovery I do not see the icon in my apps.

    I'm following the directions for a temp recovery install because I only want to root so as to be able to use a wifi tether app.

    I'm using the sprint twrp image file not the at&t international etc one.

    Also when on the bootloader screen, at the top it says "unlocked" and above that it says "tampered"

    What am I missing?

    Thanks
     

    Advertisement

  2. Recoil1

    Recoil1 Well-Known Member
    53

    Jun 21, 2010
    168
    50
    53
    You can try and install it through goo manager which had worked before but that didn't work for me. I had install it through fast boot which gave me SU function and then after that everything worked.
     
  3. gonowhere

    gonowhere Well-Known Member
    88

    Jan 8, 2012
    350
    147
    88
    Norfolk, VA
    There's always the possibility of a bad download.
     
  4. scotty85

    scotty85 Well-Known Member
    1,413

    Jul 25, 2010
    11,139
    7,418
    1,413
    i just picked up a t mobile htc one,and experienced this same problem. the temp recovery worked just fine on my s off international one,but not on the s on t mobile version.

    i tried several times,with all available recovery images,with same result(reboot and no SU in the app drawer). rest assured,youre likely not doing anything wrong,there just seems to be a wierd glitch where fastboot cannot write to system :eek:

    after i broke down and permantly installed the recovery,the superuser flash went fine.

    heres what id recomend:
    -boot clockwork recovery and make a backup(so your stock recovery is captured).
    -boot back to bootloader.(or reboot and boot back to bootloader)
    -permantly install recovery
    -reboot
    -boot to recovery
    -flash superuser
    -reboot

    if you want the stock recovery in place,find the stock recovery image in the nandroid you made with the temporary recovery. copy it to adb/fastboot folder. install it just as you did your custom recovery.

    sorry about the confusion this has caused,when i made the guide i was unaware this would be an issue. ill add a disclaimer until its worked out. :)
     
Tags:

Share This Page

Loading...