1. Are you ready for the Galaxy S20? Here is everything we know so far!

Sprint Hub Always Running

Discussion in 'Android Carriers' started by DieselJC, Mar 21, 2018.

  1. DieselJC

    DieselJC Newbie
    Thread Starter

    So yesterday my phone updated to Oreo and while I love the new features I noticed that Sprint Hub seems to be running way more than it should or used to. I've seen on forums where alot of people are complaining about this. Anyone have a solution or any ideas to keep it from draining the battery faster than it should?

    JC
     



    1. Download the Forums for Android™ app!


      Download

       
  2. svim

    svim Extreme Android User

    Try going into your Settings >> Apps menu and open up the 'Sprint Hub' app * (you might need to use 'Show system' to also show system services). Tap on 'Force stop' then open up 'Storage' and tap on 'Clear data'. That'll wipe the app's configuration settings and its cache.
    Now restart your phone (the first thing to try anyway) and see if there's any improvement.

    SprintHub.jpg
     
    Unforgiven likes this.
  3. DieselJC

    DieselJC Newbie
    Thread Starter

    I did everything as you described and still comes up. I also denied it any permissions as well...but my Google keyboard is using more batt than Sprint Hub is...strange..it shows Sprint Hub using 0% battery. It may be giving a false reading,I would think if it's giving notification it should be using a considerable amount of battery.
    Thanks for the reply.

    JC
     
  4. sussan59

    sussan59 Lurker


    I received the update for the new Oreo software upgrade last night and expereinced or at least at the top of the phone it kept the message Sprint Hub is running.


    I did go into the settings clicked on Device maintenance and tapped on the battery. That will show what apps are running and Sprint hub was in there and said 0% usage per hour so it wasn't really running.


    So I went into Apps clicked on the three dots in upper right corner as I called Sprint about this was told to select "Show system apps" scroll to Sprint Hub and select Force Stop only which it did take the message off but only a matter of time it was back.


    So I called Samsung and they basically told me to go to Best Buy as they will deal with software issues. So I guy I talked to when through everything I did and said well your battery really isn't running as shown on what we went through so he suggested and did is he went back into the step above and selected Sprint Hub and scrolled down to where it says "Notifications" and turned off and it "blocked" the notifications at the top of the phone warning at the top of the phone what everybody is getting.


    So I don't think the battery isn't running constantly at all just turn off notifications. My battery is running normally and no longer get that error at the top of my phone. I make sure to at least once a day to to into settings and click on device maintenance and optimize the battery, storage and memory to keep the phone running faster and smoother.
     
  5. sussan59

    sussan59 Lurker

     
  6. sussan59

    sussan59 Lurker

    I received the update for the new Oreo software upgrade last night and expereinced or at least at the top of the phone it kept the message Sprint Hub is running.


    I did go into the settings clicked on Device maintenance and tapped on the battery. That will show what apps are running and Sprint hub was in there and said 0% usage per hour so it wasn't really running.


    So I went into Apps clicked on the three dots in upper right corner as I called Sprint about this was told to select "Show system apps" scroll to Sprint Hub and select Force Stop only which it did take the message off but only a matter of time it was back.


    So I called Samsung and they basically told me to go to Best Buy as they will deal with software issues. So I guy I talked to when through everything I did and said well your battery really isn't running as shown on what we went through so he suggested and did is he went back into the step above and selected Sprint Hub and scrolled down to where it says "Notifications" and turned off and it "blocked" the notifications at the top of the phone warning at the top of the phone what everybody is getting.


    So I don't think the battery isn't running constantly at all just turn off notifications. My battery is running normally and no longer get that error at the top of my phone. I make sure to at least once a day to to into settings and click on device maintenance and optimize the battery, storage and memory to keep the phone running faster and smoother.
     
  7. greenleerita

    greenleerita Lurker

    I did the latest update and lost my personalized ringtones for messages. Any hope of this being restored soon?
     
  8. amarie82

    amarie82 Android Expert

    Sprint is aware of the issues on this! Impacted applications are: premium caller ID, VVM, Sprint spot, app spotlight, tidal, secure WiFi. The solution to remove any persistent notifications update the 6 applications listed!
     
    franknbeans1976 likes this.

Sprint

Loading...

Share This Page

Loading...