1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Sprint] Samsung Galaxy S4 Root Method

Discussion in 'Android Devices' started by Blackout720, Apr 28, 2013.

  1. Blackout720

    Blackout720 Well-Known Member
    Thread Starter


    Ok so In my Last Post I Did a little how to root but didn't really say how to do the root and left some things out.

    Works Wit All Qualcomm-based Galaxy S4 running Android 4.2.2 Including:
    AT&T SGH-i337, T-Mobile, Sprint SPH-L720, T-Mobile SGH-M919, GT-i9505, US Cellular, Canadian SGH-i337M, Rogers, Bell, Telus, and other Qualcomm S4s.

    Samsung Galaxy S4 Drivers: http://bit.ly/15kS5Cu

    Samsung Galaxy S4 Root Files: http://bit.ly/129kK7W


    Extract the entire contents of the 2 zip files.

    If you are using Windows, ensure you have installed the latest Samsung USB drivers available for your phone.

    Ensure USB Debugging mode is enabled on your device.
    To do this go into settings and to the "More" tab then down to "About Device"
    go to where it says "Built Number" and tap on that a few times until it says "Developer options Enabled".

    Now go back and go into Developers Options and Enable "USB Debugging"

    Connect your device to your PC via USB.
    Make sure you have Download and Installed the Drivers for your Phone First.

    If you are using Windows, navigate to the extracted directory and execute "run.bat". If you are using Linux or OS X, navigate to the extracted directory in a terminal and execute "./run.sh".

    Now watch you phone as 2 Pop ups will happen agree and press yes to both.

    And There you go, you should now be rooted!

    You can also Follow along here on this video : http://www.youtube.com/watch?v=23qSKcWNL5w

    I put my own phone on the line and try this for the first time my self. - CONFIRMED WORKING!

    Subscribe ► http://bit.ly/YoutubeMrLegend103
    Facebook ► http://bit.ly/MrLegendFacebook
    Twitter ► http://bit.ly/W71rZQ
    Google + ► http://bit.ly/V57ajp


    rkkeller, nsciucco and ocnbrze like this.
  2. nsciucco

    nsciucco Android Expert

    Has anyone actually tried this yet? Im waiting to buy my S4 until I know that a root exploit works. No offense to the OP
  3. Aaron91RS

    Aaron91RS Member

    How? There is no development mode under application manager that I can see

    Edit found it. What a PITA hidden thing. Anyway. Superuser popped up after installing and running a root app so I assume it's working.
    How To active USB Debugging on Android 4.2 Jelly Bean

    1. On your device go to Settings => About phone
    2. You will see the build number, just tap on Build Number five times repeatedly and you will see a quick note: “Press it two more times to be a developer!”. Continue tapping twice more and after completing seven tapping you will see ‘You are now a developer’ message.
    3. Now you can easily find the developer options under your settings menu.
  4. Guitardoc64

    Guitardoc64 Member

    Yeah, I found it pokin around in that menu.
  5. Aaron91RS

    Aaron91RS Member

    another note if you root it and setup everything by wifi before activating with Sprint. Sprints activation will wipe the device automatically and install bloatware.

    You can still reinstall SU afterward, but I wasted a whole day setting it up before activating it only to lose everything.
    Guitardoc64 likes this.
  6. nsciucco

    nsciucco Android Expert

    it is never a good idea to ROOT before activating. Or do any modifications. Get it activated then hack the crap out of it
  7. Aaron91RS

    Aaron91RS Member

    two words
    plausible deniability
    It was broke when it arrived, I never even activated it

    But for people willing to risk breaking a phone that has been out less then a week people would never know if a method worked or not.
  8. EarlyMon

    EarlyMon The PearlyMon
    VIP Member

    Two words -

    Consumer fraud.

    Make sure that your phone works right before rooting and messing with it.

    Because otherwise you're playing with two other words -

    Consumer protection.
    ocnbrze likes this.
  9. Blackout720

    Blackout720 Well-Known Member
    Thread Starter

    It works for anyone that's a little on the iffy side
    heres video proof: How to Root Samsung Galaxy S4 - Any U.S Carrier! - YouTube

    The first time i did it, I forgot the drivers so yeah don't forget that. it worked the second time though, no problems actually really easy the only part that took the longest was the drivers install time.
    ocnbrze and EarlyMon like this.
  10. Shabbypenguin

    Shabbypenguin Extreme Android User

    all credit for the exploit and root go to dan rosenberg (@djrbliss)
    mrpnut, EarlyMon and ocnbrze like this.
  11. rkkeller

    rkkeller Android Enthusiast

    The S4 is so new, I am going to wait a few months before rooting. I know there will at least be a couple updates and its easier to just OTA them then wait.
  12. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    well for me i always adhere to the rule, never accet an ota especially if you plan on rooting it in the future. sometimes with ota's previous exploits gets closed up so you will have to wait until there is a new exploit found

    .....now i'm not too sure how that applies to the new sammies going forward. but i would would not accept any ota's if you plan on rooting the phone.
  13. Groty

    Groty Member

    Three attempts on a Sprint S4. They continue to fail.

    [*] Motochopper: Android root exploit (Windows version)
    [*] v1.1
    [*] by Dan Rosenberg (@djrbliss)
    [*] Tested on the Motorola Razr HD, Razr M, Razr Maxx HD, and Atrix HD.
    [*] Supports lots of other devices as well. ;-)
    [*] Before continuing, ensure that USB debugging is enabled, that you
    [*] have the latest USB drivers installed, and that your phone
    [*] is connected via USB.
    [*] WARNING: This will likely void the warranty on your device. I am
    [*] not responsible for any damage to your phone as a result using this
    [*] tool.
    [*] Press enter to root your phone...
    Press any key to continue . . .
    [*] Waiting for device...
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    [*] Device found.
    [*] Pushing exploit...
    2008 KB/s (1283460 bytes in 0.624s)
    [*] Pushing root tools...
    1914 KB/s (366952 bytes in 0.187s)
    3340 KB/s (1867568 bytes in 0.546s)
    2744 KB/s (1578585 bytes in 0.561s)
    pkg: /data/local/tmp/Superuser.apk
    [*] Rooting phone...
    [+] This may take a few minutes.
    [-] Failure.
    [*] Cleaning up...
    [*] Exploit complete. Press enter to reboot and exit.
    Press any key to continue . . .

    I did not retain the original message.

    Should I delete the SuperUser.apk from the phone and attempt again?

    I've run 2 Root Checker apps and they both say it isn't rooted. Maybe they are phone specific and not config'd for the S4 yet. Is there another way to check?
  14. Shabbypenguin

    Shabbypenguin Extreme Android User

    are you on teh latest update? chances are you are rooted but teh new setuid kernel is blocking access. youll need to flash a custom kernel to get root again
  15. Corn314

    Corn314 Lurker

    How do I flash a custom kernel cuz I'm new to rooting and is says superuser but still isn't rooted. I have s4 sprint
  16. Darnell0216

    Darnell0216 Android Expert

    Follow this guide to root on update MF9: QbKing77 | Your Tech Simplified and then follow his instructions to install custom recovery.

Share This Page