1. Are you ready for the Galaxy S20? Here is everything we know so far!

[Sprint] Unlock/network problems

Discussion in 'Android Devices' started by Dbaydroid, Oct 10, 2014.

  1. Dbaydroid

    Dbaydroid Lurker
    Thread Starter

    Hi, bought this SPH-L720 and after my regular unlock sources couldn't unlock it I decided to try for myself. Tried a procedure on Galaxys4root that supposedly unlocks it for non-US carriers and tried my Jamaican sim. it did remove the 'invalid sim' message, now all I see is a red 'x' at the network signal bar.

    Current status: V4.4.2. Bld# L720VPUFNG2.

    History of what I did... Rooted, Downgrade base band to MDC, still showed V4.4.2, followed the entire procedure and got to the state of no signal but with invalid sim gone. Next I did the edit for APN settings, still nothing. Not sure what I did after that but I took a break and when i came back in the evening it was saying "Firmware upgrade encountered an issue, please select recovery mode in Kies and try again". Try as I might, Kies wouldn't connect so I got a stock 4.4.2 here (thanx) and flashed it with Odin3 v1.85 and voila ! Back to square one ! 1.5 actually because I still get that red X beside the antenna sig. None of the network settings yield anything, GSM/UMTS etc. Phone is also unrooted now.
    What I need: Help to get it unlock and fully operational, I'll root/upgrade as high as I can (learning) so any help appreciated.
    Pls excuse the long post but I wanted to list all that was done.
    Thanks in advance.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Dbaydroid

    Dbaydroid Lurker
    Thread Starter

    Ok, so it seems it's definitely unlocked since i ran the procedure again but i just cant get any GSM signal although it accepts the sim card.
    Finally got my MSL code after finding an APK file that i installed on my phone. I didnt have the MSL previously.

    So now i need it unlocked for T-Mo, AT&T etc. or maybe i just need to adjust the APN settings. Tried that but no luck yet

    EDIT: When i try to add T-Mobile apn manually with a Jamaican sim card in...i save and the T-Mo apn disappears with the refreshing of the screen, leaving my manually set Jamaican apn.

    I then insert a T-Mo sim and it auto-finds and lists the T-Mobile apn three times but still nothing on the signal bar. What gives ?

    Any help ?
     
  3. Dbaydroid

    Dbaydroid Lurker
    Thread Starter

    Found the solution and it's now sorted. Sprint Galaxy S4 SPH-L720 fully unlocked. Tested T-mobile and DIGICEL Jamaica SIM cards.
    Both working.
     
    DaisFlaque likes this.

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...