1. Are you ready for the Galaxy S20? Here is everything we know so far!

Spurious Battery Temperature Warning

Discussion in 'Android Devices' started by lotus49, Jul 18, 2011.

  1. lotus49

    lotus49 Android Expert
    Thread Starter

    I have two batteries for my SGS2. One is the original battery and the other an after market one I bought on eBay. I have been using both for a few weeks without any problems until today.

    When I swapped out my after market battery for my Samsung one, I get what appears to be a battery temperature warning. Before the phone was switched on, the display alternates between the large battery icon in the centre of the screen with 5 white dots below it and a battery icon with a yellow triangle with an exclamation mark inside it with a thermometer icon overlaid.

    I have never seen this before but it appears to be a battery temperature warning. The battery was stone cold (or at least room temperature) and the phone was at normal operating temperature, which, in my case, is again barely above room temperature. Neither is even warm let alone hot.

    Turning on the phone with this flashing is difficult and the only reliable way I can do it is to boot into CWM and reboot.

    Has anyone else seen this? Does anyone have any idea what's wrong with it?

    BTW My after market battery continues to behave perfectly normally as it always has.

  2. jr71

    jr71 Lurker

    I have a 3 week old s2 with a factory battery fitted. I had the same problem this morning, the phone was cold no signs of heat.

    Cheers Jay
  3. lotus49

    lotus49 Android Expert
    Thread Starter

    I'm going to phone O2 and ask them to send me a new battery. With any luck they won't mess about and will just send me one.
  4. lotus49

    lotus49 Android Expert
    Thread Starter

    I tried again this morning and all's well.

    I have no idea what caused this but if it doesn't recur, I shall forget about it and think myself lucky.
  5. jr71

    jr71 Lurker

    I put mine on charge last night, it seems that it isn't charging when the symbols are flashing on the screen.
    I had to do a reset to get it to turn on.
    Any ideas?

    Cheers Jay
  6. uktivo

    uktivo Well-Known Member

    Mine did exactly this about 2 months ago. I've had no issues since and the symbol hasn't reappeared..

    Hope this helps?
  7. polaris777

    polaris777 Newbie

    I get this and its a pain in the butt to get the phone back online. I find knocking out the battery and then putting it in works sometimes.
  8. lotus49

    lotus49 Android Expert
    Thread Starter

    I did try that several times without success.

    Although my phone wouldn't boot normally, I was able to start CWM (my phone is rooted) and rebooting from there worked OK.

    I'll keep my fingers crossed but since this has happened to several people, I'm wondering if it's a bug rather than a defective battery. We shall see...
  9. bigg1e

    bigg1e Lurker

    My sgs2 is doing the same thing, it also makes the charger connected beep at various different points through out the day even though the charger is nowhere near the phone. The phone is being returned to O2 tomorrow for a swap.
  10. Mine is starting to do this... less than a week old. Just tried charging at work, it charges for a few seconds then vibrates saying "charging paused, battery temperature too hot/cold to resume charging" or something along those lines
  11. lotus49

    lotus49 Android Expert
    Thread Starter

    If you have rooted your phone and can access CWM then it's fairly easy to get this working temporarily at least.

    I boot into CWM (Home button + volume up + power button) and then select Reboot (top menu item) and press the Home button again. That way it boots up fine and behaves (or did in my case) perfectly normally until you turn it off again.

    While my phone was showing the warning, I tried about 30 times to boot by just pressing the power button and it only worked once. Doing what I suggest above worked every time.

    It's odd that no-one had reported this until I asked my question but now several people are having the same bug.

    My firmware is KE2 and the phone is on O2 in the UK, what about others with this problem?
  12. tom.geypens

    tom.geypens Lurker

    Same thing over here!

    The phone seems to work normal, but when turned off battery warning with thermometer icon flashing.
    My phone is also rooted.

    One weird thing I'm also experiencing is I can't turn off USB debugging mode.
    It says:USB is connected. Remove the cable.
    Maybe you have the same problem and it's related?

    BTW thanks for the workaround for starting the phone!

    I'm curious what the causes may be... :thinking:
  13. tom.geypens

    tom.geypens Lurker

    Are there other people with this problem?
    Someone who has a solution or something for it?

    Shall it be my battery, or is there a problem with the firmware or something?
  14. lotus49

    lotus49 Android Expert
    Thread Starter

    I'm the OP and this hasn't happened again to me. I have been using the Samsung battery regularly since the problem arose 11 days ago and I haven't had any further problems.

    It's a rather strange problem but since it's gone away in my case, I have stopped worrying. Perhaps your phone will just magically start working again like mine did.
  15. Scottola

    Scottola Lurker

    I'm suffering from exactly the same problem with the battery and temp sign and the USB problems you have.

    I can't find anyway around it and much googling hasn't found any results.

    My phones is on a Vodafone business tariff, so I'm going to back it up and then get an exchange, as it's just too irritating now.

    Oh and I have hard reset to see if it went away and it never.

  16. ton

    ton Lurker

    Same here with startup temperature warning.

    1. If I shut down the phone its starts again with battery icon and temp alarm.
    2. If I remove the battery for a while and put it back, the phone starts with above. So there is no way to have the phone shutdown with the battery connected.
    3. With Restart from Service menu, the phone starts but wants to start sync MTP Connection. No way to see the main screen or program just the big sync screen.
    4. After a lot of testing I don't know how but I get back to the main screen and try to change usb debugging but I get the message: USB is connected. Remove the cable.
    5. Have tried to do a factory reset, change ROM's / Kernel without any success. Orginal, Stock, CM7, VillainROM
    6. Have removed the battery over the night but same problem.

    I hope someone found a solution soon.
  17. Snazzy

    Snazzy Android Enthusiast

  18. ton

    ton Lurker

    I Have, without success:(
  19. jr71

    jr71 Lurker

    My phone was also doing this as above, and it wouldn't turn off. It would switch off and turn back on. I rang Samsung and they said to take it to a Samsung service centre. They had it 2 days and said they could not repair it, it's got to be sent away, that was 17 days ago not happy. The phone was about 2 weeks old.
  20. lotus49

    lotus49 Android Expert
    Thread Starter

    It's worth pointing out that this appears to be related to the battery not the phone.

    I have two batteries and the after market one always worked fine. It was only the Samsung one that caused a problem. If you have a friend with the same phone, try swapping batteries and see what happens.

    In any event, replacing the battery should be enough I think (although I haven't done any testing as my phone stopped doing this the day after it first happened and hasn't done it since).
  21. ton

    ton Lurker

    With your bad battery did you have problem with MTP Connection / USB start syncronize without any cable attached directly after startup?
  22. lotus49

    lotus49 Android Expert
    Thread Starter

    Fortunately not.
  23. ton

    ton Lurker

    For the moment my phone is OK without temperature and usb problem.
    I was thinking to go to the store for service today but when I put the battery back again. Tada:)

    This is how I solved it.

    Removed the battery
    Move the simcard to another phone because is a business phonenumber.
    Let the phone rest without battery for 3 days.
    I tried with one night first without any success.

    Might be worth a try for you?
  24. Moredice

    Moredice Lurker


    I have this phone myself, bought it back in May.

    Yesterday, I was unlucky enough to drop my phone on the floor in a small puddle of water, which got into the USB port. I quickly picked it up, turned the phone off, opened the back cover, took out the battery and wiped everything off, then I used pressurized air to further blow any water inside out of it. Then I did something I perhaps should not: I put the battery in short after to try and start it, and then I got the same warning display as you describe here with the temperature icon next to it. I have a stock phone, not rooted or anything.

    It did not want to start on battery power alone, it was just stuck at displaying the battery with the yellow warning icon and temperature icon, alternating. Tried a soft-reset and a hard-reset without any luck.

    I then tried to plug a charger in to start it, it did actually start, but the first thing it did was to start the MTP sync application stating it was connected. It did this every time I started the phone using charger (both wall and PC USB cable). I plugged the charger out, the MTP application remained on screen saying it was connected. Also noticing the battery icon showing it was still charging, after I unplugged it. It took 15-20 seconds before the battery icon updated and showing it was not charging, but the MTP application remained on screen saying it was connected. I hit the home button to close it, tried to enable Mass Storage Device mode but it said the phone was connected (even through it obviously wasn't), and that I had to unplug it to continue.

    Plugging the USB cable from the PC to the device did not work either. Well, I got the USB connected sound from Windows, but nothing happened (it did not show up as a device). I use KIES for updating firmware, it also did not detect it. It did detect it when I connected it later, but it just hung at "Connecting" with the spinning icon next to it.

    After trying different methods to make it work, even doing factory reset, I attempted to restore my latest backup done through Kies (which worked the one single time it did connect after all this happened). I got an error message, after seeing everything got a nice green V, saying an error occurred. Checking my phone, everything was actually restored. But my battery indicator app did not wanna play ball with the battery, it wasn't measuring battery usage and the on-battery-timer wasn't ticking.

    I took out the battery and left my phone opened with the battery next to it over night, next day same thing happened.

    Since I work in a big-brand electronics store, I took a brand new battery from an exhibition model in our store, which I know was working, and the same thing happened. I also tried the charger from the exhibition model, it always started the same way and ran MTP upon boot.

    This means it was not the battery. For double-checking, I tried a brand new battery right out of an unopened box, this also did not work - I also tried the charger from this, no difference in result. The problem was with the phone. Yes, it was dipped in water, and yes, I should've left it drying over night even though I managed to force every drop of water out of it.

    I also saw that when I managed to start the phone after the incident while it was connected to a charger, my battery indicator app showed that the battery was giving overvoltage (3.91-4.13 volts). Temperature was perfectly fine however.

    I can't say for sure if the contact with the water caused this, even though it most likely is, but this is the exact same problem as the rest are stating to have here.

    End of the line, I just had to send it in for a check and possible repairs.

    Hope any of this may help or give some clue to the others.
    domvella64 likes this.
  25. ton

    ton Lurker

    My problem starts again after few days:(

    My daughter also purchased a galaxy s2 and I tried her battery and the temperature warning and problems with usb was gone.
    Tried to change back to the old battery and the phone started up normally even with this battery. The problem recurred, however, later but was again fixed with her ​​battery. The only thing that will not be fixed is that the phone automatically starts directly when the battery is put in and you can not turn off the phone completely. It starts up automatically after it vibrated after shutdown.

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
Similar Threads - Spurious Battery Temperature
  1. mcknigs
  2. MoodyBlues
  3. codezer0
  4. kariolmax
  5. timroosendaal
  6. bbbl67
  7. DarkSideMilk
  8. Xx_Swaglord_xX
  9. XRN9S
  10. khaos526

Share This Page