1. Check out our companion app, Forums for Android! Download from Google Play

Support Spurious Battery Temperature Warning

Discussion in 'Android Devices' started by lotus49, Jul 18, 2011.

  1. Luinwethion

    Luinwethion New Member
    6

    Mar 16, 2010
    1
    1
    6
    Same problem here,

    One day I put my phone to charge, and after a few minutes, i heard the USB connection noise, well, I didn't care about it.... but when I looked at the phone, i saw the screen was on, with a clock screensaver I've never seen before, then i find out that the phone was in Dock Station mode, I thought it might be a software bug, so I restarted the phone but then the phone was in MTP / charging mode (without any cable attached).

    In MTP mode i couldn't do anything with the phone, it kept trying to sync.... after a few restarts, the phone was working again, but then i noticed that the phone was continually charging the battery (again without any cables), and the battery went from 100% to 15% in about 5 hours.

    The next day I tried to turn the phone off, and i saw the temperature warning, and after trying to update, putting new rom, etc... I brought the phone to the shop, and they sent it to Samsung..... after 3 weeks the phone was back, with a new battery.... but when I came home, I putted the battery and the phone went on by it self, and after that, all my problems are back, the phone keeps charging it self, it keeps in MTP mode, I can't turn the phone off, because if I do, I get the battery temp. warning or it goes on again.

    The Samsung service is very disappointing, i can't send my phone for another 3 weeks for reparation.... if they don't give me another new phone, I'll start a legal complaint against the phone shop and Samsung to get my money back, and i will buy another phone, no samsung for me anymore.
     

    Advertisement

    domvella64 likes this.
  2. capntrippy

    capntrippy New Member
    5

    Aug 19, 2011
    1
    0
    5
    ...Just had the same error on my few day old samsung galaxy s2.

    It occurred after the phone shut down whilst running a prime number generator to max out the cpu (actually it maxed out one core of it I think, processor usage was reported at about 47%).

    I was doing this to run out the last few percent of battery to properly condition it (run it out all the way and charge it to full a few times after purchase)

    On plugging it in to a usb port, it displayed a battery temp. warning icon. I left it for about ten mins, pulled out the usb lead, removed the battery, put it back in after a minute or so and powered on the phone (with the usb lead out). As soon as the 'samgsung galaxy sII' logo began to fade, I plugged the usb lead back in.

    No problems so far...
     
  3. Tinderbox (UK)

    Tinderbox (UK) Well-Known Member
    43

    May 29, 2010
    199
    34
    43
    England
    I set my S2 to charge and about 20 mins later i checked the battery level, and the back of the phone was very hot, 46c according to battery monitor widget pro, which i have had running since i bought my S2 , so i downloaded watchdog lite, and i found that webroot anti-virus was stuck using 48% of my cpu, and it was not a scan as that only takes a few second, it must have crashed or something, so i removed webroot and all is fine now.

    So it could be an dodgy app stressing your cpu and causing it to overheat as you are charging your battery more heat giving you the battery warning.

    So i will be leaving watchdog lite installed for now!
     
  4. Snazzy

    Snazzy Well-Known Member
    43

    Jan 13, 2010
    460
    37
    43
    The Samsung widget AP News Mobile is another application that will hog CPU and cause EXCESSIVE battery usage and download traffic, even if not used! The only solution for this nasty app is use Titantium to freeze it. It cannot be un-installed on a rooted device!
     
  5. tom.geypens

    tom.geypens Member
    5

    Jul 26, 2011
    5
    0
    5
    Is there someone who as found a solution for this??

    F.e. Does changing the battery fix the problem permanently?
     
  6. Devish46

    Devish46 New Member
    5

    Sep 8, 2011
    1
    0
    5
    Hi everyone... I am facing same problem as mentioned above .. Please can anyone tell me the solution for this.. Should changing the battery solve this problem or its a hardware fault.. Plz reply and help me
     
  7. medsol

    medsol New Member
    5

    Sep 11, 2011
    1
    0
    5
    I had the same problem. I took my phone to a Vodaphone store and they changed the battery. The phone started without any problems. I thought that phone was fixed. However the problem came back when I recharged the phone.

    A few days later the problem had gone away on its own. The phone works ok at the moment.
     
  8. shaunydub

    shaunydub Well-Known Member
    36

    Aug 23, 2009
    127
    8
    36
    Supply Planner
    Bournemouth, England
    I had this this morning - nearly *it myself at thought of phone being knackered.

    MTP started off just repeatedly starting up and scanning mem card etc - just looping the MTP Initialising comment.

    Then the battery temp came up and that really freaked me out - had me thinking KH3 firmware had done it.

    Searched online and found comments saying that some apps have been known to cause the MTP thing after updating and clearing cache can help.
    Only app updated literally 2 mins before this problem was QR reader which had installed itself to mem card.
    Uninstalled this app and no more problems ;).

    Don't know if it is conicidence or the cause of my problems but it's good now so I am sticking with it.
     
  9. colirv

    colirv Member
    5

    May 30, 2011
    9
    0
    5
    I've had this problem since yesterday, a few hours after I changed batteries (running in a spare). The new battery might just as well not be there - the phone is dead and plugging in the charger has no effect. The original battery, once inserted, causes the big battery icon/temperature warning most of the time. Occasionally it doesn't, but when I then start the phone the connection is odd (time and date, for example, don't update) and a single press on the side button turns the phone straight off rather than bring up the menu. We'll see what tomorrow brings.
     
  10. colirv

    colirv Member
    5

    May 30, 2011
    9
    0
    5
    Well I took the phone into the O2 shop yesterday. The tech guy played around a bit, eventually did a reset (I should have most stuff backed up) and the phone appeared to work normally. On switching off, however, we got the battery and temperature indicator. So O2 have sent the phone off to be repaired centrally, and I have a basic phone on loan in the meantime.
     
  11. stevomb

    stevomb New Member
    5

    Sep 16, 2011
    1
    0
    5
    The phone seems to work normal, but when turned off battery warning with thermometer icon flashing.
    My phone is also rooted.

    One weird thing I'm also experiencing is I can't turn off USB debugging mode.
    It says:USB is connected. Remove the cable.
    Maybe you have the same problem and it's related?

    BTW thanks for the workaround for starting the phone!

    I'm curious what the causes may be... :thinking:


    3 have just contacted me and saying that it is water damage in the usb port with a
     
  12. shaunydub

    shaunydub Well-Known Member
    36

    Aug 23, 2009
    127
    8
    36
    Supply Planner
    Bournemouth, England
    My phone seems to have fixed it self.
    I'm not rooted....had battery warning sunday, monday, tuesday and not had it since.
    Strange!
     
  13. r3dpuma

    r3dpuma Well-Known Member
    38

    Aug 27, 2010
    211
    13
    38
    Student, engineer
    Mangalia, Romania
    Same problem here...:(
     
  14. colirv

    colirv Member
    5

    May 30, 2011
    9
    0
    5
    O2 had my Galaxy for just a couple of days, then returned it on Friday with a letter that said they'd found a fault (they didn't say what) which they had repaired. It seems to be working fine.
     
  15. phatbear

    phatbear New Member
    5

    Sep 25, 2011
    1
    0
    5
    Experiencing the same symptoms, symbols of battery charging when "off" with no cables connected. Battery Temp fault on startup. MTP displayed when running.

    Problem masked when external USB cable connected attached to PC.
    Problem persists when external USB cable connected, no PC.

    To me this can't be a software issue. I would guess that something in the USB interface is shorting or has gone open circuit?

    I had unknowing connected left my device on charge overnight on my PC's USB3 port prior to this occurring, however this *should* have no effect.
     
  16. shaunydub

    shaunydub Well-Known Member
    36

    Aug 23, 2009
    127
    8
    36
    Supply Planner
    Bournemouth, England
    I have noticed that the MTP things always starts when battery reaches 93% - nothing I can do to stop it, tried task manager killed all apps, cleared ram and rebooted - it just carries on waking up and initailising MTP every bloody day.

    Eventually it just stops doing it by which time Battery is approx 80%.
    I have no idea what is causing this or how to stop it.

    Additional info -
    Also noticed that when the MTP things starts messing up it resets the "time on battery" to zero.

    I charged by wall last night, unplugged at 7am and just noticed time on battery is currently 9hr24m which ties up to when I had the MTP issue this morning.
     
  17. jellon

    jellon New Member
    5

    Oct 7, 2011
    1
    0
    5
    Yes I had similar issue...
    Phone stopped charging via charger, so tried new charger same issue then decided the USB connection may have been damaged when phone got pulled to floor by charger cable so sent off for new USB connector (
     
  18. Twinn

    Twinn Well-Known Member
    113

    Jul 24, 2011
    820
    261
    113
    Male
    Ireland
    Just to remind that if anyone wants to do battery calibration, needs to be rooted.
     
  19. drutger

    drutger New Member
    5

    Oct 9, 2011
    1
    0
    5
    Dropped my usb cable in the coffe, didnt dry it properly and then put it in my phone. Stupidly. After that i got the same prob as you guys
     
  20. adetogni

    adetogni New Member
    5

    Oct 20, 2011
    1
    0
    5
    Hi
    I have the same problem. It presented a weeks ago and then it went away.
    But yesterday the phone got a little wet with some drops of water (and coincidentally, as far as I remember, was the same thing happened the first time) and now I have it again.

    I think that there is an hardware issue in the Usb port: it's probably very delicate and just some humidity or water short circuit it and makes all the mess.

    I can confirm that it's not a battery issue, because I tried with two different batteries. And I can confirm that you can't switch on or off the "Usb debugging" mode, and that's a clear indication of the USB hw problem.

    I'm going to send to assistance today. Unfortunately.
     
  21. pukenukem

    pukenukem New Member
    5

    Oct 21, 2011
    2
    0
    5
    I'm also getting the same problems on my phone, started happening about 1 week ago. Was on charge over night, the following morning driving to work I noticed the phone beeping as if going on charge. Following this I get all the same issues as above, including the battery overheat issue. When this happens I cant turn the phone back on unless it is on charge.

    Couple of things I've noticed, I get a over voltage error when charging, the issues only occur when the battery is 60-100% charged, once it drops below this all is well.

    I will be taking it back to the shop next week, moving back to my iphone while it gets sorted.
     
  22. pogostick76

    pogostick76 New Member
    5

    Oct 21, 2011
    1
    0
    5
    I had used 23hrs of standby and my phone gave be that auditory bleep that I had a low battery. then turned off. I plugged it in and kept talking then after a few mins the call was hung up on and I got the termerature alarm.
    I unplugged the phone the battery and let it cool.

    After it was cool I plugged it all back in and recharged the phone and then was able to use it.

    What happens when the phone has low battery the phone battery generates more heat to squeeze more talk time out of the battery. This generates more heat. The battery is not as efficient when the lower meter reads low.

    Always use a headset, its healthier, and keep the phone plugged in for long calls. your battery will last longer and you will not get the temperature alarm.

    Infact having a temperature alarm is brilliant because it means this phone is very sophisticated and know how to protect itself.

    The battery cools off very quickly and you can use your phone again.
     
  23. colirv

    colirv Member
    5

    May 30, 2011
    9
    0
    5
    If only it was that simple for everyone. :)
     
  24. callme307

    callme307 New Member
    5

    Jun 3, 2011
    1
    0
    5
    HI everyone, I also seem to have your problem too. I got my Galaxy S2 about 5 months ago. It was working fine but when i woke up whilst it was charging, it showed the battery temp. warning. I turned the phone on and checked using a battery monitor, it was showing normal temperature.
    Then, at the end of the day when the battery bar was empty, I tried to charge it except the charging sound wouldn't sound and it wouldn't charge. I turned the phone off and it just turned itself back on. I tried to plug the computer USB cable in but it wouldn't charge or go into MTP mode.
    I turned the phone off with the USB cable attached and it turned itself on, but now it charges... But when I unplug it, in the notification bar, it says USB host connector connected.
    I heard something about warranty for the battery being 6 months. I'll just take it to o2.
    Anyone any idea why?
     
  25. andycorps

    andycorps New Member
    6

    Oct 27, 2011
    3
    3
    6
    I've got the same issue with mine. I think it started occurring after I updated the ROM on it without the battery being at 100%. But these are my symptoms;
    Symptoms;

    When switched off and without a USB lead connected the phone display alternates between a battery level indicator (as if charging) and a temperature warning.
    Plug a USB lead in to get past this and boot the phone normally

    When switched on and you've received a 100% charged notification, rebooting the phone and checking the battery level again, shows the battery hasn't charged to 100%.
    I'm trying to force mine up to 100% by rebooting every time it stops charging to charge it a bit more. This might get it over the hurdle eventually...

    With no lead plugged in, trying to disable USB debugging mode (settings>applications>development) gives the error: "USB is connected. Remove the cable"
    I've got no fix for this yet, except maybe flashing a clean ROM onto the device with the debugging mode already disabled

    Thanks to a previous post in this thread, I'm monitoring the battery with Battery Monitor Widget (https://market.android.com/details?id=ccc71.bmw&hl=en) and have noticed the battery level jump sporadically up or down as if there is some kind of hardware monitor that doesn't correspond with the firmware monitor??? maybe??? (clutching at straws)
     

Share This Page

Loading...