1. Are you ready for the Galaxy S20? Here is everything we know so far!

StartingAlertService Wakelock

Discussion in 'Android Devices' started by parag1dubey, Dec 19, 2012.

  1. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Here I am with another wakelock :( My GS2 seems to be pulling new ones out of a hat lately. StartingAlertService wakelock has been plaguing me since yesterday. It is now at the dubious No.1 position in Partial Wakelocks. I did some googling and found that it is related to the calendar. I proceeded to freeze the splanner and anything related to calendar in Titanium Backup. Surprisingly, the wakelock was still there. I removed my battery and reinserted after 4-5 minutes. Same result. Then I restored Splanner and all calendar related apps from Tbackup. I then wiped data of all the calendar apps including splanner, removed the battery again and reinserted. This time, the wakelock vanished! But lo and behold, after an hour there it was again, sucking my battery shamelessly as i looked on in morbid fascination. :thinking: I noticed that Hawker had faced this same wakelock in his gingerbread days but there is no solution in that thread. SO, I once again invoke your guidance, Hawker and Ironass.... As of now, this thing has kept my phone awake for 1hr 51minutes out of 3 hrs and 45 minutes since boot..... Not good..
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Hawker

    Hawker Android Expert

    I think this only kicks in for events with reminders set against them
    1. do you NEED the reminders
    2. do you have calendar set to auto-sync?
     
    parag1dubey likes this.
  3. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    I did have events in the calendar (with reminders), but once i wiped the data of splanner, those events were deleted and so were the reminders. And yet, the wakelock persists. :(
     
  4. Hawker

    Hawker Android Expert

    Do you have your calendar set to auto sync? I've not had this wakelock since gb days, when I never had the auto sync option set. Since ics I've always set this option and not had it since, jb leak included.
     
  5. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    No Hawker, the calendar is NOT set to auto sync.. Only gmail is set to auto sync. The wakelock is still persistent..
     
  6. Hawker

    Hawker Android Expert

    well then, there you go.
     
  7. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Ironass, i would appreciate it if you would contribute here... That wakelock is stubbornly persistent :(
     
  8. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Do you mean I must set it to auto sync hawker??
     
  9. Hawker

    Hawker Android Expert

    I shall requote my last but one post and let you decide.
    :banghead:



    Set it, reboot and see how it goes.
    Worth a pop
     
    parag1dubey likes this.
  10. ironass

    ironass Extreme Android User

    Don't drag me into this one parag1dubey... I've run out of aspirins as it is!

    Besides, I'm having my own Dumbass Day today with Hawker! :banghead:

    See, here.
     
  11. parag1dubey

    parag1dubey Android Enthusiast
    Thread Starter

    Ha Ha :D This is a screenshot of BBS. Even after ticking the autosync option for calendar, the ruddy thing is still here.
     

    Attached Files:

  12. Hawker

    Hawker Android Expert

    I think there is a problem on your calendar, be it on the handset, or google side.
    it may be an idea to export your calendar events on google then delete them all. then let the handset resync (to no events) and then import on google

    if this fails after the events have re-synced, then it could well be a single event on your calendar that is making it trip over.

    [​IMG]
     
    parag1dubey likes this.

Samsung Galaxy S2 Forum

The Samsung Galaxy S2 release date was April 2011. Features and Specs include a 4.3" inch screen, 8MP camera, 1GB RAM, Exynos 4210 Dual processor, and 1650mAh battery.

April 2011
Release Date
0
Reviews

Share This Page

Loading...