1. Are you ready for the Galaxy S20? Here is everything we know so far!

stock accuweather widget stopped working on wifi

Discussion in 'Android Devices' started by jaliy, Dec 21, 2013.

  1. jaliy

    jaliy Android Expert
    Thread Starter

    does the stock app receive software update like other apps?
    2 days ago the accuweather widget stopped updating, even manually refreshing didn't work.

    i tried to clear cache/data and reboot the phone didn't work. however, i found out it works when i'm off wifi and on data network. so i figured it might be something going on with the router. i rebooted the router and it worked.

    this was happening on both s2 and s4, with the stock accuweather widget. i don't think my router had a problem since all connection was working. did any recent update to this widget messed up the connection?

    1. Download the Forums for Android™ app!


  2. jaliy

    jaliy Android Expert
    Thread Starter

    is this forum dead or nobody cares anymore
  3. Rukbat

    Rukbat Extreme Android User

    Nothing you (or the author) can do to the widget can determine whether your router can get data from Accuweather, and nothing you can do to the router can affect the widget.

    What I suspect (and this is a wild guess*) is that the Accuweather widget uses Accuweather's canonical address (the human readable address, like accuweather.com). The router gets that request from the phone and asks the DNS server it's using (probably your internet provider's) for the numeric address for that canonical name ( is accuweather's). Canonical names are just for us stupid humans, who can't remember a few thousand strings of numerical addresses.

    If the router loses the DNS server's address (or, more likely, since so many kids who have too much time on their hands know more than is good for them, someone poisoned [basically changed] the address in that server), any app that uses a numerical address - since it already has the numerical address, it won't ask for it - gets to the server it needs and everything works. But an app that uses a canonical address gets the wrong numeric address, doesn't get the data it needs and, rather than telling you that the temperature is "a left turn at Broadway", it doesn't change anything on the screen.

    *The reason I said "wild guess" is that if, when you're having this problem (and you're absolutely certain that you're connected to YOUR router, not to a neighbor's wifi signal) you can open your browser and get to a website by name (like androidforums.com - I usually use aol.com because it's easier to type and because I can't remember the last time they were down long enough to get dropped from the DNS system - then that may or may not be the problem.

    But a) rebooting the router may get a different DNS server, if your ISP uses a few, your router's DNS cache may have gotten poisoned or courrupted, and rebooting fixes that and b) your phone's data connection uses your phone company's DNS server, so a wifi DNS problem won't show up on your data connection.

    Next time it happens, check your wifi connection - make sure it's still yours. (If not, fix that, tap the widget and it should open the app with the current conditions, and also update the widget.)

    If it is, connect (on a laptop or desktop) to accuweather.com and see if they're down. (It could snow in July in Miami too.) If not, go to AccuWeather.com - Contact Us, tell them what's happening (there's a contact form) and ask whether it could be a DNS problem - IOW, are they going by a canonical address, so you should contact your ISP when it happens, or are they using a numerical address.

    If they're using a canonical address, ask if you could get the exact one, so your ISP can check for poisoning. Their tech people will understand what that means. They'll probably give you an address - accuweather.com/<something here> or something like that.

    Then, when it happens, call your internet provider's tech support number (hope it's better than mine - I reamed them about a dozen new ones this afternoon [I TOLD YOU the location of the store, I asked you for its PHONE NUMBER (which isn't listed on your site), so don't give me a list of the addresses of all your local stores - without phone numbers]), explain the situation and tell them that the particular address - and you have it - may have gotten clobbered in their DNS servers, and could they check it. If they're any good, they'll take the address from you, verify that it's poisoned and fix it up. (If they're like mine, they'll pretend to understand, tell you that they'll get it fixed, then go for coffee. Unfortunately, there aren't too many choices around here, and the "other" cable company has a yearly budget that I blow at Walmart for groceries.)

    (Just had another thought. If the router is really getting old, you might want to think about replacing it. The DNS cache could be getting corrupted just due to things in the router breaking down. My main router is new (the old one finally gave it up after about 10 years), but the spare one is 12 years old and still works [even after being left out in the woods one winter - looks like a mess, but works]. When the main one went, I used the spare for a couple of days, until I had time to go out and buy a new one. Wifi was a bit slow, but internet cold turkey? I think the internet is more addicting than cocaine. And the house phone is VoIP, so I need internet.)
    ironass and Hawker like this.
  4. jaliy

    jaliy Android Expert
    Thread Starter

    took me 30 min to digest all that
    i don't think there's anything wrong with the router it's only a month old and it's asus router
  5. Hawker

    Hawker Android Expert

    After all the time and effort rukbat gave up in an attempt to assist you, I think a small word of thanks wouldn't have gone amiss.

    You mention software update in your post but I assume we are talking about the weather widget updating its content and not updating the widget software itself (this is done in firmware updates)

    Strange your weather only seems to refresh on data connection and not wifi. Mine does both. I have mine set to refresh every 3 hours and auto refresh on open.

    Occasionally my weather didn't update but after a manual attempt a few hours later it did so I put this down to a problem at the weather site end. Perhaps your problem is a similar issue.

    You say manual attempts fail, so does the refresh icon spin during the attempt? My guess is it does so it's not the software but a connection issue. When it fails disconnect wifi immediately and try again. If this works then it's your router that is at fault, more specifically, its DNS.

    If you can't get to the bottom of it, it may be worth trying a 3rd party weather widget to see if this works better for you (eg. Fancy widgets)
    jaliy and ironass like this.
  6. ironass

    ironass Extreme Android User

    I have always used a third party launcher, Nova or APEX, and a third party time and weather widget, Fancy widgets, and it might be worth while trying a third party widget yourself to see if the problem persists.

    I think we can discount the phone itself as it has occurred on both your S2 and S4. See...

    accuweather doesn't auto refresh

    We can also, for the same reason, discount the firmware platform as this problem you are experiencing appears to apply to multiple phones, firmwares and operating systems.

    That leaves us with two possibilities...

    1. The Accuweather widget itself, spanning two different handsets and numerous firmware versions. This seems unlikely as there would be some very long threads on these forums, and others, regarding the problem and the fact that no-one replied to your original post would indicate that this is not a, "feature", of the Accuweather widget that all owners are experiencing, worldwide.

    2. That really only leaves you with your Wi-Fi connection which you appear to have had problems with in the past...

    wifi takes a while to connect in sleep mode?

    annoying wifi issue

    Therefore, on the balance of probability, the issue is with your Wi-Fi router as per Rukbat and Hawker's excellent posts, which I believe deserve some thanks.

    You could try getting something like a cheapo Belkin router for around
    jaliy and Hawker like this.
  7. jaliy

    jaliy Android Expert
    Thread Starter

    So how is it possible that all othet apps work on the same router but not the weather app?

    if it's in deed a dns issue how do I avoid it
  8. Hawker

    Hawker Android Expert

    Try configuring another dns server into it and see what happens.

    Also take a good look at your routers firewall settings. It may have an incoming block rule that happens to be blocking packets from the weather app server.
    ironass and jaliy like this.
  9. jaliy

    jaliy Android Expert
    Thread Starter

    i simply did a reboot of the router and that fixed it
    and, i mentioned it was working until 3 days ago, and i haven't touched my router setting for 2 months. if firewall was acting up, it should happen a lot sooner than that
    i checked the actual accuweather app in play store, it was last updated dec 17, which was around the time my stock widget stopped updating
  10. Hawker

    Hawker Android Expert

    Have you rebooted since the update?
    Did you download the accuweather app from the play store previously? If not and you're using the version that came with the firmware then I don't think it would have updated itself. I've never received an update for this, as its a system app for me. I believe the one on the play store is entirely different to the one that comes bundled with TW roms.

    If it's not been working since the update then it is indeed suspicious, so perhaps it's using a different sever to host its updates now, but if it then immediately works when wifi is switched off, then it does point the finger towards your router.
    Do you have another wifi to connect to (eg. Work) to test? This would prove it beyond doubt.
    ironass and jaliy like this.
  11. jaliy

    jaliy Android Expert
    Thread Starter

    cutting off wifi did not work as i tried to reboot the phone to get it to work
    and no i never used the real accuweather app, tried it 2 yeears ago didnt like it
    it was working on tether mode off my other phone
  12. Hawker

    Hawker Android Expert

    I thought you said it worked when not connected to wifi? So now you're saying it is not?

    So you're not on the accuweather app from the play store so you can rule out that update on the 17th. Perhaps there has been a server change. Its been working great for me though.
    Do you know anyone else in your town who owns an s4 with this weather widget to see if it's a common problem specific to your area/carrier?

    To me from what you're now telling me it's looking more and more likely to be a problem with the app. Perhaps there is about too much traffic on their severs and they cannot cope with the refresh requests.

    I would give an alternative weather app a go just to see if it works. Fancy widgets, as I already mentioned, is very good.
    ironass and jaliy like this.
  13. jaliy

    jaliy Android Expert
    Thread Starter

    it was not working on my home wifi, but when i turn on s2 data and had s4 tether off the s2 it worked since i'm really on data still

    i googled this issue seems like many others have the same problem at different times of the year. it's been working great for me too just until the hiccup 3 days ago. maybe the accuweather app update changed the server for all accuweather related apps/widget?
  14. Hawker

    Hawker Android Expert

    Reread my previous post. I edited it whilst you made your post
    ironass and jaliy like this.
  15. jaliy

    jaliy Android Expert
    Thread Starter

    ok you say the problem is with the widget itself. how come on 3g data it works but not wifi? if the server is too busy i shouldn't be able to refresh on any connection
  16. Hawker

    Hawker Android Expert

    You're confusing me now. You said in your above post that you cut off wifi and it still didn't work, thereby implying it isn't working over data.

    So now you say it is?

    Try another app and/or router gain then
    ironass likes this.
  17. jaliy

    jaliy Android Expert
    Thread Starter

    i said the wifi from my home router is not working, i don't know aobut other routers. data=3g mobile data, and that works
  18. Hawker

    Hawker Android Expert

    Ok then, so do as I suggested and try on another router if possible (eg work, or an open network somewhere) so we can rule in or out if your router is at fault or not. So far it does seem to be router related.

    Give it a go. If you can't, then try an alternative app for the time being and see if this refreshes.
    ironass likes this.
  19. jaliy

    jaliy Android Expert
    Thread Starter

    let's say if my router is at fault, is this avoidable? i understand if the server changed then the router has to be rebooted to clear the cache but it doen'st happen all the time, like once every 6 months or so. you probably had that happen to you but you just didn't realize it
  20. Hawker

    Hawker Android Expert

    Only one way to really find out for certain. Try on another router and if this works then we know we need to focus on your router eg. Alternate DNS
  21. jaliy

    jaliy Android Expert
    Thread Starter

    does this happen often? corrupt dns
  22. Hawker

    Hawker Android Expert

    It wouldn't be a corrupt dns as such. Your router doesn't have a dns database to corrupt in the first place. Your routers dns is simply an address (or addresses) to a dns server on the internet. Its this server that resolves all your ip requests that go through your router. So there could be an issue with the dns server that your individual router has been configured to use. Configuring another dns server into your router could solve the problem.This is one possibility to the problem you're having, as is your routers firewall. Finding another router to go through will tell us for sure.
    jaliy likes this.
  23. jaliy

    jaliy Android Expert
    Thread Starter

    so the server dns changed and yet my router did not? i mean the dns given from my isp
  24. Hawker

    Hawker Android Expert

    Who knows? I certainly can't say if it did or not. Its a possibility, and only that.

    Your dns isn't supplied directly by your isp. Its configured into your router so unless you got it directly from your isp it will have been preset by the manufacturer, either directly or possibly when/if you ran through a router installation wizard.

    like I said, try configuring another dns server to know for sure. Better still connect to another wifi
  25. jaliy

    jaliy Android Expert
    Thread Starter

    anyway so far we can rule out the following:

    the phone is working cause both s2 and s4 have problems
    the widget is working cause 3g works
    the problem is the router, not sure which part of it yet

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date

Share This Page