Help Stock notifications versus custom text tones?


Hi, all-- Smartphone newbie here with many a question, but I'll try to be brief for my first cry for help!

I'm trying to set a custom text tone for my text messages. I used messages>menu>settings>notifications>Recieved Message Notification Sound to choose my custom text tone from my SD card.

However, now when I get a text, it STARTS to play my custom text tone, but then stops abruptly and plays my stock notification sound (from my menu>settings>sound>notification sound).

It just started doing this in the past couple of days, and while I've been tinkering with my phone settings, I can't for the life of me figure out how to get the stock notification sound from NOT playing whenever I'm texted and just play the custom text tone that I selected in Messages.

Any help with how to fix this? I read on some other Android phones that you can disable the stock notification sound? But that's not what I'm looking to do-- I'd still like it to play for gmail notifications for example. Plus I don't even see how you would go about disabling the stock notification sound completely anyway on the Normal profile. Siiiiiiiiiiiiigh. I TRIED to be brief... :eek:


Thread starter
Okay, I think I figured it out... For some reason, my Stock Notifications wasn't reacting well with my Stock Messaging Notifications, but Stock Notifications works totally fine (no doubling) when I assign it something standard, disable the Stock Messaging Notification, and use Ringo Lite to assign ringtones/text tones.

Weird. We'll see if this continues to go smoothly or not! :)