1. Are you ready for the Galaxy S20? Here is everything we know so far!

Support Stop HTC Desire Z '50' SMS

Discussion in 'Android Devices' started by ttinjust96, Feb 18, 2011.

  1. ttinjust96

    ttinjust96 Lurker
    Thread Starter

    Since switching my AU Virgin sim from my old phone to my new HTC Desire Z, I keep receiving SMS location messages. When I am on the bus moving from suburb to suburb, I constantly receive messages from '50' with the text 'suburb'. Is there a setting in the phone that I can change to stop this?
     

    Advertisement

  2. Slug

    Slug Check six!
    VIP Member

    Go to Settings/Call and ensure Cell broadcast is unchecked.
     
    jonesyg and mirfromoz like this.
  3. dezgo

    dezgo Lurker

    Did you solve this? I have the exact same issue on my new HTC Desire HD, very annoying. I've tried switching off GPS and cellular data networks to get location, but I still get them. It's pretty weird / dodgy that even when I have all location tracking turned off, I still get message telling me where I am.... how does it know?!
     
  4. martindurin

    martindurin Lurker

    I've got the same problem. Mine Location SMSs from 50 started after updating the system to a newer version on 8th of December (very cool update btw). But regarding to the age of your comments, it seems that the update doesn't seem to have a lot to do about it. Did you solve it? It is extremely annoying!
     
  5. dezgo

    dezgo Lurker

    It's been a while and I certainly no longer get those messages. I've since done a factory reset on it, I can't remember if it was gone before that as I did it for other reasons, but if not I'm sure that would have sorted it.
     
    martindurin likes this.
  6. martindurin

    martindurin Lurker

    Okay, I should try it too.
    Factory reset deletes all data (including apps)?

    Thank you for advice
     
  7. dezgo

    dezgo Lurker

    Yep everything, so make sure you have a backup first so you can restore stuff if required.
     
  8. mirfromoz

    mirfromoz Lurker

    Slug's reply was the perfect fix!

    "Go to Settings/Call and ensure Cell broadcast is unchecked."

    Thanks, that was too easy!
     
Loading...
Tags:

Share This Page

Loading...