1. Download our Official Android App: Forums for Android!

Support Straight talk APN ATT help!

Discussion in 'Android Devices' started by Amaeloeze, Nov 20, 2012.

  1. Amaeloeze

    Amaeloeze Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    131
    Joined:
    Aug 25, 2011

    Aug 25, 2011
    131
    5
    36
    I'm not able to use any data on my nexus 4 because my apn is not set up. I don't know how to set it up i've been looking and trying things but nothing is working can someone please help?! thanks
     

    Advertisement

  2. Rcarnes91

    Rcarnes91 Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    306
    Joined:
    Mar 7, 2012

    Mar 7, 2012
    306
    32
    43
  3. kismetgeek

    kismetgeek Member
    Rank:
    None
    Points:
    16
    Posts:
    69
    Joined:
    Jun 26, 2010

    Jun 26, 2010
    69
    9
    16
    That poster was incorrect about needing two different settings. your phone can only use one at a time.


    follow this guide:
    How to set up the right APN on your Nexus 4 | Android Central

    except leave the proxy field blank. You don't need it, and it will probably slow you down slightly.

    it's that simple, just those 5 or 6 settings in the APN, reboot, then you're ready to go.
     
  4. danielunde

    danielunde Android Enthusiast
    Rank:
    None
    Points:
    56
    Posts:
    328
    Joined:
    Dec 4, 2011

    Dec 4, 2011
    328
    7
    56
    Male
    GA.
    What about the Galaxy S3 APN? Would it be the same?
     
  5. jhawkkw

    jhawkkw Chinchillin'
    Rank:
    None
    Points:
    1,333
    Posts:
    10,634
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    10,634
    7,397
    1,333
    Washington, DC
    Yes, APN settings should be the same across devices.
     
    danielunde likes this.
  6. danielunde

    danielunde Android Enthusiast
    Rank:
    None
    Points:
    56
    Posts:
    328
    Joined:
    Dec 4, 2011

    Dec 4, 2011
    328
    7
    56
    Male
    GA.
    What about if they are unlocked S3 and S4?
     
  7. jhawkkw

    jhawkkw Chinchillin'
    Rank:
    None
    Points:
    1,333
    Posts:
    10,634
    Joined:
    Jul 30, 2011

    Jul 30, 2011
    10,634
    7,397
    1,333
    Washington, DC
    Shouldn't be a problem. APN settings for ST are mainly used so the phone knows the address of where to pull data and MMS from. Shouldn't matter which phone is used.
     
  8. SlyFerret

    SlyFerret Android Enthusiast
    Rank:
    None
    Points:
    43
    Posts:
    395
    Joined:
    Dec 1, 2009

    Dec 1, 2009
    395
    25
    43
    This is what I have configured on my and my wife's nexus 4 handsets. MMS has been working for us.

    # Straight Talk #
    Name: Straight Talk
    APN: att.mvno
    MMSC: http://mmsc.cingular.com
    MMS proxy: 66.209.11.33
    MCC: 310
    MNC: 410
    APN Type: default,supl,mms
    Protocol: IPv4
    Roam Prot: IPv4


    -SF
     
  9. ritchea

    ritchea Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    134
    Joined:
    Nov 2, 2010

    Nov 2, 2010
    134
    34
    43
    south central Florida
    Because ST APN's seem to be fickle, especially with MMS, I've included what works for me. This DOESN'T mean the above settings won't work so try them first. I believe the numbers 66.209.11.33 = mms2.tracfone.com. I do not know if the port is necessary, but I have it. Note that :80 after the proxy numbers will work. I added the "hipri" when I was having problems with mms. It could be coincidental that mms started working after that. When I am on wifi, I usually have to turn it off for mms to send.
     
  10. smacdow

    smacdow Lurker
    Rank:
    None
    Points:
    25
    Posts:
    2
    Joined:
    Jun 13, 2013

    Jun 13, 2013
    2
    0
    25
    I just set up my Nexus 4 using the info from the straight talk sim support page:

    (go to this link and click on "Phone Programming")


    1. CREATE A NEW APN (ACCESS POINT NAME). ENTER ONLY THE SETTINGS LISTED BELOW:

    FIELD SETTINGS

    NAME: straight talk

    APN: tfdata

    PORT: 80

    MMSC: http://mms-tf.net

    MMS PROXY: mms3.tracfone.com

    MMS PORT: 80


    2. SELECT THE APN YOU JUST CREATED.

    3. DELETE THE OLD APN FROM YOUR PHONE IF POSSIBLE.

    It is working perfectly on my phone.
     
  11. john30308

    john30308 Well-Known Member
    Rank:
    None
    Points:
    43
    Posts:
    239
    Joined:
    Dec 3, 2009

    Dec 3, 2009
    239
    33
    43
    Ditto above. Been working for months no problem.
     
  12. Dmowry

    Dmowry Member
    Rank:
    None
    Points:
    15
    Posts:
    32
    Joined:
    Jan 3, 2012

    Jan 3, 2012
    32
    0
    15
    Just tried these settings today twice and was never able to get then to work. Back to the original att.mvno settings.
     
Tags:

Share This Page

Loading...