1. Are you ready for the Galaxy S20? Here is everything we know so far!

Strange behavior

Discussion in 'Android Devices' started by timbuk2, May 19, 2011.

  1. timbuk2

    timbuk2 Well-Known Member
    Thread Starter

    My Captivate seems to be going hay wire. I'm using Froyo 2.2, AT&T and things have been great. Today, when I get into Settings Menu, or Address Book or seemingly anywhere else I can't get out, go back or do anything. I have removed the battery, rebooted etc. It was a refurbished unit, so I think I'm out of warranty, $125 Deductible on Insurance.... so options are few.

    I'm familiar with another non smart-phone that has done this, but never heard of the cure.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. DaNaRkI

    DaNaRkI Member

    So then your saying the soft-touch buttons at the bottom of the screen are not working?
     
  3. timbuk2

    timbuk2 Well-Known Member
    Thread Starter

    That's correct. I tried all the resets, even on the phone with AT&T, didn't realize it was under 90 day warranty so they're replacing it. We have another one that was purchased new that has worked great for about a year now but the refurbished one konked out.
     
  4. DaNaRkI

    DaNaRkI Member

    Good to hear that you could get it replaced easily. Sadly theses phones still suffer greatly from quality control issues...

    But yeah, your only options would have been replace the whole phone/send in for repairs or to take the phone apart and swap out some parts.
     

Samsung Captivate Forum

The Samsung Captivate release date was July 2010. Features and Specs include a 4.0" inch screen, 5MP camera, 512GB RAM, Hummingbird processor, and 1500mAh battery.

July 2010
Release Date
0
Reviews
Loading...

Share This Page

Loading...