1. Download our Official Android App: Forums for Android!

Root strange root/cm11 issues

Discussion in 'Android Devices' started by BradTheGeek, Dec 27, 2013.

  1. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    I used wigs nexus root toolkit on my n7. With it I unlocked the boot loader, rooted, and installed a recovery. I believe I have a nandroid of this point.
    A little later, I wanted to test ART runtime, so I got the CM 11 nightly. I could not boot to recovery, I just got the android guy with the warning triangle in his guts.

    So, I went to the root toolkit and it was able to boot my tab to recovery. I never got around to asking about it, but that was weird thing one.

    Since I could get to recovery now , I flashed the nightly and gapps. No problems. With art activated there were some crashes and incompatible apps, so I returned to dalvik.

    Now, the next issue. CM11 has been fine, and until today I don't think I used any root required apps. Today I installed titanium backup to move an app and data from a phone over.

    The first launch of titanium said I had incomplete root. I tried to restore the desired app and it crashed. The second launch said I had root, but supersu was better. It crashed on restore again. I installed supersu, opened it, granted it root from the existing su, installed the binaries, and rebooted. Now I have no root at all!

    Any pointer or advice are welcomed. Since I don't need art yet, I may return to rooted stock,but that still won't fix the recovery issue. Thanks!
     

    Advertisement

  2. argedion

    argedion The TechnoFrog
    Rank:
    None
    Points:
    953
    Posts:
    6,360
    Joined:
    Jun 20, 2011

    Jun 20, 2011
    6,360
    6,294
    953
    The Infernal Swamp
    Sounds like to me you have the default recovery. On the N7 can you boot into the recovery you installed?

    I manually rooted my device so I don't know about this Wugs stuff. A lot of people swear by it though. I have Linux so Wugs doesn't work for me anyway :rolleyes:

    What recovery did you install?
     
  3. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    I flashed TWRP from the toolkit.
     
  4. WoohooGuy

    WoohooGuy Android Enthusiast
    Rank:
    None
    Points:
    118
    Posts:
    460
    Joined:
    Dec 15, 2011

    Dec 15, 2011
    460
    288
    118
    Male
    woodworking
    boston ma
    After installing the binaries for SuperSu, did you try to reinstall it from the play store as suggested by the prompts before you rebooted?

    You kinda have a perfect storm of instability going on right now.

    ART is experimental on the nexus 7 and you are using a nightly build rom that introduces too many other variables as well.

    How did you flash CM 11, did you use TWRP recovery flashing a downloaded image, NRT with a downloaded image, or other? You didnt try the CM installer on a rooted modified device, did you?

    What was the status, android build, and recovery you were running before you went to the CM11 nightly?

    When you finally were able to get back into recovery and flash the nightly package, it was TWRP you used to flash it and the gapps package?

    Once the tab was running again did you immediately enable ART and then install apps or did you install apps and then enable ART?

    Once you returned to Dalvik did you uninstall the apps that were having issues and reinstall to test again?

    Titanium is having issues with ART on 4.4, while they have added support it is no where near what anyone would deem reliable right now.

    Using a nightly based rom you have to expect you will have issues and totally crash and burn on occasion so it's not for the faint of heart. You can go to bed one night with everything shitting unicorns and rainbows, have a new nightly installed in the AM, and then be android belly up by lunch. It happens, its the nightly.

    That said you need to isolate your issues to what you are willing to tolerate.

    Using a nightly rom where you already toggled experimental ART and a Dalvik return is already asking for a lot of trouble before even using an app that has known issues with ART to begin with!

    If you want to try and salvage what you have, flash the SuperSu zip from Chainfire's official download page -
    SuperSU Download

    If you want to be on the cutting edge of nightly's, especially for the nexus devices, then you should consider using ClockworkMod Recovery -
    CyanogenMod 11.0 M1
     
  5. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    I am using the tab to type this, which makes it tricky to see your big post and respond to all the questions in order, so instead, I will edit this post as soon as I get to my PC.

    No, I did not reinstall SuperSu, it did not ask. I installed from the store, then launched, it asked for root privs from su, pushed the new binaries then suggested a reboot (which I did).

    I flashed CM11 with TWRP and a downloaded image. (I was only able to boot to TWRP using Wug's toolkit.)

    Prior to flashing the nightly, I was rooted, with the flaky TWRB (only bootable from wug), running stock 4.4. I do not know which build, and come to think of it, there may be a secondary issue here. I allowed my tab to update to 4.4 before rooting, but there was another small 4.4 update (30 mb or so), and I cannot remember if I pushed that in before or after rooting. Perhaps that is what started breaking root. It is hard to remember because I was also pushing stock updates on my girlfirend's N7 at the same time.

    As stated before it was TWRP recovery, booted from Wugs toolkit (I am sure it sent some adb or fastboot commands to get there).

    I ran for a while on Dalvik, installed some apps, then I siwtched to ART. The reboot took a while (assuming it was compiling all the apps as it said optomizing app xxx of xxx). Gapps would then occasionally crash and recover (esp when launching chrome), and one or two non essential apps would not run. After a week or so, I switched to dalvik, rebooted, the apps reoptomized and all ran normally as it did on stock and pre-ART. No apps had issues after that.

    I just tried the supersu zip, but I got a bad copy, need to do it again.
    Given the fact that ART did not offer me really noticeable performance increases on this device (it did on one of my phones!), and that it is still beta, I will likely switch back to stock ROM (not to mention that on a political level I am not very happy with CM right now, but that has no technical implications).

    My biggest concern is the weirdly broken recovery, and that was from before CM11.

    As a side note, the steps I followed for Wugs toolkit had me remove all other android/adb drivers using device manager and a nirsoft tool that was included with the kit, prior to installing the N7 drivers. I understand the reasoning behind this, but it WILL break comms with other devices, and the drivers won't auto reinstall. So you will lose MTP/ADB access to other phones/tabs from the machine you use the toolkit on if you do this. Just wanted to warn you.
     
  6. WoohooGuy

    WoohooGuy Android Enthusiast
    Rank:
    None
    Points:
    118
    Posts:
    460
    Joined:
    Dec 15, 2011

    Dec 15, 2011
    460
    288
    118
    Male
    woodworking
    boston ma
    You can flash clockwork recovery using NRT and try CM11 again if you so desire.

    You can also run stock and use multirom to dual boot your N7.
    [MOD][DEC 24] MultiROM v19 - xda-developers

    Get your tablet back to stock, then flash the multirom modified TWRP in NRT (advanced utilities)

    Then flash the multirom package and modified kernel for stock.

    You can now select what ROM you want to run at boot, if you do nothing multirom will automatically boot to your stock ROM.

    If you want to add roms you just load them via the multirom option in TWRP.

    You can also use the multirom app https://play.google.com/store/apps/details?id=com.tassadar.multirommgr
     
    BradTheGeek likes this.
  7. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    Did not know about the multiboot. I may just try that later. I have tons of errands and chores today, so no spending hours flashing ROMS and such, at least not till this evening!

    Thanks.
     
  8. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    Got it flashed back to stock, unrooted 4.4.2, the REcovery problem persisted. I flashed TWRP again and it was all fixed. I rerooted and am good.

    I want to try the multiboot, but I am stuck and feel like a dummy. I understand why it needs a custom kernel, but I do not know how to push the custom kernel to the device. I thought it was just flashing the zip from recovery, but that is not it. Any pointers?

    EDIT
    It appears I should be able to flassh kernels, but TWRP fails..some sort of getprop error. Have tried 2 kernels, no luck. Grrr.

    EDIT 2
    After using the app to install the modified TWRP, I was able to flash the appropriate kernel. I am now dual booting rooted stock and ubuntu touch. Woot!

    Thanks all! Especially WoohoGuy
     
    argedion and funkylogik like this.
  9. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Im guessing the problem was you not flashing the supersu update zip (or flashing an old version)? :beer:
    How is Ubuntu btw? Is it hard to learn?
     
  10. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    I do not know what the SU issue was, or how I lost root, but it is all fixed up now.

    As for Ubuntu Touch, I use Linux from time (I am ancient and first installed Slackware with linux kernel 1.2.10 back in 95), but I despise the Unity and Gnome 3 interfaces.

    On a tablet, unity seems a little better, but it is still unoptomized and SLOW. I also do not know how do use the interface, for instance, I do not know how to close an app. I can swipe to switch, but not close. I had a terminal open, typed exit which closed the text area, but not the app. It remained open and in my app switching, and using memory.

    There are no 'standard' context buttons like home, settings, etc to help navigate. In it's current state, it is not very usable to me. I could learn the UI elements, but at this point I think UI elements should be fairly standardized and not have to learn crazy new ways of doing simple things for new systems/releases (IE the idiocy that is metro on the desktop). I am getting quite opinionated I know, but what if Ford came out with a car that you steered with your feet and braked and accelerated with your hands. Would it be good? Under the hood can be as different as you like, but user interaction should remain consistent, or at least intuitive enough to grasp easily. I have been working in IT and tech fields for nearly 20 years, and this does not feel user friendly to me. So as it is, I cannot give it a ringing endorsement.

    What I can hope, is that like other things in the open source arena, people will modify and add to make it better than Shuttleworth's/Canonical's vision. Perhaps one day even get alternative desktop managers etc that feel more like what you want. First though, this baby needs tuning under the hood to make it snappier!
     
    funkylogik likes this.
  11. funkylogik

    funkylogik share the love peeps ;)
    Rank:
    None
    Points:
    1,443
    Posts:
    21,404
    Joined:
    Sep 15, 2011

    Sep 15, 2011
    21,404
    7,248
    1,443
    Male
    monkey
    Paisley, Scotland, Western Europe
    Nice explanation man cheers :beer:
    Ive never used linux so Ubuntu Touch isnt for me (yet)? :)
     
  12. BradTheGeek

    BradTheGeek Newbie
    Thread Starter
    Rank:
    None
    Points:
    36
    Posts:
    20
    Joined:
    Dec 16, 2012

    Dec 16, 2012
    20
    6
    36
    Well, you may not know it but you use linux every day. Androind uses a linux kernel, your bog screen tv probably runs linux, as do many other devices with a small embedded OS. Many websites you visit run linux, so in a way you are using it there too.

    In all those cases, you only interact with a user interface, and do not have to mess under the hood (and in many cases you are locked out of the engine compartment). That is Ubuntu's goal too, and largely they are there I think, even if I do not like the interface.

    Regardless, on this tablet, it feels slow as hell and buggy, as well as not being very intuitive to me, so unless you like bleeding edge and a lack of things you may normally do, I would say wait a while to see where it goes. It is certainly not a daily driver.
     
    funkylogik likes this.

Share This Page

Loading...