1. Are you ready for the Galaxy S20? Here is everything we know so far!

Struggling with a Samsung A51 (A-515F/DS) on Mint Mobile

Discussion in 'Mint Mobile' started by Ashton2, Sep 16, 2021.

  1. Ashton2

    Ashton2 Newbie
    Thread Starter

    I've been struggling to get this phone to IMS Register and to get the voLTE to operate on Mint Mobile.

    This phone is spec'd to be US LTE Compatible. It has all of the necessary bands.

    I must say, I have a $3/Mon T-Mobile SIM in this phone also and it doesn't have the problems that Mint has.
    When making voice calls on Mint it switches to GPRS, UMTS or HSPA+. Never 4G LTE. I have also tested Mint on a Nokia 6(TA-1025) and it Registers, and voLTE has never failed, but it's only a Single SIM phone.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    It's been a while since I used a dual sim phone, but I seem to remember that data usage was only available on one of the sims, which may be preventing the VoLTE from working on the LTE network. You can probably confirm this by toggling the data to the Mint sim instead of he other sim and see if that resolves the problem.

    FWIW, I'm using Mint on a Samsung Galaxy S20 and it works fine on both LTE and 5G.
     
    kate, puppykickr, Ashton2 and 2 others like this.
  3. Ashton2

    Ashton2 Newbie
    Thread Starter

    Thanks Unforgiven,
    I switched SIM locations and now the Mint is in position #1 and voLTE is working!
    IMS is Registered too.
    Thanks so much.
     
    Unforgiven likes this.
  4. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Glad to hear it was easy. That's usually the only things I can answer. :p If you poke around there should be a way to select which sim data is turned on in settings without physically swapping the sim locations.
     
    ocnbrze likes this.
  5. Ashton2

    Ashton2 Newbie
    Thread Starter

    There may be a Primary SIM position I'll try to determine this. I had noticed the LTE flag was only next to the SIM 1 signal indicator all along. In the settings data can be switched off/on for each SIM. I also added an APN named 'T-Mobile IMS'. I noticed this APN was loaded automatically for my second SIM (T-Mobile). Thought it wouldn't hurt to test it since the Mint SIM was status 'Unregistered' since day one.
     
    ocnbrze and Unforgiven like this.
  6. Unforgiven

    Unforgiven ...eschew obfuscation...
    Moderator

    Like I said, it's been years since I used a two sim phone, so I don't remember how the settings were, I just kinda remember the options in there. At least you got it sorted so it is useable. :)
     
    ocnbrze likes this.
Loading...
Similar Threads - Struggling Samsung A51
  1. Marvin P Droid
    Replies:
    19
    Views:
    337
  2. conrail
    Replies:
    5
    Views:
    230
  3. Cotzie
    Replies:
    3
    Views:
    209
  4. neil154
    Replies:
    10
    Views:
    447
  5. 4Jonah
    Replies:
    7
    Views:
    363
  6. Mcgee10
    Replies:
    7
    Views:
    354
  7. Daniel Burnett
    Replies:
    2
    Views:
    503
  8. kumaranil13k
    Replies:
    9
    Views:
    541
  9. gabrieltito234
    Replies:
    14
    Views:
    550
  10. skfl
    Replies:
    0
    Views:
    638

Share This Page

Loading...