1. Download our Official Android App: Forums for Android!

Support stuck in boot loop

Discussion in 'Android Devices' started by JCGA, Nov 26, 2009.

  1. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Hi, after my phone crashed / went unresponsive after a call I did what I've gotten used to doing which is taking out the battery to reset it. Though, this time I had the charger in which I'm guessing is what made the phone corrupt. Now I'm stuck in a boot loop with no way to reset it. Recovery mode doesn't help and I'm guessing there's no hardware reset button.

    I've never rooted or installed anything that's not from the free market.

    I'm living in Sweden but bought it in Germany so am reluctant to go through the hassle of returning it. Or does samsung have som kind of world wide warranty?

    Thanks for any help you could give me.
    /Janne
     

    Advertisement

  2. pasxal

    pasxal Member
    15

    Nov 2, 2009
    47
    0
    15
    You can use ODIN to flsh your phone. Instructions on how to to it are here.
    I am pretty sure that it will fix your phone (been there).
     
  3. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Sounds great, will try as soon as I get my usb connector back from work.

    So Odin intercepts communication with the phone before it starts to boot?

    thanks
     
  4. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    before doing a odin flash
    boot into recovery (vol down + accept call + power) then i think you press the home button to restore when you are in recovery mode
     
  5. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Tried odin, everything went as it should while flashing but after the procedure and reboot it once again got stuck in the boot loop. Just as before. =/

    I'm guessing it to be hardware failure at this point or could I try something else?

    I read somewhere on this forum of an htc user who had a boot loop problem that was solved by exchanging the sd card but since the sd card is built in on the galaxy that's not an option. Even if it was, I'm guessing the odin flash overwrote everything?
     
  6. Rastaman-FB

    Rastaman-FB Android Expert
    313

    Sep 11, 2009
    6,113
    1,010
    313
    UK
    have you tried what i said?
     
  7. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Yes, no luck. =/ It says RECOVERING MODE..... then it moves over to the samsung galaxy logo with the white/blue progress bar and gets stuck. After 10-15 seconds it reboots.
     
  8. pasxal

    pasxal Member
    15

    Nov 2, 2009
    47
    0
    15
    You should also try to fastboot and flash a new recovery . Then in recovery mount the sd card to your pc and push galaxo and II5. Reboot in recovery again and flash galaxo with the steps described in hdblog.

    Did you know what firmware version you had? We may find a nandroid backup if you are able to flash the recovery img.
     
  9. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Thanks for all the help.

    I hope it's not as complicated as it sounds and will try what you suggest over the weekend. It's getting late here in Sweden and brain is foggy.

    I had H8 before this happened. Now, after the failed odin flash, II5.
     
  10. kam187

    kam187 Android Expert
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    If you use the 'one package' II5 it wont wipe your data partition, so you could still have a hang.

    You should be able to go into recovery tho, if the flash worked properly. So did you definatly see [Recovery] and then it hung?

    Have a quick search for my individual H7 firmware files, these will force a factory reset afterwards. After those are applied and you have a running system you can upgrade back to II5
     
  11. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    I tried your individual H7 files but got the same results. Stuck at the blue progress bar. =/

    Continued to fiddle with the different boot modes (fastboot, download mode etc) when suddenly the progress bar started to move and it booted. Though, once done loading and faced with the unlock screen neither the unlock button or any other button worked. So it slowly went to screen saver mode and didn't work, once again.

    Removed battery and tried to boot again but it went back to stay stuck at the progress bar. Started trying different keys during halt and figured out that it's the camera button that makes it continue to boot. Weirdness...

    I even got it to boot in recovery mode but when I press menu during the triangle a progress bar appears for a second and then the phone seem to turn itself off...

    So, once again my guess is hardware failure cause this seems too weird to be a software error, no?
     
  12. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Update:
    I got it to unlock by randomly holding keys (go figure) and tried a proper factory reset from settings but that didn't work either.

    SOLVED - Is it possible to format internal sd card somehow. The option is greyed out in settings. Don't want my personal stuff on there if I try to return the phone... - SOLVED

    Edit / add
    Is the software / driver that handles the hardware keys something that gets updated as well when flashing with odin? Probably a stupid question as I'm guessing yes, it's updated. But if it's not it could still be a software issue.

    Weird thing is that I'm finding logic in my messed up keys. For example; camera key=unlock and unlock key gets me to the turn off phone menu and then camera if I press back...
     
  13. kam187

    kam187 Android Expert
    118

    Aug 3, 2009
    1,320
    46
    118
    UK
    You have a key stuck! Its a relatively common problem on the galaxy with some phones. Press all the keys in turn and check you receive the same physical feedback from them. Try to 'unstick' them by pressing them in and out etc

    Usually its the camera key or one of the 4 (not usually home on the front.
     
  14. JCGA

    JCGA Lurker
    Thread Starter
    5

    Nov 26, 2009
    8
    0
    5
    Thanks for taking the time to respond. I really appreciate the help you get on this forum.

    If it is a stuck button I can't get it unstuck. They all feel as they should and wiggling, pressing or chanting to them doesn't help. =/ So if it's definitely not a software issue I have to try to get it replaced. Thanks y'all again..
     

Share This Page

Loading...