Root Stuck in boot loop

[EDIT]: So, I just reflashed to the 2.1 ROM I was using, and that worked. At least, my phone is running now. But I'd still like to downgrade to 1.6 if anyone knows of any tutorials that would be great. Thanks.

So, I am pretty sure I made a bonehead mistake. I rooted my phone, started running OpenEclair, and everything was great. I thought it was a bit slow so I decided I would downgrade to a Cyanogenmod donut ROM. I didn't think about the fact that maybe I should have downgraded to stock before switching to the Cyanogenmod. I'm guessing this is where I made my mistake.

So, I flashed the CM-Recovery image to my phone. Then I flashed the defanged DRC83, and then the cyanogenmod After that I reflashed the radio even though I am pretty sure I already had that radio all set from doing the OpenEclair mod.

Now, when I try to start my phone or reboot it, it stops at the g1 screen.

Also, I tried wiping and re-flashing, then tried wiping and repaired ext2 on the sd, and still nothing.

Any help or information will be greatly appreciated, and hopefully I'm not screwed.