1. Check out our companion app, Forums for Android! Download from Google Play

Support Stuck in Outbox/Exchange corporate account

Discussion in 'Android Devices' started by c182pilot, Oct 4, 2010.

  1. c182pilot

    c182pilot New Member
    Thread Starter

    Oct 4, 2010

    I have a Droid 2, brand new from Verizon.

    My company uses Exchange Server 2003 R2. No PIN is required, and OMA is set up for my account. I can receive emails to the phone with no problems; the setup was simple and the messages sync'd to the phone quickly.

    I can't send, reply, or forward messages. The messages stay in the outbox. The replies I seem to find on this topic online seem to be related to IMAP/POP accounts, and this is neither.

    Sorry for a "newbie" question, I must be looking in the wrong place as I can't seem to find a solution.



  2. Redflea

    Redflea Well-Known Member

    Oct 6, 2009
    Never heard of this...

    Have you tried removing and re-adding the account?

    If that doesn't work, you could try a factory reset (Settings>Privacy>Factory Reset) and then add the account again.

    You could also try the "better email" app - it's available on the market. See how it goes with that email app (leveraged from the stock Email/Exchange client from Android 2.2). At least that would give you an interesting data point if it works w/that and not w/the standard D2 email client.
  3. bernardhoffman

    bernardhoffman New Member

    Oct 26, 2010
    I've got the same issue. Seems to be unique to the Droid2. Unit has been in use for 2 weeks and has consistent problems with "<corporate> Sync Error" and messages stuck in Outbox.

    I'm all open to ideas, but don't really want to rely on Touchdown or like apps to do what the OS is supposed to do natively.
  4. blbaustintx

    blbaustintx New Member

    Dec 1, 2009
    I found lots of people with this problem -- Droid 2, exchange email, emails stuck in their outboxes. AND people with Droid 2 complaining that they could only get their emails if they went to the client and hit refresh -- data push didn't work. I had both of those problems -- plus, the 15-minute fetch wouldn't. Only got emails when I went to get them myself by hitting refresh.

    I found few answers, but I think I might have just figured it out. Maybe.

    I have admin access to my Exchange 2003 server. I looked at the event logs, and saw that every 2 seconds, the server was generating an error with Event ID 3005. I found that if I turned off data push on my phone, these errors stopped. I then ran some google searches on Event ID 3005, and eventually landed on making these 2 changes on my server (which is actually SBS 2003):

    1. Within IIS, I expanded SERVER_NAME\Web Sites\Default Web Site. (This is the web site that has all of the Outlook Mobile Access, ActiveSync, etc.) I went to the Properties of Microsoft-Server-ActiveSync, Directory Security tab, and then the certificate settings, and I unchecked the "Require secure channel (SSL) setting for this directory.

    2. Then I went to the properties of the Default Web Site. I had IIS set to respond with this web site for these 3 options:
    Port # IP Address Header
    Port 80, <particular IP address>, internal.domainname.com
    Port 80, <particular IP address>, internal.seconddomainname.com
    Port 443, <all unassigned IP addresses>, <blank header>
    I added a fourth one:
    Port 80, <all unassigned IP addresses>, <blank header>

    3. At a command prompt, I used IISRESET /RESTART to force all Internet services to restart.

    When I turned "Data Push" back on, on my Droid 2, Event 3005 errors were not being generated anymore -- but more importantly, I was immediately notified of emails that had come in while I was monkeying with this.

    I'll point out that the settings I had used before were the same ones I used with "push" email on Windows Mobile 6, Windows Mobile 6.5, and my Droid 1. I'm not sure why the Droid 2 would be any different, but ... at least it's working for this moment.

    I appreciate everyone else's tips, so I wanted to share this, in case it solves anyone else's woes.

  5. xyvyx

    xyvyx New Member

    Nov 23, 2010
    had a similar problem... new Droid 2 (global). With an Exchange 2007 server, I just had a bunch of messages pile-up in my outbox. I changed one setting in the "corporate accounts" settings... uncheck Verify Certificate. Pretty sure I had to do something similar on my Droid 1.

    So between that and the phone restart, the messages were flushed & the sync. appears to be working better...
    I get immediate notification of new messages, and when I read a message on my desktop, it gets removed from "alert status" on my phone within about 60-90 seconds.
  6. ChristopherL

    ChristopherL New Member

    Jan 4, 2011

    I had the exact same issue. I unchecked the "Verify Certificate" setting, and as soon as I restarted the phone all of the emails stuck in my outbox sent. Thanks for the tip!
  7. lavisser51

    lavisser51 New Member

    Jan 27, 2011
    Armed with this information I tried a slightly different approach. First, I connected to my Exchange account using Outlook Web Access in a browser on my Droid 2, then disconnected. This appears to have downloaded the certificate to my phone. So, email push now works flawlessly without having to disable the "Verify Certificate" setting.
  8. ASaffo

    ASaffo New Member

    Feb 2, 2011
    I was having a similar issue and I tried uninstalling my account, and all the other things I found online. When I went in and unchecked Accept all SSL certificates it works fine for me now. So almost the same.
  9. fvilla01

    fvilla01 New Member

    Jul 24, 2011
    This was happening to me as well, however not all the time. I think it has to do with any changes on the server side, passwords, updates etc etc. However an easy fix:

    On DROID X:
    Scroll to APPLICATIONS
    Scroll to EMAIL

    then you will have to clear cashe/foce stop
    Turn phone off then you will notice your email in your outbox has been sent. Go to your corporate email and verify your sent email.

    Frank Villa
  10. MikeDroidUser

    MikeDroidUser New Member

    Sep 15, 2011
    Thanks for the fix above with stopping the email app and restarting phone!!

    When I changed my Outlook password (which we have to do every 90 days due to corp policy) I only RECEIVED email, but SENT messages were stuck in Outbox. This occurred after I changed to the new password on Droid (which I never had to do when I had corp Blackberry)...before I changed it nothing was received either which is a lot more obvious since an error message is displayed. When messages are stuck in Outbox there is no error message.

Share This Page