1. Are you ready for the Galaxy S20? Here is everything we know so far!

Stumped Updating to 2.1

Discussion in 'Android Devices' started by Zenshooter, May 20, 2010.

  1. Zenshooter

    Zenshooter Lurker
    Thread Starter

    Im working on a Windows 7 64bit system. When I connect the Moment to the computer, the device manager displays "Samsun - Android" and I can mount the SD card with no issues.

    However, when I try and run the updater, I get to the point where it asks me to connect the usb cable to the phone and PC... when I do, the device manager says M900. The updater will never connect and I cannot update the drivers so that the M900 can connect to the updater. Stays disconnected and detecting a port.

    Anyone see this before? Have an idea what I can do to correct this. When I attach the phone the little dialog box that tells you that its installing new hardware fails to load a driver for this M900 device.

    I've spent a couple of hours fooling around with this and quite frankly my frustration level is pretty high

    Any help would be greatly appreciated... Thanks.

    1. Download the Forums for Android™ app!


  2. Zenshooter

    Zenshooter Lurker
    Thread Starter

  3. 9Nails

    9Nails Member

    When you connect the cable to the phone, is your phone in the Download screen?

    (Download screen)

    If not, it will need to be.
  4. ColdStart

    ColdStart Well-Known Member

    What phone are you using to apply this upgrade to? This doesn't like the Moment that I have.
  5. mrmojoz

    mrmojoz Android Enthusiast

    This is your whole problem. The drivers used to mount the SD card aren't the same ones needed to flash the phone. You can find 64bit drivers and instructions on this forum as well as SDX: SDX-Developers
  6. zcarman

    zcarman Android Enthusiast

    Amen mrmojoz... I had the same issue... Uninstalled all the Sammy stuff from my laptop - did a clean install of the DE03 flasher and poof... Perfection!
  7. Zenshooter

    Zenshooter Lurker
    Thread Starter

    Yup.. thats what it looks like. But when I connect the USB cable to the PC the Device Manager says M900 and not Samsung Android. The updater cannot connect to the phone... none of the com ports will work.

  8. Zenshooter

    Zenshooter Lurker
    Thread Starter

    I installed what I thought were the 64bit PC Studio drivers... is this incorrect?

    Samsung Moment | Random Tech Info
  9. ragingbull2k2

    ragingbull2k2 Member

    DO NOT, I repeat, DO NOT INSTALL the pc studio drivers... you have to go into Device Manager on your comp and uninstall EVERYTHING samsung related... after that, reboot the computer and install the following:


    that should (IIRC) install the drivers you need along with the software to flash official 2.1 android... if you had already installed this, go ahead and uninstall it along with everything else samsung related... try this, and let us know how it works out...


    p.s. sometimes you have to unplug/plug the phone a couple of times from the microusb for the computer to recognize and assign the com port... if that still doesn't work, reboot the phone... normally fixes the issue...
    Zenshooter likes this.
  10. Zenshooter

    Zenshooter Lurker
    Thread Starter

    Perfect... worked like a charm. Much appreciated... had it all loaded in about ten minutes after spending hours reading forums and watching youtube instructions.

    Thanks again.

  11. ragingbull2k2

    ragingbull2k2 Member

    no problem and glad it worked! any more questions, just send me a pm or post up...


Samsung Moment Forum

The Samsung Moment release date was November 2009. Features and Specs include a 3.2" inch screen, 3MP camera, GB RAM, processor, and 1440mAh battery.

November 2009
Release Date

Share This Page