1. Download our Official Android App: Forums for Android!

Su permission not working on dc

Discussion in 'Android Devices' started by avacomputers, May 13, 2010.

  1. avacomputers

    avacomputers Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    374
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    374
    31
    43
    Computer Tech.
    I'm running damage control, I installed root manager, when I open it the su permission app opens but I don't see anything but a blank blank screen, any suggestions?
     

    Advertisement

  2. ccapasso

    ccapasso Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,127
    Joined:
    Jan 12, 2010

    Jan 12, 2010
    1,127
    278
    163
    Make sure USB Debugging is enabled.
     
  3. ccapasso

    ccapasso Android Expert
    Rank:
    None
    Points:
    163
    Posts:
    1,127
    Joined:
    Jan 12, 2010

    Jan 12, 2010
    1,127
    278
    163
    Furthermore, opening the app itself will show a blank screen until you start granting permissions. For example, say you launch an app that requires SU permission. You click always allow. Now when you go back into the SU app you should see something listed.
     
  4. avacomputers

    avacomputers Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    374
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    374
    31
    43
    Computer Tech.
    I'm not trYing to open the app. Root manager is requesting permission.
     
  5. avacomputers

    avacomputers Android Enthusiast
    Thread Starter
    Rank:
    None
    Points:
    43
    Posts:
    374
    Joined:
    Dec 9, 2009

    Dec 9, 2009
    374
    31
    43
    Computer Tech.
    Usb debugging worked, thanks
     
  6. mslisaj

    mslisaj Android Enthusiast
    Rank:
    None
    Points:
    36
    Posts:
    367
    Joined:
    Feb 11, 2010

    Feb 11, 2010
    367
    6
    36
    Mechanic
    Klamath Falls, Oregon
    I ran into this too. I forget the exact. Order of these steps but if my memory. Serves me I disabled debugging and shut the phone off. Then I turned the phone back on and enabled debugging and I had SU and could use root explorer from then on.
    Good luck. :)
     
Tags:

Share This Page

Loading...