1. Are you ready for the Galaxy S20? Here is everything we know so far!

Sudoku is killing my battery

Discussion in 'Android Apps & Games' started by rogerstg, Nov 6, 2014.

  1. rogerstg

    rogerstg Newbie
    Thread Starter

    UPDATE: After solving the problems as detailed in the following posts, I reinstalled the offending app and have NO problem. It doesn't even register on the battery use monitor when not being used. I write this because I don't want users researching this app to think that it will cause a problem. Maybe this could have happened with any app, maybe it was a glitch in the operating system or file recording, who knows. I'd hate to a have anything to do with denigrating the hard work of app developers for something that may not have been their fault.


    My battery life became dismal after installing Sudoku Free from Genia. This happens while the phone is just standing by. When I checked battery use in settings,

    I noticed application com.icenta.sudoku.ui is the second highest drain on power after Screen. It is using more battery than the Android OS.

    So I tried various things. I uninstalled it, rebooted the phone, wiped the cache and there was no change after each of these steps.

    Also tried to "force stop" the application, but the button in greyed out and not usable.

    I'm at a loss for what to try next. Any help is appreciated.

    [​IMG]

    [​IMG]
    [​IMG]
     



    1. Download the Forums for Android™ app!


      Download

       
  2. jj14x

    jj14x Android Expert

    I'm moving your thread over to the Android Apps forum.

    I'm not familiar with that app - did you get it from the play store? Check the permissions to see whether it has more permissions that such an app should have.

    After uninstalling it, is the app still showing usage?? (or did you reinstall it after removing it?)

    I'd suggest uninstalling this app, and making sure that after you recharge/reboot the phone, the app is not showing up in battery usage. If so, try a different app (with good reviews on the play store)
     
    rogerstg likes this.
  3. rogerstg

    rogerstg Newbie
    Thread Starter

    Thank you for your response.
    Yes - I received the app from the Play store. I'd used it on my prior phone, but had not re installed it since January 2014.

    The app usage in the photo is AFTER it's been removed, rebooted, cache cleared, rebooted.

    I just want to get rid of this parasite.
     
  4. BigRedGonzo

    BigRedGonzo Android Expert

    I hate to suggest this, but it may work. Try installing the Sudoku app again and then go to the app manager and see if it will let you force stop the app, then uninstall it again. Its just a shot in the dark, but I've had issues with remnants causing issues before and that was the solution. Evidently, during the uninstall process, some stuff got left and the second install/uninstall cycle remedied the situation.
     
    jj14x and rogerstg like this.
  5. rogerstg

    rogerstg Newbie
    Thread Starter

    IT WORKED!

    After reinstalling, I used the app manager. I cleared the cache, cleared the data, force stop and finally uninstall.

    I'm not sure if each of the steps were necessary, but I thought it might be best to pick away at the extraneous parts before removing the app.

    Thank you.
     
  6. BigRedGonzo

    BigRedGonzo Android Expert

    Glad it helped.
     
Loading...

Share This Page

Loading...