1. Download our Official Android App: Forums for Android!

Support Sync 2 gmail accounts' contacts - not working

Discussion in 'Android Devices' started by leondroid, Aug 5, 2011.

  1. leondroid

    leondroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Aug 5, 2011

    Aug 5, 2011
    5
    1
    6
    Hello,

    I have 2.2 on my HTC Desire HD.
    I have not loaded lots of funny stuff, phone pretty close to virgin.

    I added my one google account and after a while figured out how the contacts really work - changed all to Google contacts and they sync nicely now.

    I then added a 2nd gmail account, and all the Settings > Accounts & Sync stuff are set correctly.
    However this 2nd gmail account's contacts are not synching.
    If I try to do a manual forced sync on that account, and the 3 "sub sync" parts come up (Contacts, Gmail, Calendar), the Contacts one does not do anything. No errors, just does nothing. The network indicator shows that something is (very) briefly happening, but e.g. the date last sync-ed stays empty, and the synching of course didn't happen.

    I checked all the common advice people give and none of them seems to help here, and I can't see any setting that treats the 1 gmail account differently to the other.
    so why would 1 sync and the other not?

    I can read both's mail and that does sync, and I don't use the calendar much but did get reminders for the one where the contacts don't wanna sync.

    Please Help!
    Leon
     

    Advertisement

  2. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    Welcome to the forums! :)

    When you're in the phone book, hit menu, then view. Does it give you an option to display contacts from the 2nd Gmail account?
     
  3. leondroid

    leondroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Aug 5, 2011

    Aug 5, 2011
    5
    1
    6
    Yes, they're both there. Each labelled "Google", with the actual account name under it. Both enabled in View.
     
  4. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    If you open the gmail app, switch to the 2nd account, then sync, do they appear then?
     
  5. leondroid

    leondroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Aug 5, 2011

    Aug 5, 2011
    5
    1
    6
    If I'm in gmail then both accounts work and are "refreshed" when I choose that, but it does not update the contacts at that point, only the mail.
     
  6. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
  7. leondroid

    leondroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Aug 5, 2011

    Aug 5, 2011
    5
    1
    6

    Thanks El Presidento,
    I did read that earlier. There seems to be many different issues, people don't experience the same problems. If I do figure out what to do I will post it here.

    Thanks
    Leon
     
  8. leondroid

    leondroid Lurker
    Thread Starter
    Rank:
    None
    Points:
    6
    Posts:
    5
    Joined:
    Aug 5, 2011

    Aug 5, 2011
    5
    1
    6
    Hello,

    I think I stumbled accross it:

    To keep my network access down, under "Settings", "Accounts and Sync" I had the "Auto-sync" option OFF.
    Instead I went into each account separately now & then, like when I know I updated something.
    There (manual sync) only the one account updated, the other did nothing and the timestamp did not update.

    Now when you check "Auto-Sync", it changes the meaning of the 2 Gmail accounts listed below the "Auto-sync" tick:

    When auto-sync is off, it shows you the 3 parts that make up synching (Contacts, Mail, Calendar), and by clicking on any 1, that one is manually Synched . That's the part that didn't work on my 1 account.

    When Auto-sync is ON, instead of allowing you to manually sync each component, it now becomes tick boxes where you indicate which components exactly you want to auto-sync (when auto-sync is enabled).

    In my case, the 1 account that didn't want to sync when I manually wanted to, was not ticked as an option for Auto-Synching (even though I don't want to auto-sync).

    All I did now was to set the contacts for both accounts to auto-sync while the Auto-sync was enabled, and then disable the auto-sync again.

    Now when I manually sync either, it does seem to work.

    Regards
    Leon
     
    El Presidente likes this.
  9. El Presidente

    El Presidente Beware The Milky Pirate!
    Moderator
    Rank:
     #4
    Points:
    3,118
    Posts:
    32,117
    Joined:
    Jan 3, 2011

    Jan 3, 2011
    32,117
    24,060
    3,118
    Scotland
    Seems relatively logical!

    Thank you for posting how you managed to resolve, it'll be handy to refer back to if anyone has the same issue again :)
     

Share This Page

Loading...