1. Download our Official Android App: Forums for Android!

Support Sync phone contacts BACK to google account

Discussion in 'Android Devices' started by blackfox, Apr 8, 2010.

  1. blackfox

    blackfox Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    18
    1
    16
    IT Hardware
    Midlands, UK
    Hi, I have searched around on this and other forums, looking for the answer to a question that has been bugging me since before the weekend!

    I got the HTC desire on friday (love the phone!:D) and have got to the point where most of the things are set up how I want. I have used HTC sync to import my contacts from Outlook where they were already set up how I wanted. However I can't seem to be able to import these contacts back up to my Google account though. I have turned on all the sync settings and checked these, but nothing seems to work.

    I tried creating a dummy contact in my google account and prompted a sync from my phone which pulled this down ok. So this would indicate that the sync seems to work one way, but wont pull my contacts back up the other.:thinking:

    I don't really want to re-enter all my contacts into my Google account to get the sync working properly plus I am assuming this will create a duplicate of every contact already on my phone.

    Am I alone with this issue?

    Thanks in advance for any suggestions/help!
     

    Advertisement

  2. mobrienjr

    mobrienjr Android Enthusiast
    Rank:
    None
    Points:
    63
    Posts:
    383
    Joined:
    Mar 14, 2010

    Mar 14, 2010
    383
    27
    63
    I have the droid and have not had any problems getting my phone contacts to sync w/ google. If you go into settings/accounts & sync it should show what accounts you can manage. You can select your gmail account and then it would give you the option of what you want to sync w/ gmail...ie contacts, gmail, calender...

    I hope that this helps.
     
  3. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    Just to make sure they are set up as google contacts, on your phone open the people app and do the following:

    Menu > view

    Can you confirm here that in the brackets to the right of the "Google" text there is a number? Which one of those in there has a number of contacts associated with them?

    It sounds to me as if you only have "phone" contacts, not "google" ones?
     
    Warwick likes this.
  4. blackfox

    blackfox Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    18
    1
    16
    IT Hardware
    Midlands, UK
    mobrienjr - thank you for your reply. I did go through the settings in sync, and ticked all under gmail account. This did not make a difference.

    lekky - Indeed, you are right, all my contacts are "phone" contacts. It does appear to let me change this either. It must be a default attribute of importing contacts from Outlook via HTCsync that they go on to your phone as "phone" contacts.

    I think the best work around for this issue would be to sync your contact on the phone back to outlook (or just make sure you have the most up-to-date version of contacts on outlook) then using a third party app or service such as kigoo (getkigoo.com) or oggsync (oggsync.com) to sync your outlook contacts with gmail. Delete the contacts from the phone and perform a sync with gmail to pull the contacts back down. This would (in theory) get all your contacts into gmail and the phone as "google" contacts without the tedious task of re-typing all of them into the gmail account.

    I will post back when I have tried it out!
     
  5. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    Glad to be of help, can i suggest an easier way though:

    menu > import/export > select export to sd card

    then do the same thing but import from sd card. at that point it should allow you to choose what you want to import them as, so pick google contacts.

    Must say that I havent tried this but it seems logical that it should work.
     
    Trigger911, Syko, fluffsri and 4 others like this.
  6. blackfox

    blackfox Newbie
    Thread Starter
    Rank:
    None
    Points:
    16
    Posts:
    18
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    18
    1
    16
    IT Hardware
    Midlands, UK
    lekky - awesome! Glad I read your post before I started, this worked great :D.
     
  7. lekky

    lekky Lover
    Rank:
    None
    Points:
    313
    Posts:
    5,250
    Joined:
    Oct 29, 2009

    haha cool, glad it worked :)
     
  8. mal.uk

    mal.uk Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    2
    2
    6
    I had the same problem, easily solved with a few quick steps.

    1. Open People, Menu, Import/Export, Export to SD Card
    2. Import/Export, Import to Google
    3. Menu View - Select only the Google Account so you don't see duplicates (I choose to leave the contacts on my phone as a backup)
    4. Home Screen, Menu. Settings, Accounts and Sync, Tap on Google and make sure Sync Contacts is ticked. Tap Sync now to sync straight away - although my phone already detected the new contacts and was already syncing.
    5. Check you google account and volla, your contacts are now in sync.

    I love my phone, but it should come with a warning, only for the tech savvy amongst you!!!

    Hope that helps
     
    foxhunter and DodgerinNH like this.
  9. mjholgate

    mjholgate Lurker
    Rank:
    None
    Points:
    5
    Posts:
    3
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    3
    0
    5
    I just noticed what looks like a related issue with contact sync on HTC desire.

    If you add a birthday to a contact on the phone, it appears that the contact will no longer sync correctly with gmail contacts. To get around this, I found you had to delete the birthday field on the phone, and add one using the gmail contacts. When you do that, sync seems to work properly.

    I'm guessing this is a bug - would be interested to know if anyone else has seen this?
     
  10. mal.uk

    mal.uk Lurker
    Rank:
    None
    Points:
    6
    Posts:
    2
    Joined:
    Apr 8, 2010

    Apr 8, 2010
    2
    2
    6
    Thanks for that, I just noticed when I added a second email address it also didn't sync. I will look into this and feed back.
     
  11. emmalouiserogers

    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Apr 11, 2010

    Apr 11, 2010
    1
    0
    5
    Hi mjholgate, I have experienced exactly the same problem as you. If I set birthdays using gmail contacts on my PC then all is good. I can make changes to anything other than the Birthday field on my HTC desire and it syncs OK.
    But if I change the Birthday field, sync fails , and my HTC desire contact gets overwritten with the original unchanged Gmail contact, i.e. Gmail will not update (including any other fields that I change at the same time as the Birthday on my phone).
    I think we have to live with only being able to edit birthday through Gmail for the moment!
     
  12. gooner rich

    gooner rich Newbie
    Rank:
    None
    Points:
    35
    Posts:
    17
    Joined:
    Feb 17, 2010

    Feb 17, 2010
    17
    0
    35
    UK
    I have the HTC Hero 1.5. From my own personal experience with my phone plus what I have read from other threads on this forum, the answer is no: you cannot back drive "phone" contacts up to "google" contacts (if you're still running 1.5). I believe 2.0 or 2.1 will enable you to change "phone" contacts to "google" contacts.

    However, I had well over a hundred phone contacts that I wanted to back up / add to google contacts. I've now sorted this problem by doing the following...(I cannot take credit for the advice, I've just duplicated advice from other threads!), it's different from the method Lekky talks about, I didn't follow that because 1. I couldnt find how to export to my SD Card (only had the Import option from the menu) and 2. I wanted to merge/delete duplicate contacts:

    1. Download "ExportContacts" from the Market...this app allows you to export all contact info (apart from contact picture I belive) to a .CSV file on your SD Card
    2. Open the ExportContacts app, select your desired SD file location to save the contact.csv and select "Export Contacts"
    3. Connect your phone to your PC and "mount SD Card", copy the contact.CSV file to an appropriate location on your PC (i copied it onto my Deskptop for easy location)
    4. Open GoogleMail from your PC and go into "Contacts"
    5. Select the "Import" link and then "Choose File" and locate the .CSV file you have just saved to your PC and then click the "Import" button
    6. You can now sort any duplicate contacts (merge, delete etc.) from here by clicking on the "Find Duplicates" button OR manually by selecting (checking) the relevant contacts in your contact list and selecting the "Merge these contacts" link
    7. Once you're happy with your GoogleMail contact list then you can sort your phone contact list by syncing your phone to your google contacts by doing "Menu > Settings > Data Synchronization > Google > Contacts" (you should see the little syncing symbol next to "Contacts" and in the Task Bar)
    8. Then to stop you seeing any duplicate contacts in People, open the People app and go "Menu > View", make sure that only Google is selected.
    9. Then you just have to make sure that any new contacts you add manually to your phone you add them as "Google" type contact

    There have been some mixed reviews from Hero users when running the ExportContacts app. I can say I have had no problems, so I'm guessing it's just luck of the draw.

    Hope this helps. The same problem has been getting on my nips for ages, finally decided to sort it out once and for all!
     
  13. MrXavia

    MrXavia Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jul 1, 2010

    Jul 1, 2010
    1
    0
    5
    Brilliant thanks, I am glad I found this, was getting frustrated at not being able to copy from phone contacts to google and vice versa! because Only phone contacts can be grouped it seems!
     
  14. el_caro

    el_caro Newbie
    Rank:
    None
    Points:
    16
    Posts:
    29
    Joined:
    Jul 17, 2010

    Jul 17, 2010
    29
    3
    16
    I have been wondering? is the setting in gmail (on the pc) relevent to this syncing?
    Gmail settings states as follows;

    "What's the difference between IMAP and POP?
    Unlike POP, IMAP offers two-way communication between your web Gmail and your email client(s). This means when you log in to Gmail using a web browser, actions you perform on email clients and mobile devices (ex: putting mail in a 'work' folder) will instantly and automatically appear in Gmail (ex: it will already have a 'work' label on that email the next time you sign in).
    IMAP also provides a better method to access your mail from multiple devices. If you check your email at work, on your mobile phone, and again at home, IMAP ensures that new mail is accessible from any device at any given time.
    Finally, IMAP offers a more stable experience overall. Whereas POP is prone to losing messages or downloading the same messages multiple times, IMAP avoids this through two-way syncing capabilities between your mail clients and your web Gmail.
    If you're trying to decide between using POP and using IMAP with Gmail, we recommend IMAP."


    Does this only apply if you are 'Adding a POP3/IMAP email account' or does it have an effect on syncing gmail?

    I set mine to IMAP and when i delete a message on the phone it deletes from gmail on the pc?
     
  15. halcyondays

    halcyondays Member
    Rank:
    None
    Points:
    16
    Posts:
    48
    Joined:
    Apr 29, 2010

    Apr 29, 2010
    48
    1
    16
    Lekky, your a star. Been trying to sort this for ages. Cheers.
     
  16. Warwick

    Warwick Lurker
    Rank:
    None
    Points:
    25
    Posts:
    4
    Joined:
    Jul 23, 2010

    Jul 23, 2010
    4
    0
    25
    Scotland, UK
    Have changed all contacts to 'google' contacts, and edited all birthdays, etc via web rather than phone. All was going well (so far).

    Tried to add a new contact today; selected type 'google', entered only name and number, but when the phone sync'd it was wiped :mad: - phone is back to an exact copy of online.

    Am I missing something? Shouldn't the phone update the online contacts?

    W
     
  17. RightSaidJames

    Rank:
    None
    Points:
    6
    Posts:
    9
    Joined:
    Jul 2, 2010

    Jul 2, 2010
    9
    1
    6
    After following lekky's method on my HTC Wildfire, the contacts didn't stick when I synced my Google account under Accounts & Sync. So instead I imported the file into Google Contact Manager and edited it from there, then let everything get synced back down to the phone. One annoying feature of the Export function in 2.1 (or at least on the Wildfire) is that the numbers are reformatted US style (xxxx-xxx-xxxxx or something along those lines), and changed to the type of "Other"!
     
  18. arjun_a1989

    arjun_a1989 Lurker
    Rank:
    None
    Points:
    5
    Posts:
    4
    Joined:
    Jul 21, 2010

    Jul 21, 2010
    4
    0
    5
    Im having exactly the same issue! Please can anyone help
     
  19. Surreyuser

    Surreyuser Newbie
    Rank:
    None
    Points:
    16
    Posts:
    29
    Joined:
    Jun 13, 2010

    Jun 13, 2010
    29
    1
    16
    I've had the same problem changing an item in Google Calender on my phone - it wouldn't let me delete one occassion of a recurring event.
     
  20. briankdk

    briankdk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    2
    Joined:
    Sep 10, 2010

    Sep 10, 2010
    2
    0
    5
    yeah...... wtf !

    This is very annoying - anybody has a way to work around that ?

    Here in denmark the numbers at 43781211 style, when exporting from my desire it shows like 437-812-11 that sucks !

    if i have+45 infront it dosent happen .....
     
  21. origdav

    origdav Member
    Rank:
    None
    Points:
    16
    Posts:
    45
    Joined:
    May 20, 2010

    May 20, 2010
    45
    2
    16
    Hi,

    I wanted to sync my phone contacts with my Gmail account and found this thread.
    This has worked perfectly and within the People app -> Menu -> View, I can see the same number next to Google as I can Phone. At present only Google is ticked.

    My problem is when I enter a name within a new text message the contact appears twice, once from the Phone entry and once from the Google entry even though only Google is ticked within the People app.

    Does anyone know how to change it so only the Google contacts show up when you enter their names in a new text message?

    Thanks
     
  22. bass2rez

    bass2rez Member
    Rank:
    None
    Points:
    36
    Posts:
    44
    Joined:
    Aug 27, 2010

    Aug 27, 2010
    44
    7
    36
    IT Security
    Wokingham UK
    I too am having much the same problems. I can add a new contact online and this will sync down to the phone, but if I create a new contact on the phone, I cannot get this contact to appear online.

    I have now tried to save my contacts to sdcard, deleted all my contacts and then re-imported my contacts from the sdcard.

    Now I have the same infuriating problem as RightSaidJames and briankdk in that all of my contact numbers are now in American format xxx-xxx-xxxxx.

    Even worse, now when I now try to sync contacts, I get the message "Sync is currently experiencing problems. It will be back shortly." It has been unable to sync for 5 days now.

    If anyone has any ideas about how I amd the others can resolve these issues, we would be most grateful.

    One main question springs to mind, to assist in the troubleshooting. Can anyone confirm that they can successfully add a contact on their phone and sync, and get this new contact to appear online?

    If so, then it means that some of us must have something set incorrectly on the phone. If not, perhaps we are trying to perform a function that has a bug.

    Cheers,
    Steve
     
  23. origdav

    origdav Member
    Rank:
    None
    Points:
    16
    Posts:
    45
    Joined:
    May 20, 2010

    May 20, 2010
    45
    2
    16
    Works for me.


    1. Add contact to People App.
    2. Switch Wireless or Mobile Internet on
    3. Switch Background data sync on -> Menu -> Settings -> Accounts and Sync, tick Background data
    4. Select Google -> Sync Contacts, time stamp should update
    5. Check Contacts with Gmail and it's there.
    I have noticed if you're in the People App and it's still syncing or thinking about it it seems to stop it.

    I'm going to start a new thread for my issue in post 21.
     
  24. bass2rez

    bass2rez Member
    Rank:
    None
    Points:
    36
    Posts:
    44
    Joined:
    Aug 27, 2010

    Aug 27, 2010
    44
    7
    36
    IT Security
    Wokingham UK
    As an update to my earlier post, I have resolved this issue by doing the following, after ensuring I had a recent backup of all my contacts:

    Home screen -> Menu -> Settings -> Applications -> Manage Applications -> All -> Contacts Storage -> Clear Data.

    Once I did this, my contacts all dissappeared (so please ensure you have backed then all up!) but then immediately started populating again, from the Google online contacts. As a side effect of doing this, the phone numbers are also now in xxxxxxxxxxx format, rather than American format.

    I have yet to see if this has made any difference to the issue with uploading changes.

    Cheers,
    Steve
     
    Doug2a and webfoolery like this.
  25. mcchriswood

    mcchriswood Well-Known Member
    Rank:
    None
    Points:
    36
    Posts:
    151
    Joined:
    Mar 3, 2010

    Mar 3, 2010
    151
    1
    36
    couple of questions guys.
    1. When i save a ontact to my phone if i choose too save it to my google account then within a couple of minutes the contact is nowhere too be found on my phone.
    2. my contacts numbers are appearing as so xxx-xxx-xxxxx - is there a way too change this so that the number just appears as xxxxxxxxxxx.
    I have read the above but my online contacts are also in the above format so i cant see that doing the above will help me??

    EDIT : done the abover and it didnt help contacts still in wrong format.
    Im having to save new contacts by saving too sim exporting to sd card then importing too google.
    Surely this isn't right where is it going when i save directly to google
     
Tags:

Share This Page

Loading...