1. Download our Official Android App: Forums for Android!

Root "System update available" nags & reboots

Discussion in 'Android Devices' started by mlaurence, Jul 18, 2011.

  1. mlaurence

    mlaurence Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    May 10, 2011

    May 10, 2011
    5
    0
    5
    I rooted my phone using YouTube video tutorials that I found through these forums. Thank you, I love the wireless tethering and everything works fine. I am using DRockstar Clean Kernel EC05 v1.02. Just one problem.

    About once a week, after I've rebooted the phone, I get a message that a system update is available. It's the Sprint MR4 EC05, which downloads and tries to install, forcing me to reboot the phone. It doesn't take, and using Clockwork Recovery I then reboot again into the original rooted version.

    Is there an easy way to fix this? I have been Googling and reading through this forum for weeks, thinking there must be others with the same problem, but I don't see anything that helps.

    Following one thread and videos, I tried to use ODIN but I can't get it to work despite multiple tries. I'm using a Mac but running Windows on a partition to attempt this. Should I replace the manufacturer's USB cable? Am I on the right track to try to restore the original settings, accept the Sprint update, and then reroot the Epic?

    Thank you for any help.
     

    Advertisement

  2. icecold

    icecold Android Enthusiast
    Rank:
    None
    Points:
    98
    Posts:
    667
    Joined:
    Dec 31, 2009

    Dec 31, 2009
    667
    75
    98
    WI
    I wouldn't jump right into ODIN right away. You have a few options to try beforehand...

    1) Flash a custom ROM. Most, if not all, should have the updater removed.
    2) Use Titanium Backup to freeze SystemUpdater.apk (I have read of some reports of this not stopping the update popup though)
    3) Or just uninstall the SystemUpdater.apk
     
  3. altimuh

    altimuh Member
    Rank:
    None
    Points:
    36
    Posts:
    46
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    46
    4
    36
    Simple easy and free

    1) Download and install "Terminal Emulator" from the market
    2) run the program
    3) type "su" (without the quotes) and press enter
    4) a pop-up will ask you if you wish to allow this program root rights
    5) click "allow"
    6) type "pm disable com.samsung" (without the quotes) and press enter
    7) back out of the program and enjoy no update notifications

    additionally the following commands (and what they do):

    pm disable com.sec.android.providers.drm (Disables DRM launcher)
    pm disable com.sec.android.app.sns (Disables sns)
    pm disable com.samsung (Disables updates)

    All credit to http://forum.xda-developers.com/showthread.php?t=1120050&highlight=freeze+battery
     
  4. mlaurence

    mlaurence Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    May 10, 2011

    May 10, 2011
    5
    0
    5
    Thanks for both replies. I'm trying both solutions as it doesn't seem they are mutually exclusive. The first one went well, and two steps of the second solution went well. But when I type "pm disable com.samsung" I get the following reply:

    /mnt/.lfs: Function not implemented
    /mnt/secure/asec: Permission denied
    [1] Killed pm disable com.samsung
     
  5. altimuh

    altimuh Member
    Rank:
    None
    Points:
    36
    Posts:
    46
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    46
    4
    36
    Confirm you are rooted and have an app called "SuperUser" in your app drawer.
    Open that up and confirm that "Terminal Emulator" has a green dot (meaning root access allowed) next to it.
     
  6. mlaurence

    mlaurence Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    May 10, 2011

    May 10, 2011
    5
    0
    5
    Yes, I have SuperUser, and yes, there's a green dot in the right place. I did have to reboot Terminal Emulator to get that green dot, but now I have checked the button to "always" allow root access to Terminal Emulator.

    But even after that, I still get the same error message as above when trying to "pm disable com.samsung"

    And now I have the pesky System Update insisting that I install it again. :(
     
  7. altimuh

    altimuh Member
    Rank:
    None
    Points:
    36
    Posts:
    46
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    46
    4
    36
    If I open up Terminal Emulator and just type in "pm disable com.samsung" I get an error message that's similar to yours, albeit longer.

    Code (Text):
    1. Unable to open log device '/dev/log/main' : Permission denied
    2. Unable to open log device '/dev/log/system' : Permission denied
    3. Unable to open log device '/dev/log/events' : Permission denied
    4. Unable to open log device '/dev/log/radio' : Permission denied
    5. Error connecting (Permission denied)
    6. Error connecting (Permission denied)
    7. /mnt/.lfs Function not implemented
    8. /mnt/secure/asec: Permission denied
    9. Unable to chmod /data/log/dumpstate_sys_error.log: Operation not permitted
    10. [1]     Killed                          pm disable com.samsung
    11.  
    However when I type in "su" then press enter, I see a bubble that pops up that tells me "Terminal Emulator has been granted super user permissions".

    Then typing in:
    Code (Text):
    1. pm disable com.samsung
    I see:
    Code (Text):
    1. Package com.samsung new state:disabled
    I hope this helps - if not let us know! :)
     
  8. mlaurence

    mlaurence Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    May 10, 2011

    May 10, 2011
    5
    0
    5
    I just tried it the new way. I do get the bubble you mentioned, but then I get the same string of error messages as in my original post. Frustrating!

    thanks, though for your help.
     
  9. mlaurence

    mlaurence Lurker
    Thread Starter
    Rank:
    None
    Points:
    5
    Posts:
    5
    Joined:
    May 10, 2011

    May 10, 2011
    5
    0
    5
    I'm also revisiting your solution since that didn't appear to work either, now that I've seen the update nag appear again.

    I don't see an app called "SystemUpdater.apk" by searching my phone and SD card. I'm doing this by typing that file name into Astro and starting at the highest level, so it appears to search through the entire contents. Result: nothing found. Maybe that's because I was successful at deleting it in the first round of this exercise. But, something caused the nag/reboot procedure to return.

    I was able to perform the original root by following a well-done video tutorial. Do you have any suggestions on how to find a similar tutorial that will help me replace the current ROM? Or...any other suggestions would be appreciated. :)

    Thanks!
     
  10. altimuh

    altimuh Member
    Rank:
    None
    Points:
    36
    Posts:
    46
    Joined:
    Jun 11, 2010

    Jun 11, 2010
    46
    4
    36
    Check out this thread - last post is a link to SDX Stock App Remover
    HOW TO Strip your Epic NAKED! - PPCGeeks That's what you need to take out SystemUpdater.apk

    Out of curiosity, what method did you use to root? Perhaps you can try re-rooting... that might also help out your Terminal Explorer experience. Tried and true:
    [MOD][One Click Root] Clockwork Mod version 3.0.0.5/6 - UPDATED FOR EB13! - xda-developers
     

Share This Page

Loading...