1. Are you ready for the Galaxy S20? Here is everything we know so far!

[T-Mobile] Failed during ROM install, now no OS, no boot, nothing. Help me, Scotty!

Discussion in 'Android Devices' started by Slacker20, Jun 30, 2013.

  1. Slacker20

    Slacker20 Member
    Thread Starter

    Background info:
    The phone is a T-Mobile HTC One (PN0713000 T-MOB010)

    I had previously unlocked the bootloader via HTCDev, flashed ClockworkMod, SuperSU, etc etc, and was starting to try out different ROMs. After having Cyanogenmod for a couple days I started performing all the backups via CWM and Titanium, saving the files over to my computer, so that I could try out something else. While attempting to install a stock ROM it failed and left me with nothing but a Cyanogenmod bootloop and the ability to fastboot and get into ClockworkMod Recovery. However, when booting into CWM Recovery it says this and seems to not contain ANY partitions or folders:
    ClockworkMod Recovery v6.0.3.2
    E: Can't mount /cache/recovery/command
    E: Can't mount /cache/recovery/log
    E: Can't open /cache/recovery/log
    E: Can't mount /cache/recovery/last_log
    E: Can't open /cache/recovery/last_log

    Attempting to flash a stock RUU and just get the phone to at least boot and let me start over gave me this:
    [HIGH]C:\HTC One>fastboot flash zip 1.29.1540.3miniruu_tmoible_.zip
    sending 'zip' (951927 KB)... OKAY [ 95.406s]
    writing 'zip'... INFOzip header checking...
    INFOzip info parsing...
    FAILED (remote: 99 unknown fail)
    finished. total time: 95.672s[/HIGH]

    I've tried flashing ROM zips that way as well and keep getting similar errors. I'm not sure when to use adb (hboot, fastboot, recovery, or only a booted OS), but I can't get a response from "adb devices" so I haven't had any luck doing an adb push or adb sideload (from within CWM).

    Please tell me I have some options here... :banghead:

    1. Download the Forums for Android™ app!


  2. zimlokks

    zimlokks Android Expert

    yes yu do, if yu can get into recovery yu have the potential to recover from this.

    have yu tried to do a factory reset via cwm?
    scotty85 likes this.
  3. Slacker20

    Slacker20 Member
    Thread Starter

    Odd, I tried doing that earlier today and it merely rebooted the phone, returning it to a looped CyanogenMod boot animation. Just tried it again, however, and it has seemed to successfully reformatted my sdcard and re-created some folders to work with.

    But now what? How can I get any ROM zip over to the phone if adb isn't working from within fastboot or CWM?
  4. zimlokks

    zimlokks Android Expert

    is adb working while the bootloop is happening? if so it will tell yu the errors, but i think its cache not letting it boot since its not being mounted at boot and it is needed.
    scotty85 likes this.
  5. Slacker20

    Slacker20 Member
    Thread Starter

    I have no idea how or why or what exactly happened, but it just booted into a clean install of CyanogenMod. I am totally confused, but no longer stressed about a potentially bricked phone.
    scotty85 likes this.
  6. zimlokks

    zimlokks Android Expert

    its cache, do you have a backup of the system? restoring it might fix the problem.
  7. Slacker20

    Slacker20 Member
    Thread Starter

    Yep, about to do a restore of my stock 4.1.2 rooted system from last week, then go from there. I miss my OG Motorola Droid's physical SDCard, whose data didn't have to be affected by newly installed ROMs...
  8. zimlokks

    zimlokks Android Expert

    i heard that tha og moto droid is virtually unbrickable
  9. Slacker20

    Slacker20 Member
    Thread Starter

    Unfortunately, my Droid's screen randomly stopped working one day, so mine is no longer anything more than an old, heavy paper weight. May as well have bricked.
  10. zimlokks

    zimlokks Android Expert

    true, hows the restoration going?
  11. Slacker20

    Slacker20 Member
    Thread Starter

    And... now I can't restore using previous backup files. It gives an md5 mismatch error?
  12. zimlokks

    zimlokks Android Expert

    are yu sure that the backups are intact and fully safe?
    scotty85 likes this.
  13. scotty85

    scotty85 Extreme Android User

    not much more to add. typically those errors described in the first post only occurr when you flash the recovery and then try and boot directly to it,without a reboot in between.

    generally speaking,you should not attempt to restore any system apps or data with tibu. only user apps,and some user app data. espeically when going from a sense tom to aosp or vice versa,the frameworks are totally different and will casue all sorts of issues,from app FCs to bootloops to splash hangs

    are your backups from CW? not sure if CW will restore twrp backups.

    for your adb prollem,heres a basic checklist:
  14. Slacker20

    Slacker20 Member
    Thread Starter

    All backups have been made via ClockworkMod Recovery.

    I now have no issues with ADB, able to do push/pull and everything fine when the phone is booted into the OS, but now I'm getting no response from "fastboot devices" when I am indeed in fastboot (not hboot) and connected to the same computer I've been doing fastboot with. After entering the "fastboot devices" command it doesn't even display an empty list of connected devices, it says nothing at all.

    Code (Text):
    1. Microsoft Windows XP [Version 5.1.2600]
    2. (C) Copyright 1985-2001 Microsoft Corp.
    4. C:\Documents and Settings\Brandon>cd C:\HTC One
    6. C:\HTC One>fastboot devices
    8. C:\HTC One>
  15. scotty85

    scotty85 Extreme Android User

    is fastboot in the HTC One directory? sounds like a driver,windows version,or usb issue... the troubleshooting steps above are my best guess.. i dont really have anything above and beyond that.

    youll need to actually try all those things,and not just dismiss them as "it cant be that..."

    ive learned the hard way the value of a simple port switch or pc reboot,and that not all usb cables are created equal ;)
  16. Slacker20

    Slacker20 Member
    Thread Starter

    USB cable hasn't changed since I was using fastboot just fine yesterday, USB port hadn't even changed (I just tried every single one on my laptop though, 4 total, all of them USB 2.0, with no difference). I've uninstalled and reinstalled drivers, installed the modified HTC drivers you listed, uninstalled HTC Sync Manager and no change, reinstalled HTC Sync Manager (and thus associated drivers, again) and no change. The only thing that has changed since being able to fastboot yesterday is that yesterday I couldn't boot into an OS until it randomly decided it would boot into Cyanogenmod again, then ever since then I've been able to use ADB while booted into the OS but no fastboot while in the bootloader. I've also tried multiple ROM installs and CWM restores (4.1.2, 4.2.2, and root/no root variations of all of the above), multiple wipes of cache, delvik cache, and data wipe/factory resets, and still no fastboot response.
  17. Slacker20

    Slacker20 Member
    Thread Starter

    Not sure if it's relevant, but I've noticed that when in bootloader->fastboot, whether the USB is already plugged in when entering fastboot or I connect it after, the "fastboot" status at the top of the screen doesn't change to "fastboot usb" unless I use the volume buttons to scroll through the menu options.

    Also, when HTC Sync Manager is not installed, every time I connect the phone to the computer via USB I repeatedly get pop-up messages asking to install HTC Sync Manager, but then of course when I do have it installed it attempts to open every time the phone is connected and begins searching for media to import; it's driving me crazy.

    My current setup is simply a stock T-Mobile 4.1.2 CWM restore (with all the T-Mobile bloatware and everything), with ClockworkMod Touch Recovery flashed (not merely booted to) and superuser.zip flashed.

    ADB commands work, fastboot commands return absolutely nothing. I can also navigate to the Internal Storage through Windows Explorer and copy, move, and delete files to and from the phone when it's connected via USB while booted. All ADB, fastboot, SDK, etc files have not been touched (as in, everything worked fine a few days ago, and no changes have been made to any such files or locations since then) and still remain in the C:\HTC One directory.
  18. scotty85

    scotty85 Extreme Android User

    sorry youre having such trouble. is htc sync completely uninstalled? ive never been prompted to install sync manager. :eek:

    still nothing above and beyond the checklist. one of those things has got to be not correct/changed somehow. if the phone is in fastboot(displaying fastboot usb at the top),and correct drivers are installed for your OS my gut feeling is something running on the PC. sometimes its a program that wants to communicate with the phone,sometimes its an antivirus,spyware,or similar program.

    what windows version/bit system are you using?

    have an old laptop or other pc you can try?

    if you open device manager,place the phone in fastboot,then plug in... do you get "found device" noises? what pops up in device manager?
  19. Slacker20

    Slacker20 Member
    Thread Starter

    I've gotten it to work... kind of. Sometimes I'll get both adb and fastboot responses, sometimes I'll only get one or the other, sometimes neither will work. When one or the other doesn't work, I can now usually get it to come up after a few disconnects and reconnects of the USB cable, reboot of the phone, or reinstall of the drivers.

    The computer is a 2007 Asus G1 gaming laptop (my One is twice as fast and has the same 2GB of RAM, lol) running a dual boot of Windows XP and Linux Ubuntu. I don't have any other computer to try, unfortunately. HTC Sync Manager is completely uninstalled, and multiple computer reboots have been made since then and confirmed it's still uninstalled. I've installed and reinstalled the separate HTC drivers multiple times, by both running the .exe as admin and also manually via Device Manager.

    Also, when connecting or rebooting the phone, I get multiple "device connected" sounds, but sometimes it sounds like it connects and reconnects rapidly several times before ultimately either giving a response through adb or fastboot or giving no response at all.

    It almost seems like the drivers aren't wanting to stick. I don't know.
  20. scotty85

    scotty85 Extreme Android User

    well,i wish i had some better advice or a solution. :( im not quite sure what to think,either... i will continue to mull it over and let you know if i can think of anything else.

    is there another pc at friends house or somewhere you could check out sometime?
  21. Slacker20

    Slacker20 Member
    Thread Starter

    Unfortunately not at the moment. I'm a full-time student (taking those HORRIBLE 1- and 2-month summer classes) and I also work, so my free time is rather nonexistent for now, hah. Can ADB and fastboot be setup on Linux? I hate using my Windows partition, it never does anything correctly and is quite laggy, far slower than my Linux partition. I always use Linux unless I absolutely have to boot into Windows.
  22. scotty85

    scotty85 Extreme Android User

    sure. you can absolutely use linux instead of windows. youll have to set up adb and fastboot a bit differently,and the commands are a bit different. if youre fairly proficient with linux it should be no prollem :)

    cant seem to find some links i thot i had atm,but some googling should help you out. :)

    heres one of them: http://androidforums.com/evo-4g-lte-all-things-root/671150-mini-sdk-all-rooter-needs.html

HTC One M7 Forum

The HTC One M7 release date was March 2013. Features and Specs include a 4.7" inch screen, 4MP camera, 2GB RAM, Snapdragon 600 processor, and 2300mAh battery.

March 2013
Release Date

Share This Page