1. Download our Official Android App: Forums for Android!

Root T Mobile G1 rooting issue

Discussion in 'Android Devices' started by asanga, May 31, 2011.

  1. asanga

    asanga Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    May 23, 2011

    May 23, 2011
    8
    0
    25
    Hi Guys, I'm new to this forum and this is my 1st thread.

    I have a T mobile G1 which came with RC32 (android 1.6) and I wanted to root it so that I can upgrade it to android 2.1.

    Now I went by the guide I found on the internet and managed to downgrade it to RC29

    I'm not sure if obtain root access via telnet and Flash recovery.img using telnet command were done properly , because I get this (see pic below) when I tried to Install Radio image.

    Can anyone tell me what has gone wrong, :thinking:

    I formatted the micro sd card to fat32 and renamed it to sdcard. not sure if that has something to do with.

    Thanks in advance.

    [​IMG]
     

    Advertisement

  2. sdrawkcab25

    sdrawkcab25 Android Expert
    Rank:
     #64
    Points:
    423
    Posts:
    5,589
    Joined:
    Aug 5, 2010

    Aug 5, 2010
    5,589
    2,005
    423
    Male
    PA
  3. asanga

    asanga Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    May 23, 2011

    May 23, 2011
    8
    0
    25
    Thanks for the link, I followed that but still had the same issue where every time I reboot after flashing custom recovery image through Telnet, it goes back to stock recovery for some reason. see the pic below
    [​IMG]

    This is the telnet page I see
    [​IMG]

    Finally i managed to flash the custom recovery (recovery-RA-dream-v1.7.0.img) via USB debugging and it worked. But once I updated the Radio (G1-radio-2_22_23_02) and DangerSPL it got stuck at G1 screen and never got to install CyanogenMod. After waiting for about 30mins I removed the battery and had to run the DREAIMG.nbh to recover from it. Now I'm back to square 1 with stock recovery . Its so frustrating!:mad:
     
  4. asanga

    asanga Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    May 23, 2011

    May 23, 2011
    8
    0
    25
    Update: Followed this method http://androidforums.com/g1-all-things-root/12637-root-guide-stock-2-cyanogen-update-rom.html

    Reformatted SD card and Managed to re-flash recovery (cm-recovery-1.4.img) and SPL, ROM (1.6 Recovery Image" signed-dream_devphone_userdebug-ota-14721) and CM (update-cm-4.2.15.1-signed). All good now. :) One thing I did wrong during recovery flash via Telnet is not leaving spaces at right places in command lines !

    Now if I want to upgrade to CM6 can I just re-flash it or do I have to downgrade to downgrade to RC29 ???

    Thanks guys
     
  5. daswerk

    daswerk Lurker
    Rank:
    None
    Points:
    5
    Posts:
    1
    Joined:
    Jun 2, 2011

    Jun 2, 2011
    1
    0
    5
    If you get it to work, please post.
    I tried numerous times and never could get things to work right.
    Finally got CM installed but never could get the new app market.
    Finally, went back to stock G1 1.6 and used the one click root program.
    So I have root and able to use programs like setcpu to speed things up.

    I finally got CM6 to work too. It was over the DangerSPL.

    Figures, get the trusty G1 updated just before the release of the new HTC this month for T-Mobile. Really would like to try that one if it works out.
    (Went through two G2's that didn't work right - then back to the G1)
     
  6. asanga

    asanga Lurker
    Thread Starter
    Rank:
    None
    Points:
    25
    Posts:
    8
    Joined:
    May 23, 2011

    May 23, 2011
    8
    0
    25
    Ok, I managed to upgrade to CM6 without any issues , all went smoothly.:)

    I upgraded exiting hardSPL to DangerSPL before flashing cm6 as thats what recommended for CM6.

    My radio is 2.22.19.26i and I did a Wipe data/factory reset before flashing cm6,
     
Tags:

Share This Page

Loading...