1. Are you ready for the Galaxy S20? Here is everything we know so far!

[T-Mobile] S4 Help needed (Warning: Long story)

Discussion in 'Android Devices' started by Subzero9775, Sep 22, 2014.

  1. Subzero9775

    Subzero9775 Lurker
    Thread Starter

    Hey guys, let me just start off by saying I have spent almost 8 hours straight today trying to figure this out and dig myself out of a hole I've created for myself, that being said, I'm going to try and be as detailed as possible so you guys know EXACTLY where I am and what I've tried. This post looks long but that's because it is. It's pretty much my entire day's worth of trouble typed out. So just bare with me and see if you guys can help me out here!

    I have a T-Mobile Galaxy S4 model: SGH-M919 it has Android 4.4.2. Now on to the problem: I've had this phone for almost a year now and a few months ago I rooted it. Did a simple Youtube tutorial and used Odin to do the work and everything worked out fine. A couple months down the road (yesterday), after using the phone like a teenager, downloading apps and cluttering it up it started to slow down and not run some apps. After thinking about it I decided to factory reset it. All of my contacts, photos, and videos were backed up on Google so I thought "why not?" Well, this is where $#!% hit the fan.. being rooted then factory reset, right before the phone came online it had me answer two questions about the root. Something to the effect of "Do you want to keep root? (This option is not reversible)" I thought since I wasn't using the features I originally rooted the phone for I figured nah just get rid of the root. So the phone did its T-Mobile boot up and started the Initial setup.

    Everything up to to this point was fine until I wanted to log in to my Google account during the setup. Please understand that where I am I have full 4G LTE coverage and have access to a pretty fast and sturdy wifi connection. Well, when it came to the google sign in I entered my email and password and it came up with a message reading "Can't Sign in - Can't establish a reliable connection to the server" (believe me i wish that was the only issue) so after reading that, I thought I'd try with my wifi.. nope. Same thing. Since neither my 4g or wifi worked I thought it was Google's servers so I tried again this morning, same thing. (keep in mind at this point i think my phone isn't rooted anymore.) I call the t mobile store and they give me a technical support number, so I call it and I tell them i cant sign into Google. The gentleman told me he cant do anything because he can tell my phones been rooted. Only thing he suggests is to contact Google, well, the customer care number just tells you go to google.com/support and there's nothing there about my problem.

    This is where I dig my hole even deeper. I tried another factory reset and up in the top left corner i still see that root text. Even the rooted android symbol pops up before the Samsung logo or t mobile. Since I saw that I thought "ohh it just didn't get unrooted all the way." I look up ways to completely remove a root and a lot of them require plugin your phone into the computer and using Odin to flash a stock firmware on to the device. I went to plug my phone into the usb port but my computer didn't recognize the usb device, having experienced this a long time ago I searched around for the latest Samsung usb drivers and I installed those. Device still isn't recognized. Let me just note before people tell me to use MTP mode or Developer tools> usb debugging or connection mode.. The only thing that happens when plugging my phone via usb is the phone starts charging and my computer makes the trumpet noise like something is plugged in. Other than that, there is NO notification of it being plugged in. The reason i stress this is because I called Samsung technical support at this point and the guy (not gentleman) treated me like a 5 year old and ran me through all of these options after i told him I already did everything he was suggesting, including downloading Samsung Kies 3 and having it install the drivers. It does not pick up the device either.. at this point I looked up ways to remove the root without the computer. I found out you can just go into the root app "SU" or something and theres a remove root option. I jumped on that opportunity and had it removed. I restarted the phone and all the problems still persist, it even still has the root text on the top left when you factory reset it again. However now, even if you factory reset and select the option "keep root," thinking it would bring back the"SU" app it does NOT.

    So lets recap. I have a phone that thinks its rooted and even appears rooted to t mobile but doesn't have any of the root apps or privileges or capabilities to fix my Google log in issue (like the host file in filemanager). And I can't re-root to get that app back because none of my 3 usb ports, 3 different usb cables (one being the cord that came with the phone), or any of the ports/cables on someone else's computer will recognize the darn thing to work on that way! I have all these issues that are supposed to fix each other but I can't do any fixing because they cancel each other out too... I'm at a dead end.

    In case this isn't the right forum/website/thread/post area etc.. I have this whole message saved in Microsoft Word document so I can repost it anywhere you guys might suggest better results. Any help/advice will be much appreciated.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

  3. Subzero9775

    Subzero9775 Lurker
    Thread Starter

  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!!

    i would look into getting a custom recovery on your phone. first since your phone cannot communicate with your pc you can try using airdroid to transfer the recovery file over to your phone....or you can use an sd card, hopefully you have an sd card reader.

    with recovery you should be able to flash a custom rom and hopefully that should fix your issues.....as it sounds more software then hardware and all a custom rom is is software.
     
  5. Marc_G

    Marc_G Well-Known Member

    There are a couple things to consider:

    1. If you have a proper PC, with working USB2 ports, and a good cable, it doesn't matter what is going on with the phone software wise, since to use ODIN, you boot the phone into Download mode, which has nothing to do with any ROM or even stock/custom recovery you've installed.

    2. So, Presuming no hardware failure with the USB port on the phone (which doesn't sound like the case here), and if you've put the phone into download mode, and ODIN isn't recognizing it, then you've got a problem with the PC / Windows / Drivers / Cable. It's not the phone.

    Your best bet is to go to the XDA forum and seek help there... there's a lot of activity there, and many helpful people. Here's a link:

    T-Mobile Samsung Galaxy S 4 Q&A, Help & Troubleshooting - XDA Forums

    Read the directions and post in the proper place, such as the newbie friendly help thread.

    Good luck! And don't worry... we've all been there with a reluctant phone. When you figure out the problem, you'll probably find out it was something simple.

    Marc
     

Samsung Galaxy S4 Forum

The Samsung Galaxy S4 release date was April 2013. Features and Specs include a 5.0" inch screen, 13MP camera, 2GB RAM, Exynos 5410 Octa processor, and 2600mAh battery.

April 2013
Release Date
0
Reviews
Loading...

Share This Page

Loading...