1. Are you ready for the Galaxy S20? Here is everything we know so far!

Tablet wont connect to google play.

Discussion in 'Android Devices' started by Blarghed, Jan 11, 2013.

  1. Blarghed

    Blarghed Lurker
    Thread Starter

    Help please.

    I have a Freelander PD20-D tablet.

    I was able to connect to google play a couple of days ago, then the day after i couldnt connect.

    The wifi is working fine, i can use the browser, check my gmail, and use apps that require internet. But whenever i try to open google play is shows the loading screen , then i get a did not connect. It is also linked with youtube, i could not log into my account, it just showed the loading and no connection.
    I have no sure idea what caused this. The day before this happened my SD card said it was full, so i started removing apps that i downloaded.

    Im thinking of factory resetting, but i dont want to loose my current game data, or if the problem still persist after factory restore i might be s.o.l. and cant download my purchased games from play store.

    1. Download the Forums for Android™ app!


  2. mikedt

    mikedt 你好

    Did you buy it from a Chinese wholesaler or Ebay, shipped from HK or Shenzhen?

    I think I know the one, it's a cheapo Chinese device, manufacturer unknown. And what's apparently happened is the manufacturer has hacked Google Play in, i.e. it doesn't officially have the Play store. More than likely they haven't tested it properly and is now giving problems. You could try a factory reset. Failing that, suggest you send it back for a refund.
    Blarghed likes this.
  3. Blarghed

    Blarghed Lurker
    Thread Starter

    Yeah i did buy it from ebay and it is chinese.

    Damn i hope when i factory restore it fixes it. if not i can still use it...
  4. franktko

    franktko Lurker

    I'm skeptical about the Hacked Play Store story. You don't have to have the Play Store "officially", this is all open platform and Google welcomes any manufacturer. And last thing Goggle would want is to NOT have the Play Store on the device.

    It seems like it happened to all PD-20 in the last few days. I don't think a factory reset will fix your access.

    I noticed that my version of the Store on my PD-20 is 3.5.15 but on my mini cube it's 3.10.10 and working fine. It's seems like the Google Play Services are also missing from the PD-20. I will check into that...
  5. franktko

    franktko Lurker

    The problem has been found and you can fix it yourself but it's a bit tricky. See this thread: PD20 Google play issues

    It's an entry in the etc/hosts file that no longer points to the correct server. I removed the entry from the host file on my PD-20 and I'm back connecting to Google Play.

    It's tricky because you don't have permission to edit this file. In that thread, they explain that you need to root your tablet to be able to edit the hosts file. What I did instead is use ADB from the Android SDK (Android Debug Bridge | Android Developers) to open a shell on my PD-20, remounted the /system folder to give it write permission and then I was able to edit my hosts file. My tablet is not rooted.
  6. mikedt

    mikedt 你好

    Actually you do, as I will try to explain. :)

    Yes..but however: Google for various reasons (mostly disagreements with the Beijing government), doesn't really have much to do with Android in China. Where most of these off-brand/non-brand devices come from and are used, and are usually sold on Ebay and by Chinese wholesalers, e.g. the Freelander. That's why I posted "Did you buy it from a Chinese wholesaler or Ebay, shipped from HK or Shenzhen?"

    Android itself is completely open and anyone can make a device based on this OS. However Google Play and associated Google apps are not open, they're proprietary.

    Devices have to go through some compatibility tests and the manufacturer has to sign an agreement with Google to get the Play Store officially on their devices, "with Google". That costs money, effort and time. So many anonymous Shenzhen Android device makers don't really care and can't be bothered to go through that. Their devices either just don't have Google Play at all, or it might be hacked in sometimes, with little or no regard for testing for compatibility. That's probably why the OP was having problems, and the fact you've had to hack the thing yourself to make it work, by following instructions found on some Shenzhen wholesaler's forum.

    Android Compatibility | Android Open Source

    "If you are building a mobile device, you can follow these steps to make sure your device is compatible with Android. For more details about the Android compatibility program in general, see the program overview.

    Building a compatible device is a three-step process:

    Obtain the Android software source code. This is the source code for the Android platform, that you port to your hardware.

    Comply with Android Compatibility Definition Document (CDD). The CDD enumerates the software and hardware requirements of a compatible Android device.

    Pass the Compatibility Test Suite (CTS). You can use the CTS (included in the Android source code) as an ongoing aid to compatibility during the development process.

    Joining the Ecosystem
    Once you've built a compatible device, you may wish to include Google Play to provide your users access to the third-party app ecosystem. Unfortunately, for a variety of legal and business reasons, we aren't able to automatically license Google Play to all compatible devices. To inquire about access about Google Play, you can contact us."

    Also FYI..


    BTW Freelander PD20-D screenshots.
    freelander1.jpg freelander2.jpg
    Hands up anyone who uses, Baidu, Baidu Tieba, Baidu Maps, QQ, Weibo, RenRen, Ctrip, Qihoo, JingDong and HiMarket?
    ocnbrze likes this.
  7. Ah, well, to get beyond the "buyer remorse" notes and on to an actual Solution ...

    Go to the pandawillforum page below and look for "astroman" 01-23-2013, 04:24 PM. He is the +++HERO+++ who put together a simple solution which does an "Upgrade" for to fix text in one file.

    PD20 Google play issues - Page 6

    This corrects an entry in /system/etc/hosts file for Google Play which was improperly hard coded to an IP address that Google recently changed away from. Some tablet vendors had this "bad code" in their builds and are therefore vulnerable to this. "Can't establish a reliable connection" is Google's way of saying "Host not found". The solution is "simply" to remove or comment out that line so that DNS can properly do its job, but editing the hosts file is difficult given the security the devices are created with.

    He says "Use at your own risk", which I agree with. It is mentioned for ICS 4.0.3 on a particular PD10 or PD20 tablet, but I have NO idea if it is universally usable for other vendors / releases - he says he thinks so... All I can say is that I tried it in desperation on my PD20 and it worked for me first try; was done in 5 minutes. No rooting or fancy toolkit loading needed. If you haven't already, DON'T Factory Reset your phone. I already had before I found this, so I'm having to restore everything - Yuck...

    For what it is worth, I submitted a support call with the Chinese retailer, and they responded with a link to GetJar. They didn't even try to fix it, and basically just gave up and advised using a different service. I thought that was rather lazy as the actual solution is quite simple once you understand it...
    ocnbrze likes this.
  8. Blarghed

    Blarghed Lurker
    Thread Starter

    Thanks!! Finally a solution to all this mess has been found.

    Unfortunately i already factory restored back in january when there was no solution.

    Ive yet to use the update file yet because i dont want to reinstall the ton of apps i put on already. But i will when ready. Finally hope that i can use my purchased apps!
  9. junkes

    junkes Lurker

    Owners of these Tablets will have been having problems with Google Play and Gmail - this was caused by a chage that Google made to a server address, which was in 'hosts' on the Freelander PD10 and freelander pd20 Tablets. Though various solutions have been suggested, I have found that the following, copied from the Pandawill Forum is a really easy fix - thanks to a man in Greece, Astroman! I have used this on 2 Freelanders, with success.

    'Google has from 27/12 a specific list of branches that are compatible with play store and gmail. Finally I found the most easy way now to fix my tablet. I have an olympic PD10 that works fine and I believe this solution works for all. I uploaded a file here update.zip named update.zip Download this file on your pc and then connect your tablet through a usb cable to the pc. Drivers are not necessary. Select to see it as a hard drive. Just copy update.zip to the root (not in a folder) of your tablet. Disconnect it and go to settings -> about -> system update -> install system update -> from nand storage. After the reboot you are ok.
    (Use on your own risk)'
    ocnbrze and mikedt like this.

Share This Page