1. Are you ready for the Galaxy S20? Here is everything we know so far!

Tablets lose connection when assigned static IP

Discussion in 'Android Lounge' started by oas51, Oct 14, 2014.

  1. oas51

    oas51 Lurker
    Thread Starter

    I have a mix of tablets, different brands/models, with the same issue on each one. The majority of the tablets are HP Slate21's.
    I have a Windows network/domain, and wifi access points around the building connected to it. My tablets fully connect to the wifi (able to access both intranet and internet sites) when set to DHCP, but when I assign them a static IP, they drop connectivity. The wifi actually still shows as being connected, but not active, no access to either intranet or internet.
    I'm assigning them open IP's so there is no conflict there.
    I've tried the IP of the wifi router as the "Gateway", as well as our actual domain gateway, and including/not including DNS 1 and DNS 2... any combination of settings I could think of, all with the same result.
    As soon as I reset them to DHCP, it picks the connection right back up.
    If anyone can give me any insight as to how I get this working, I'd really appreciate it. Thanks.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. girolez

    girolez Often Off Piste

    Hi and welcome to the forums! :)

    Sorry if this is too simple, but have you assigned the static IPs to the devices mac addresses from the router management software/interface? You can't AFAIK assign static IPs from the device itself.

    Roger
     
    oas51 likes this.
  3. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    You can if MAC access control is disabled on the access point. If it is enabled, then you'd need to add each device's MAC address to permit access. If you have the model number of the router and the firmware version handy I can look it up and tell you how to add them.
     
    oas51 and girolez like this.
  4. oas51

    oas51 Lurker
    Thread Starter

    Thanks, I appreciate the replies.
    If it's a router issue, I can take care of that. I thought just setting the IP on the tablet would be enough, was thinking it worked like it does on a pc. Thanks!
     
  5. lunatic59

    lunatic59 Moderati ergo sum
    Moderator

    IF your PC's are wired, then most likely your router isn't filtering access by MAC address. IT's actually the wireless security that is blocking the connection.
     
    oas51 likes this.
  6. Slug

    Slug Check six!
    VIP Member

    Double-check that the IP addresses chosen are not assigned to the router's DHCP pool.
     
    lunatic59 and oas51 like this.
  7. oas51

    oas51 Lurker
    Thread Starter

    I figured it out. I had the network plugged into the WAN port on the router, which I'd also set the IP for. Just had to switch the plug to a LAN port, reset the IP on the LAN setting, and the tablets took the IP's.
    I spend so much time with this stuff, sometimes I can't see the forest from the trees. I appreciate all the help, sometimes it takes bouncing the problem off someone else to shake it loose in my own head. Thanks again!
     
    girolez, Slug and lunatic59 like this.
  8. Slug

    Slug Check six!
    VIP Member

    I think many of us have been in a similar place. I once spent two days fruitlessly troubleshooting a network issue before realising that the cable from the PC wasn't one actually connected to the router! :eek: Now every hard-wired device uses a differently-coloured cable.

    Glad you got it sorted.
     
    lunatic59 and oas51 like this.
Loading...

Share This Page

Loading...