1. Check out our companion app, Forums for Android! Download from Google Play

Root Tether through my AscendII

Discussion in 'Android Devices' started by timpolo, Mar 6, 2012.

  1. timpolo

    timpolo Member
    Thread Starter

    Mar 4, 2012

    I have tried rooting my new Huawai AscendII quite a few times with no luck. My question is this: Do i have to root the phone in order to tether via the usb cable? I have the Droidx and have not root the phone but able to tether without my carrier blocking me like Cricket is on the Ascend. I can always root the phone later but was wondering if anyone has had any success tethering without rooting?!

    THanks in advance,


  2. Pikidalto

    Pikidalto Active Member

    If I recall correctly, the Muve update has tethering enabled by default, it should be in Settings under "Wireless & Network".

    Another option is to try fastboot or ADB -- you'll need to get the build.prop file off of the phone, edit it to enable tethering (it's just one line), then upload it to the phone. I don't know enough about fastboot and adb to tell you how to do it, though.

    Without installing the Muve update, the easiest way is to root the phone and use a file manager such as Root Explorer that has a text editor built in (or use a terminal emulator, su to root, and use a command line text editor, this still requires rooting the phone).
  3. timpolo

    timpolo Member
    Thread Starter

    Mar 4, 2012
    The main problem i am having is not being able to root the phone! I have followed the instructions of some of the folks on this forum and it has not worked yet. The phone has 2.3.5 installed on it; in fact that is what came with the phone. I have not read if anyone has sucessfully rooted this phone yet. It seems like 2.3.3 folk have been sucessful. I purchased the phone a few weeks ago. Maybe it is to new of a release? Not sure. Do you have the Huawei Asxcend II with 2.3.5? It is on Cricket network. I have downloaded super one click but have not tried it. Not to familiar with this program and not too sure if it is only for specific phones or all in general. It does not seem that difficult to root a phone. Sort of like updating firmware on devices. Are you familiar with super one click?
  4. DWILSON48625

    DWILSON48625 Well-Known Member

    Nov 30, 2011
    Harrison Mi
    I used the following method on 2.3.6

    Download Poot.apk (mine was labled .zip, renamed .apk)
    Download Ministro II.apk (again, renamed it to .apk)

    Run poot, it will open minestro automatically.

    Tap "press to Poot" after it downloads the files.

    Tap the root checker button. Should find su/ ....

    I then tapped "get super user". This goes to playstore for that.

    Download, then reboot.

    Should have root.

    I attached the files. Just delete the .zip and change to .apk, then tap to install. Install both, then run Poot.

    Attached Files:

  5. jefboyardee

    jefboyardee Well-Known Member

    Jan 18, 2011
    No. I've never rooted and use Klink - Tether without root. Just plug it in, turn on USB Debugging, launch Klink on the droid and PC, works great. Slow on 3G, but steady.

Share This Page