1. Are you ready for the Galaxy S20? Here is everything we know so far!

The 'Insufficient storage available.' problem

Discussion in 'Android Devices' started by dellboyy, Apr 29, 2012.

  1. dellboyy

    dellboyy Lurker
    Thread Starter

    Hi, i've an unrooted HTC Desire S, with about 96mb free on the internal storage, and plenty on external. Ever since either the android system software upgrade, or google play i've been getting the 'Insufficient storage available.' message at random when trying to install apps, obviously i have storage available so this isn't the problem.

    I understand this is now quite a common error with android, and looking across the net have found endless solutions, none of which seem to work.

    Has anyone got an official fix for this yet?

    On another note, my gmail app has started to not receive new mail at all, even after reinstall it works for a short time before stopping to receive again, related in any way?

    Problems with this software seem to be growing day by day!

    1. Download the Forums for Android™ app!


  2. dellboyy

    dellboyy Lurker
    Thread Starter

    Guessing nobody has any ideas on this one?

    I've sent an official support request to Google relating to Google Play. So far they've just sent the usual clear cache etc steps that don't work. If they manage to find a fix i'll post it here.
  3. Sefi

    Sefi Lurker

    I'm starting to have this problem too when I move apps to SD with the free space thing in storage settings, if I try to move more than one app at a time it tells me the SD card has insufficient space, even though there is over 1gb
  4. rtX

    rtX Lurker

    I am getting the same problem with my HTC Desire. It is really frustrating. I cannot even update the applications I have already installed. Come on Google this needs fixing urgently!
  5. lammylott

    lammylott Lurker

    I'm getting this problem too, even when trying to update apps. Plenty of internal storage and space on the SD. It's getting to be rather frustrating :mad:
  6. jdthepig

    jdthepig Lurker

    I have the same problem with my HTC Amaze. It started about 1-2 months ago. I received the Ice Cream Sandwich update last night with high hopes it would resolve the problem but it did not.
  7. nagendragpu

    nagendragpu Lurker

    only solution for this u have to again root the mobile then install app2sd(rooted version)
    you will find it in google play...after installing app it shows number of apps installed in phone memory.
    select one app and move that to sd using app2sd app It will forcibly move the app to your external.

    It did worked in my rooted phone,let me see it worked on your mobile
  8. jmckean

    jmckean Lurker

    I am getting it too. Droid X, Gingerbread stock. It happens sometimes when installing a program and often when updating. Sometimes it will fail, but when I try a few times, it will work.

    I have more than 1 GB available in internal storage and 8 GB on the SD card. But my RAM is constrained. Although the specs for my phone shows 512 MB of RAM, I am showing about 384 MB. Applications seem to hold onto RAM even after they are closed. Killing apps frees some up, but it quickly refills.

    I am going to guess that a memory management function is trying to efficiently use most of the available memory, releasing it only when a more active program wants it. But there is a problem with the installation and/or updating process that causes it to not understand that memory could be available and throws the error.

    Total speculation, of course.
  9. how do you "clear cache"?
  10. Drzaid

    Drzaid Lurker

    to solve this problem, use "root explorer" app and search for file with the same program u want to install it. Then delete them. now you can install the app.
  11. I had this problem on my Droid X. I tried all the suggestions (clearing market cache, rebooting, etc) and nothing worked. I finally just went into manage applications and cleared the cache individually on all my downloaded apps. I'm not sure if there is an easier way to do a mass clear cache, but it didn't take me very long to do. Went back to the market and all is well. Able to update my apps now, even the huge latest Google Maps update. Hope this helps.
  12. iamtechlover

    iamtechlover Lurker

    download app "Android Assisstant" from google play store...it has option of clearing all cache :)
  13. syztemlord

    syztemlord Newbie

    I have found a solution to this. I used Root Explorer and went to data/app in there I found an .ODEX file for the app I was trying to install. I deleted it and was then able to install directly from Play store. Hope this helps.
    Psalm23UK likes this.
  14. Bizwaz

    Bizwaz Lurker

    Hi dellboyy. I fixed this problem on an HTC Wildfire by going into SETTINGS / SD and phone storage / Make more space. By following the process, along the way, I was given the option of moving some apps from my SD card to my external memory card. This did the trick. Hope this helps (somebody).
  15. Psalm23UK

    Psalm23UK Lurker

    After trying loads of fixes this one is the only one that worked for me, seems some apps leave a trace behind which stops you reinstalling the app again until you remove .ODEX file.

    [SOLVED] for me anyway!
  16. gabrielus018

    gabrielus018 Lurker

    [SOLVED] works for me too. Can only delete the .ODEX file with Root Explorer (the others didn't see it).
  17. shaanigr8

    shaanigr8 Lurker

    HI.. well for me.. first i moved all application into sd Card.. then.. i clear all cache from sd card and phone memory.. after that.. go to google play and clear search history data.. then uninstall google play and install it again.. it works for me...
  18. codeandcake

    codeandcake Lurker

    Clearing the cache of the app in question worked for me. This time, anyway :)
  19. olbriar


    Hello codeandcoke. Welcome to Android Forums. Have fun...
  20. ThiSidUp

    ThiSidUp Lurker

    Absolutely nothing has worked for me. Cleared cache . . . looked for single .odex files (none not connected to an .apk) Can't run app2SD on my note 2 . . . fixed permissions . . . I've done every "fix" I have found on several forums and still nothing. Now the phone is going into some kind of sleep mode when it sits for more than 15 minutes and won't wake up unless I pull the battery.
  21. maclro

    maclro Lurker

    Same problem. Tried all the obvious fixes like low storage wizard, clearing caches, uninstalling apps. No luck. Eventually tried to install root explorer as recommended on this thread, but I can't because I apparently have insufficient storage available. Grrrr!
  22. hexplor

    hexplor Lurker

    Ok guys, after suffering disk storage error i found finally a way how to do that. I know this thread is kinda old but someone may suffer similar problem. So to fix above error you have to install or run (if you have already installed) an root browser, it can be "Root Browse" or any other app which can browse or manipulate root file.
    Then go to: data/app-lib and delete directory containing your app name, for example: com.facebook.pages.app-1

    This fixed issue for me when i was getting storage notice with youtube and facebook apps.

    Good luck :)
    tarani likes this.

HTC Desire S Forum

The HTC Desire S release date was March 2011. Features and Specs include a 3.7" inch screen, 5MP camera, 768GB RAM, Snapdragon S2 processor, and 1450mAh battery.

March 2011
Release Date

Share This Page