1. Are you ready for the Galaxy S20? Here is everything we know so far!

The Official One-Click Rooting Solution for Droid Thread!!! :D :D LATEST: V2.0.4

Discussion in 'Android Devices' started by RDKamikaze, Sep 15, 2010.

  1. JoseyWales

    JoseyWales Lurker

    Doesnt the Androot app root 2.1 and 2.2 in a click of a button?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    @Hercules - No, it doesn't make a backup as that's why I recommend it if you know how without being rooted in advance. It's not required though, as this root will not delete any of your data/apps/etc. and will not brick your phone.

    @JoseyWales - Never heard of that, but since there's a bunch of interest in this thread I would venture to say probably not.
     
  3. d0nutd0n

    d0nutd0n Lurker

    Was able to root on first attempt, Thank you!!

    Edit: Installed Rom Manager and says I'm not rooted, any advice?

    Didn't realize you had to reboot while still connected to the computer, works now!
     
  4. CRAWLR

    CRAWLR Lurker

    Well, I have been reading this thread all night and just when I was about to try it, 2.0 showed up so I decided to try it. It installed the Motorola drivers perfectly but then just sat at a window that said "root me" for a few minutes, then said it was done but it didn't actually do anything. So then I tried 1.8 and the first time it ran, durring the 70 sec delay I got 'device disconnected', 'found new hardware', 'new hardware installed with errors', and a couple other messages that went by too fast to read, then it finished but didn't root the phone. Kinda wierd, but I figured what the hell, I'll try it again. The second time worked perfectly! Thank you for this! I can't wait to tell my friends how to get the wi-fi tether back! (thats the only thing I used the root for before I lost it with the update) Now that I'm feeling confident, I think I'll try some roms. I'll send you a little something for your efforts :)
     
  5. kratos

    kratos Back on my throne!!!
    VIP Member

    I have heard that Androot and Easyroot don't root the phone properly (No matter what version Android you are on). Those apps don't set the recovery up properly during the rooting process and the phone then resets the recovery. The people who have started threads on this forum about this issue have gotten their phones fixed, but it was a very painful and time consuming process.

    My suggestion is to use the "manual" rooting techniques. This process uses the "manual" process with ADB, but simply automates it. This Dev is working very hard to make this process as automated as possible, but also sticking to the tried and true way in order to avoid any problems later on.

    Kratos
     
  6. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    Thanks for your donation, you rock!!! The beta 2.0 should give a couple dialog boxes asking if you are sure you want to continue and asking if you have drovers installed or not. Then it will sit for a couple minutes and root in the background. I am still working on figuring out the progress bar at the bottom so you know how far along your rooting is. Then a new window should pop-up saying rooting is finish, please check for superuser and run again if not there.

    Droids are hard to post on ;)
     
  7. OMJ

    OMJ Bazinga

    universal androot and easy root do root the phone properly. They use a different exploit but in the end accomplish the same thing as rageagainstthecage does. The only thing they dont do (universal androot may do it I forget) is stop the script that causes the stock recovery to come back. That can be an annoying issue and has caused some major issues for some.

    But anyway both easyroot and universal androot will not work on the most recent froyo builds like FRG22D
     
    kratos likes this.
  8. kratos

    kratos Back on my throne!!!
    VIP Member

    That's what I was trying to say, but I guess it didn't come across quite right. Thanks for clarifying this for me.

    Kratos
     
  9. Hercules

    Hercules Well-Known Member

    So can you install the recovery image before rooting? Or are you just talking about making a backup of the apps installed. I didn't think you could do a nandroid before root.
     
  10. ejbaca03

    ejbaca03 Lurker

    RDKamikaze, I have tried both 1.8rA and 2.0 and still dont get the Superuser icon in tray. I dont understand how I could not have rooted if I follow the directions to a T. What next?
     
  11. ejbaca03

    ejbaca03 Lurker

    OK, I got it working. This is what I did. I had to delete the souproot folder. I then tried 2.0 again and that didnt work so I deleted the folder again and ran 1.8rA and finally, Ive got root. Thank you very much for creating this program for us to use. Your work is awesome.
     
  12. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    @ejbaca03 - Thanks for the input on how you got it working on your computer. The 2.0 beta release has a cmd that deleted the souproot folder before anything hpapens, so that's weird why you had to delete and try on 1.8rA. I'll look into that, would you mind PMing me all the versions of SoR you tried? That might help me debug the problem for you (and maybe others).

    Also everyone, I just got an idea!! I'm going to incorporate a log file that gets emailed to an email I'm creating with the cmd process as it's good to see what specific commands are going right/wrong where for who. If you don't mind, that would help me solve issues a LOT faster!! I'll have to include a textbox in the GUI where you put your username before rooting, just put your AndroidForums username there so I know who sent it ;)
     
  13. CRAWLR

    CRAWLR Lurker

    The way you describe 2.0 is exactly how it ran, but it didn't do anything to the phone. In fact for the hell of it I tried to run it without the phone connected and it ran exactly the same way again.

    Just to be clear, the first time it ran, I clicked 'no' when it asked about the drivers and it installed the drivers then went through the whole process, then the second time I ran it I clicked 'yes' for the drivers and it went through all the steps you described again with the same result. Then I tried it without the phone.

    Thats when I decided to use 1.8
     
  14. Mrdroid921

    Mrdroid921 Android Expert

    When you do this, is it hard to unroot?
     
  15. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    @CRAWLR - Open up cmd.exe manually (Start > Run > cmd.exe) What does the title bar of the cmd window that comes up say? (ex. Mine says "Administrator: C:\Windows\system32\cmd.exe")

    @Mrhorology - unrooting is easy, but you have to reflash in RSD Lite the factory ROM if you want to remove all traces of root. Recommended to make a backup in ROM Manager first if you do so. There are ways to "remove root" AFAIK but those don't delete all traces of it.
     
  16. ejbaca03

    ejbaca03 Lurker

    No, it is not hard to root using this method. Oops sorry didnt read the post completely.
     
  17. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    @CRAWLR - I found my mistake,m I set the value for what my[/i] command prompt shows haha!!! I set up a function to find your cmd now (which means it will actually do something) ;)

    Nobody else try 2.0 beta, I'm going to upload 2.01 beta after I tweak a few things :)
     
  18. zandroid

    zandroid Android Enthusiast

    Will 2.01 be easy enough to just download and do it, or do i still need to download the moto drivers? Im on a mac now, waiting to get home for the windows machine
     
  19. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

  20. zandroid

    zandroid Android Enthusiast

    i keep getting hung up on the driver installation. barely get passed 5% of that part...
     
  21. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    Driver installation shouldn't be a problem as that's Motorola's program just incorporated into mine.

    Could you maybe PM me a screenshot and we'll work it out there?

    Side note for everyone: I just got a new wireless keyboard/mouse combo tonight and I am soooo happy!!!! My old wireless keyboard had SUPER sticky shift, backspace, and enter keys so it took WAAAY longer to program or just do anything!!! I'm never buying a $6 wireless keyboard mouse combo again!! I love family members who have nice things lying around when I need them most ;)
     
  22. smroark

    smroark Member

    Thank you for the Rooting process and guide!
    Much appreciated!
     
  23. zandroid

    zandroid Android Enthusiast

    Kamikaze, i went ahead and manually did the drivers, ran your program and it worked fine. I'm rooted, now what!

    PS. already have SetCPU for the overclock, whats the first step for getting new ROMS?
     
  24. RDKamikaze

    RDKamikaze Android Enthusiast
    Thread Starter

    @smroark - Glad to hear it worked out for you! :D

    @zandroid - I'm happy to hear you figured it out :) I'll have to try the driver install section on another computer that doesn't have drivers yet (or uninstall mine and see what happens). For new ROMS I would recommend reading the how-to ROM guide and installing ROM Manager (make sure you flash clockworkrecovery with ROM Manager first).
     

Motorola Droid Forum

The Motorola Droid release date was November 2009. Features and Specs include a 3.7" inch screen, 5MP camera, 256GB RAM, processor, and 1400mAh battery.

November 2009
Release Date
0
Reviews
Loading...

Share This Page

Loading...