1. Are you ready for the Galaxy S20? Here is everything we know so far!

"The Security Certificate for this site is not trusted"

Discussion in 'Android Lounge' started by sleepwalking, Jan 5, 2013.

  1. sleepwalking

    sleepwalking Lurker
    Thread Starter

    I haven't used my tablet in about two weeks but today I charged it, turned it on and it wouldnt connect to facebook using the fb app. So I tried to go on fb using the browser and chrome and both give me the security certificate warning.


    I bought the tablet in the US and am using it in australia if that makes a difference (although I'm pretty sure it doesnt).


    Fix please? :)


    Tablet is an Asus Transformer Infinity if that matters...
     



    1. Download the Forums for Android™ app!


      Download

       
  2. lightsleeper23

    lightsleeper23 Android Enthusiast

    I got that same message today on my Asus nexus 7 using chrome. I was just going to straighttalk.com, which is a pretty big wireless provider here. I thought it a bit strange but just chose to go anyway, and ignored it. It didn't happen again after that. In fact I tried it again just now, and the message didn't pop up. Can't say it was the same problem, but I would just ignore it if it's a trusted site (like facebook) you're going to. If it persists, then it's obviously something to look into.
     
  3. breadnatty08

    breadnatty08 pain rustique

    Have you tried different sites or different browsers (like Dolphin, Boat, Firefox) to see if you get the same warnings?
    I'm not a FB user so can't confirm the problem.
     
  4. Davdi

    Davdi Android Expert

    That message can mean many things including:
    * The organization issues their own certificates, and they're not a recognized CA (Certificate Authority)
    * It's a subsidiary company using the Parent Company's certificate -or vice-versa
    * The certificate has been revoked
    * or been corrupted

    It depends on the company and what the certificate says as to whether you trust it.
     
    SirSpace likes this.
  5. SirSpace

    SirSpace Well-Known Member

    Like davdi said u should be fine if u know the site is trusted your fine. I get the same with Google sometimes I think it has nothing to do with devices but on there end maybe server issues but I wouldn't worry. Yes it's annoying but mine just stopped so you might have to do the same and just wait
     
  6. nickdalzell

    nickdalzell Extreme Android User

    check the date/time settings. I do know that on a computer if the date/time is wrong the web browser will complain about site certificates. in addition, on some browsers these alerts can be turned off in settings.
     
  7. Martincloud9

    Martincloud9 Lurker

    I have tried the time/date settings. All Ok.
    I have reset my browsers (all settings possible) and installed new browsers.
    Nothing has worked.
    How do I repair/re-install my certificates? The only website (so far) this causes a problem with is Hotmail. I cannot even enter the site. I don't even get the 'proceed anyway' option.
    I don't want to end up re-installing my OS to get this working properly again.

    Help please!! :(
     
  8. mikedt

    mikedt 你好

    Hotmail? Hotmail became Outlook.com about 2 years ago. You shouldn't be seeing any site from Microsoft called "Hotmail" now AFAIK. You might still have a @hotmail.com email addess, but the site should be showing as "Outlook".

    You could even be on a phishing site masquerading as "Hotmail", and if you have entered your login details on a site like that, change your password ASAP. Maybe why the browser is giving certificate errors and refusing to proceed, because it's a bogus website it's trying to access. Could be your ISP blocking a phishing site, and that's why there's no proceed anyway.

    Can you view Facebook or Google OK, because those should be HTTPS secure websites with certificates. Does Google Play work on your device, because if the date and time are wrong or the certificates are messed up, that won't connect.

    The "Trusted credentials" in Android are at the system level, and there's no way to mess around with them or compromise them, unless the devices is rooted. You can add new "user" certificates, and tell it to ignore various pre-installed ones, but that's all you can do at the user level.
     
    MoodyBlues likes this.
  9. Martincloud9

    Martincloud9 Lurker

    Thanks for the advice.

    After spending a lot of time trying to figure out what was going on, I noticed that my emails were 1 hour out if sync...?? I guess shouting at my mobile wasn't enough...

    Turns out the 'automatic' time settings on my email account (Hotmail/Outlook) were incorrect. It was set a Universal GMT?? I set it to London GMT and that seems to have solved the issue. I didn't even know there was a Universal GMT.

    Just to state, all other website were working fine. I hope this helps someone in the same predicament as me.

    This all seemed to start when I was trying to find a programme on Google play to sync my Google calendar with my Outlook.

    Any ideas on one that works? I was using Google Calendar Sync, but apparently this has now no technical support...
     
    mikedt, John Bean and ocnbrze like this.
  10. John Bean

    John Bean Happy Wanderer

    They use terrible terminology. What they call "Universal GMT" is simply GMT; GMT is what it is, no need for extra descriptors.

    What they call "London GMT" is just "London time", automatically set to either GMT or BST as appropriate to the time of year. Calling it "London GMT" is both wrong and confusing.

    Can't help on Outlook sync, I haven't used Outlook for years... and hopefully never will again;-)
     
    mikedt likes this.
Loading...

Share This Page

Loading...