1. Are you ready for the Galaxy S20? Here is everything we know so far!

The "so you upgraded to z4 and lost root" guide.

Discussion in 'Android Devices' started by danhalen1, Oct 10, 2014.

  1. danhalen1

    danhalen1 Well-Known Member
    Thread Starter

    So you took the OTA update and lost root. Well you lucked out, but don't do that again!

    Warning: There's a lot of steps here, so pay attention. Read the linked posts. I am not responsible if you destroy your phone. At this point there's not much that can be done with root or fastboot or my bootable cwm other than flashing donjuros debloated rom.

    This is kind of a process, and you are going to have to download a bunch of stuff.

    First step is to read this post.
    http://androidforums.com/volt-all-things-root/861292-how-restore-phone-dl-mode.html

    Download the file linked from asmugone.
    Download the megalock.dll

    Follow the steps outlines in the linked post.

    Good so now that's done, you get to do more work.

    Run towelroot on your freshly downgraded phone. Im not going to bother linking to it, its easily found.

    Read donjuros first post here.
    http://androidforums.com/volt-all-things-root/872005-rom-zv4-updated-stock-rom.html

    Download his modified z4 update.

    Read this and then download my CWM build refrenced in this post
    http://androidforums.com/volt-all-t...wm-based-recovery-v6-0-3-7-a.html#post6668157


    Good? great. Now Read this post.
    http://androidforums.com/volt-all-t...r-no-flashing-needed-working.html#post6660832


    Still following along? Read below for the people who didn't bother to read the post. Get your phone connected and start adb on your computer.

    adb shell
    su
    dd if=/dev/block/platform/msm_sdcc.1/by-name/laf of=/sdcard/laf.img

    Run the following code to zero out laf:

    dd if=/dev/zero of=/dev/block/platform/msm_sdcc.1/by-name/laf

    adb reboot
    power off
    hold volume up
    plug in usb

    You delete the laf partition, which forces fastboot mode and takes the place of download mode.

    IF you want to return the phones download mode
    fastboot flash laf laf.img

    Great so now you are rooted and have the fastboot interface unmasked.

    Did you copy over the z4 update to the sdcard? you should probably do that.

    Remember that cwm build you downloaded? You dont copy it to the phone, it should be on your computer. PRobably just go ahead and copy it to the root of your adb folder.

    Make sure the phones booted into fastboot mode now.

    Open up good ole adb.

    Run fastboot devices to make sure your computer can find the phone. It should produce a result if it can connect.

    This part may be optional:
    While in fastboot run
    fastboot oem unlock
    This "unlocks" the bootloader, not really but im not sure if its needed.

    Good? Lets carry on.
    Last step.
    Fastboot boot cwma1.img (you can rename the img if you wish. I named it cwma1 because it was the first alpha build.)

    Now just flash donjuros zip and then you will be updated to z4 and be able to go back in and use towelroot to root it.

    This is not really a hand holding exact step by step guide, but there has been a ton of topics lately all asking the same thing.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. TeknicalGeek

    TeknicalGeek Lurker

    I followed all the instructions and it appears to have worked, the only thing is, my phone is no longer virgin mobile branded. The boot screen is just the default LG one, and the carrier is set as LG. My service is still working however. I just wanted to know if this was normal, or if it could pose issues in the future. I'm not complaining though, the virgin mobile apps that force install themselves have not showed up, so it's a bit cleaner than before.
     
  3. halrulez

    halrulez Well-Known Member

    You flashed the stock rom it sounds like. Yes it's normal. Your all good.:thumbup:
     
  4. danhalen1

    danhalen1 Well-Known Member
    Thread Starter

    I have not had to do this myself, but according to others its normal. Its an unbranded version that works for both boost and virgin mobile.
     
  5. TeknicalGeek

    TeknicalGeek Lurker

    I see, no problems then. Thanks for this amazing post, it worked perfectly! :)
     
  6. shezzy

    shezzy Android Enthusiast

    Did this last night..went perfectly. Thanks!!
     
  7. shezzy

    shezzy Android Enthusiast

    Op, can you add how to flash radio and kernel? I'm still on c1 instead of c8 baseband and I used your method
     
  8. bg4m3r

    bg4m3r Android Expert

    Instructions for the radio are right there in the first post of the z4 thread. To flash the kernel, just pull the boot.img from the zip and flash it via fastboot.

    fastboot flash boot boot.img
     
  9. shezzy

    shezzy Android Enthusiast

    Thanks... what's weird is it looks like my kernel updated with the updated zv4 stock rom ( it's now 3.4+) but my radio didn't ( still showing c1 )

    Is the kernel for zv4 suppose to be 3.4 or something else?
     
  10. Entropic

    Entropic Newbie

    Disable service was failing to block the aggravating update notification, and letting it try always failed to update properly.

    This was nicely explained and worked great! Never even used fastboot before. For those on linux:

    Linux one-liner ADB\FastBoot install!

    Update PRL\Update Profile was required to get data running again.
     

    Attached Files:

    Sands207 likes this.
  11. rsoberanis

    rsoberanis Newbie

    Guys, I'm sorry for this inconvenience but is there any mac way to do this (or a way to do this through parallels for mac?)
     
  12. bg4m3r

    bg4m3r Android Expert

    Boot camp maybe?
     
  13. spunky168

    spunky168 Newbie

    First download "Android File Transfer" program for mac:
    https://www.android.com/filetransfer/

    This will allow you to access your phone and transfer files to phone's internal storage or SD card.

    To set up adb and fastboot, download and follow the setup on this thread:
    [GUIDE] Set up ADB and Fastboot on a Mac eas… | Android Development and Hacking | XDA Forums

    From there on, you should be all set to go and then follow danhalen1's and others' instructions and threads on this forum.

    All the best. I was able to do everything on my mac with the above setup.

    Spunky168
     
    donjuro likes this.
  14. ODGeek

    ODGeek Well-Known Member

    I did it running Windows 7 Pro on Virtual Box on my MacBook Pro. Seemed to work fine.
     
  15. rsoberanis

    rsoberanis Newbie

    Thanks a lot guys! I really appreciate the help!! :D
     
  16. spocko

    spocko Well-Known Member

    Thanks danhalen1! This thread should be a sticky.
     
  17. K4HLU4

    K4HLU4 Lurker

    I've followed this guide and the ZV4 updated stock rom guide and I am left with a status 6 error when I go to flash through entering the commands:

    Fastboot boot cwma1.img
    Fastboot oem unlock (OKAY finished)

    Fastboot update new.zip (status 6 error!)
    Fastboot update radio.zip (haven't gotten this far yet...)

    The transfer starts, goes a little ways, but then I get the Status 6 error message on my phone.

    My V3 LG Volt is rooted, and the bootloader is unlocked. Stay Awake and USB debugging are both turned on, I put my phone in MTP mode before entering fastboot recovery through cwma1.img. Under PC connection Charge phone, Media sync (MTP), and Send images (PTP) are all working with my PC. While in recovery mode, at first, my phone was not showing up properly in my PC's Device Manager. What I did to fix this? I right clicked the yellow exclamation mark and went into Update Driver Software...I selected Browse my computer for driver software, Let me pick from a list of device drivers on my computer, I selected Android Sooner Single ADB Interface. Now the phone and the computer are paired, even in recovery mode. =)

    I have transferred both the new.zip and the radio.zip to the root of my External SD card. I have even put the two files in the sdk/platform_tools folder on my PC as well. I rebooted back into my phone after I got the status 6 error and everything still works-- just no V4 yet. :/

    Before anyone asks me about this, I have updated my flashboot and adb libraries through the Android SDK Manager I have Android 5.0 (API 21) ~ 4.0 (API 14). I ticked the Extras box and downloaded all of those as well. I have installed MTP Porting Kit and HTC Sync Manager, as well as making sure my phone's USB drivers are up to date by installing the LGUnitedMobileDriver_S51MAN312AP22_ML_WHQL_Ver_3.12.3 driver. My adb and flashboot commands in the command prompt are fully functioning thanks to 15 seconds ADB Installer v1.4.2. I also shift+right click in the platform-tools folder to bring up the command prompt. *All installers were ran under Administrative mode. =)

    The phone is hooked up to my PC through the white USB cord that came with the phone. I'm running Windows 7 Ultimate x64. My phone has Xposed, SuperSu Pro, Titanium Backup, Juice Defender, Tasker, Greenify, Tether, BusyBox Pro, and Root Explorer. I have granted my computer SU access and ticked the box on my phone 'always give this computer su access'. Also, I enabled Developer options in the phone Settings menu by going into the About phone menu and then into Software information and tapping on Build Number seven times.

    In Developer options (which is on) I have ticked Stay Awake, USB Debugging when USB is connected. Do I need to turn off Verify apps over USB? Other than those three options, nothing else is ticked in Developer options.

    Write me back if you would on how to solve the error 6 message so I can get my phone updated from V3 to V4. Thanks guys!

    Edit: I was also wondering... is there any way to get Sprint Zone.apk back? I miss having the ability to manage my prepaid account through an app. Though, I know I can just go find a WiFi hotspot and do it over a browser instead-- it's just not as convenient. Sprint Zone also allowed me to check how much of their data plan I have left on my phone. That was really useful!

    I've never flashed with flashboot before. So far I think i'm doing good. Maybe I'm entering the wrong commands? Nobody else seems to be getting status 6 error. Is it Fastboot update new.zip or ADB sideload new.zip? Or is it something else that I should be typing? I even tried updating through the phone itself by navigating to the External SD card using the volume and power buttons in cwma1. No dice.
     
  18. bg4m3r

    bg4m3r Android Expert

    I don't understand what you are trying to accomplish with this command. If new.zip is on your SD card, this won't work, it needs to be in the same directory as the fastboot exe. All the flashing for updating to z4 is done through cwm, not fastboot.

    Add for Sprint Zone, unless it is radically different from Boost Zone, it is really quite pointless. Just make a bookmark for the mobile site and put a shortcut on your homescreen.
     
    bostonbb likes this.
  19. K4HLU4

    K4HLU4 Lurker

    Alright, disregarding the Sprint Zone bit, which yeah, I've just put a shortcut on the homescreen, but it would still be nice to view the leftover data locally without having to go online to see what's left in my data plan.

    new.zip (892,415 KB) is in my adt-bundle-windows-x86_64-20140702\sdk\platform-tools folder, as is radio.zip (59,285 KB). So my command is wrong? Or? Anyone want to TeamViewer? Can you tell me the command if it is not fastboot update new.zip

    I am in cwma1 (accessed by adb reboot power off vol up)
    Yes I did fastboot boot cwma1.img command from PC.

    The phone boots to cwma1...

    Is the next command:
    fastboot flash boot new.zip

    Because when I try this it reads <waiting for device> on the cmd prompt...
    The phone is set to (MTP) on PC connection, is there something I need to do in cwma1?
    There are no exclamation marks in Device Manager.

    ? I would like to not brick this phone. I just bought it. Is there any way to get Cyanogen or OmniROM loaded onto this phone? The app says my phone is not supported. =P I'd rather not be bugged by Google Play to update my OS to ZV4, possibly bricking my phone if it decides to auto update one day. If going onto an aftermarket OS is what needs to be done to prevent that, then I'm all for it--

    The bootloader is unlocked and the phone is rooted, so it should be ready for a custom OS. Right? Pretty sure that even if I install this ZV4 rom, Google Play Services will prompt me in the future to download ZV5 which probably takes it all away again... I like to use utter! for automated voice commands and it requires Google Play Services to function properly. If I disable the Google Play services and clear the cache, I get no annoying update. However, it interferes with other apps I like to use. (So, I'm just leaving Google Play Services on. The other option I have is to stay on V3, but my phone came loaded with ZV4 in the first place which I downgraded with LG Flash Tool.) I wonder if there's a way to use Tasker to block that specific update and just that specific update. I've read that Titanium Backup can, but I have no clue how to do that.
     
  20. donjuro

    donjuro Android Expert

    The latest version of zv4 isn't working and I'm going to fix it when I get the time. Until then you can use the old version.
     
    spocko and K4HLU4 like this.
  21. K4HLU4

    K4HLU4 Lurker

    You're my hero. I'll use the Mirror 1 and report back if all goes well. Thanks man.

    I decided to upgrade from cwma1.img through the phone rather than the computer.
    What I did was download the ls740_zv4.zip from your guide, I put it on the external SD card, navigated to it from inside cwma1, then updated through the phone. It succeeded, and then I updated radio.zip. That succeeded. Then I went to advanced options and booted into recovery mode, it prompted me that root may have been lost so I used that option to restore it. It went into recovery mode, and then I shut it down, turned it on again. Now it says:

    Android is upgrading... Optimizing app x of 261. Finishing boot. Opened Root Checker...

    "Sorry, this device does not have proper root access."

    Yet, I have all my apps... and it's now on V4. What gives?

    Edit: Used Towelroot and restored root access on V4! =)

    Cool beans. Towelroot didn't work on the V4 that came with the phone. I love you guys.

    SUCCESS!

    I just have one last request. When you go to fix the broken new.zip, can you add the Edify update to it so that we can theme the phone up in ZipThemer.
     
    bostonbb likes this.
  22. Outcast22

    Outcast22 Lurker

    Ive posted elsewhere but noone answering. Ive tried to Restore but I keep getting a Wrong DLL message in LGFlash Tool. Im using all the files from the links given and have even uninstalled and reinstalled but still nothing.
     
  23. spocko

    spocko Well-Known Member

    When I flashed V4 I ignored the messages in CWM that said root may be lost. I did not have a problem with root afterward, nor did I have to re-root. It's possible that the CWM option actually breaks root instead of fixing it. I have seen that with custom ROMs on my Samsung GS4, depending on which recovery is being used.
     
    Phil42 and donjuro like this.
  24. K4HLU4

    K4HLU4 Lurker

    I have a different problem now, ever since flashing to that V4 rom Xposed Installer won't install the needed Framework. XposedBridge.jar is active. However, the app_process framework is not. I'll go ahead and change the Installation Mode to Classical and have it write to /system directly. It should be noted that I didn't encounter this problem on the V3 rom. =)

    As when I tried to install the framework through recovery I was greeted with Secure Booting Error! Cause: boot certification verify.

    Does this mean that there is something awry with the recovery mode now? Let me know what you think. It's important to me that everything functions correctly. Installing through /system worked. My framework is working completely, but I am still concerned about my Recovery being bugged up.
     
  25. ChuchoIsIn

    ChuchoIsIn Lurker

    Hello everyone. I've decided to take the plunge and downgrade my phone back to V3 in order to root it. I never had an itch to root until recently when i noticed that apps weren't being moved to the SD card. Before doing so i just wanted to know will i lose any data (contacts, pics, ringtones, etc.), will i have to reactivate my phone with VM and what would be the purpose to upgrade to the custom v4 rom?

    Thanks in advance for all and any answers you all can offer.
     

LG Volt Forum

The LG Volt release date was May 2014. Features and Specs include a 4.7" inch screen, 8MP camera, 1GB RAM, Snapdragon 400 processor, and 3000mAh battery.

May 2014
Release Date
0
Reviews
Loading...

Share This Page

Loading...