1. Are you ready for the Galaxy S20? Here is everything we know so far!

The "USB Connected" notification stays on after the USB is disconnected

Discussion in 'Android Devices' started by Got, Aug 20, 2010.

  1. Got

    Got Newbie
    Thread Starter

    The "USB Connected" notification stays on after the USB is disconnected, there's no way to evict it other than a reboot but now will reboot only if USB is reconnected to PC or Charger.

    How it as evolute:

    I was so pleased by my new Galaxy S cell 3 days ago after a week of exploring and managing to get the best carrier and plan for this bright Samsung Smartphone. Then, the day after it lockup, but removing the battery for few seconds then replacing it back fixed that problem for that day. The following day been great too up the second lockup at night and this time, removing temporarily the battery did not permit to have the cell working anymore.

    So today I have been trying all day to determine under what condition these lockups occur. During those tests, I've first determined that during charging or during USB PC connection, I could repower up the Galaxy S. Then the cell could work for long period of time if connected to USB PC or power supply, but when I remove the USB cable, the firmware fail to detect that there is no more USB connection and start to flash every couple of seconds the message "USB connected" replacing the status bar at the top of the screen.
    Then after several minutes, the cell freeze, and only by removing for few seconds the battery and then plugging the charger again, will permit to successfully power up the phone.

    I have of course made a Hard Reset to Factory Default, to no avail, during those tests. I think it's a hardware malfunctioning around the USB Port section. The connector look good seen with loop and both USB cable seem ok.

    If it's corrected by an update, I wonder if I'll be able to re-flash under this condition.

    Edit: Been seen on Samsung Captivate and Vibrant too here: my captivate wont turn on and says usb connected - Android Forums

    Best solution follow:

    coworker23 and Hrithan2020 like this.
  2. snapper.fishes

    snapper.fishes Android Expert

    Never happened to me. Are you using a Captivate or the original Galaxy S?
  3. Got

    Got Newbie
    Thread Starter

    Galaxy S bought on ebay, from Hong Kong traded in AU $, shipped to Canada
  4. cremebrulay

    cremebrulay Lurker

    i have had the same problem with a uk galaxy s from vodafone bought around 2/3 weeks ago. basically after about 2 weeks i had the same recurring problem (usb connected rolling round/flashing when the usb cable was detatched) and the phone would turn itself off when on screentimeout, and would only display the battery charging 'sun' symbol, not the battery symbol and would not boot up, unless the usb/charging cable was attached. it would then boot up, but as soon as the usb cable was detached, i would get the usb connected flashing error.
    luckily i was still within the 28 day return for faults period (which has since been reduced to 7 days, lucky me as the fault only appeared after 2 weeks) and vodafone immediatel;y exchanged the handset for a new one, whic so far has been fine.
    from my observations though, i suspect that i had somehow accidentaly damaged the usb charging port on the phone. i say this because my new handset charger/usb cable has 2 small hooks that seem to lock it into the usb charger socket on the phone. i seem to recall that my old charger cable did not have this and it seemed to waggle about alot when placed in the charger socket. i would suspect that this is a possible design flaw in early models, which has sinse been corrected by this almost unoticeable upgrade.
    i culd be talking rubbish and it may not be this at all, but i i remember looking at the usb charger socket on my phone and thinking that the small rectangular stickyouty bit seemed damaged in that it was not symetrical.
    i will try and take some photos of my new charger/socket to explain better as i realise that my descirption is a bit wishy washy but its the best way i can explain it at the minute!
    it would be usefull if you could check your charger/usb socket for any signs of damage etc...

    Edit pictures added... usb hook.JPG

    usb port 1.JPG

    usb port 2.JPG
  5. Got

    Got Newbie
    Thread Starter

    Thanks Cr
  6. StephenNZ

    StephenNZ Lurker

    My Galaxy S was doing the same thing. I think it has something to do with the on usb connection settings (Settings, About Phone, USB Settings). I've since changed my to "Ask on Connection" and its been working fine. I previously had it set on the Mass storage mode. Perhaps try that and report back.
    Grawil63 likes this.
  7. dencat

    dencat Lurker

    Hi, I just started reading here and I found this place really helpful.

    Any news on this issue? I am able to connect my captivate to my windows 7 x64 pc and successfully mount the internal and external SD cards. After ejecting from my pc and turning off USB storage on my phone, I still have the USB icon on my notification bar. Am I missing anything?
  8. Dillops

    Dillops Lurker

    Same problem here. Just started suddenly today.

    Can't get rid of USB connection sign and can only reboot with cable connected.

    Any solutions or does the phone need to go back?
  9. Got

    Got Newbie
    Thread Starter

    When did you buy your Galaxy? My supposition is bad batch for the USB port component.

    StephenNZ had a theory to test but he never came back with the result. I'm still waiting for return from repair or replacement.
  10. Dillops

    Dillops Lurker

    Bought it on August 10, in a T-Mob shop.
  11. Got

    Got Newbie
    Thread Starter

    About same time as mine.
  12. aaanekre

    aaanekre Lurker

    So today I inspected the USB plug thoroughly and found that there was some corrosion in there..... The plug is so small it's difficult to see much, but after washing with paper soaked in anti-corrosion liquid the phone is working. So far.. (knock on wood).
    The paper was well dirty afterwards.....
  13. Got

    Got Newbie
    Thread Starter

    What? corrosion!

    What was exactly the symptom ?
  14. pmmusale

    pmmusale Lurker

    I am also facing same problem. I am getting "USB Connected" notification even if I am connecting my charger. If screen locks, I can not unlock it and I have to reboot my phone. Even rebooting also gives problems and will start after 4-5 attempts. I tried factory reset but it doesn't seem to work. I have tried to flash my phone but still this notification is there. It sometimes goes away but I haven't observed any particular pattern about it. It comes back whenever I plug it in charger or my PC. This is really weird and I can not use my phone.

    I called samsung service center in Hyderabad, India. They told me this is the first time they have seen this problem and I have to visit service center here. I will keep you posted about what service center has to say.

    Please post if you find any solution in the meantime.

  15. sergiopi

    sergiopi Lurker

    In "settings" activate DEBUG USB option, then restart the phone. Solved :).
    You can UNCHECK the debug and the phone still works. No HW problem, just software
  16. pmmusale

    pmmusale Lurker

    If you go thru other posts in this thread, then you will realize it's not that simple. I have tried several times enabling debugging and then disabling it. This problem really does not have any pattern. For example, tonight I was getting same annoying usb notification and I was not able to unlock my phone once it was locked. I had to reboot it every time this happened. But when I kept it off for 2-3 hrs and when I started it, the notification went away. It's again normal. But I am sure it will pop-up next time when I plug it either in charger or USB data cable.

  17. pmmusale

    pmmusale Lurker

  18. sergiopi

    sergiopi Lurker

    1. It seems really strange that we have so many usb hardware problems :)
    2. it looks as a software problem, temporarily or definitely solved by activating USB DEBUG
    3. isn't ROM related problem, it happens BEFORE ROM load
    May be is related to some USB cables or some USB ports, activating a debug option , tempraruy solved checking and unchecking the USB DEBUG
    4. I will suggest a usb port change, no USB HUB and usb debug mode activated
  19. pmmusale

    pmmusale Lurker

    Hi Sergiopi,

    Thanks for summarizing this. As I said earlier, this problem really doesn't have any definite occurrence pattern hence not definite solution yet.

    Yesterday I observed that I started getting this notification and after few minutes I got a call. I was on call for 55 mins and surprisingly after my call USB notification was gone and my phone was normal. But I got it back when I charged my phone with charger this morning.

    It's really strange that every one started getting this problem same time. I have bought my phone 7-8 weeks ago and it was working fine till last week.
    I am going to flash it with my original DDJF3 firmware and want to see if it stays after that.

    Will keep you posted.

  20. kend82

    kend82 Newbie

    i have the same issues, plus sometimes when i charge through the wall charger mine thinks i'm using the usb and vice verser. sent mine back to 02 uk yesterday, will share what they say when i get phone back... upto 14 days tho to fix sadly.
  21. pmmusale

    pmmusale Lurker

    I flashed mine today with XXJF2 and did a clockworkmod recovery with my original back-up. I didn't root it or install any other application. Still I started getting "USB Connected" notification after putting it in USB. I tried my charger as well as PC USB cable.

    So I am going to Samsung Service center this weekend. This doesn't look like software problem anymore rather a hardware problem. Will keep you posted.

  22. Fapple

    Fapple Lurker

    Menu, settings, applications, development, USB debugging - unchecked.

    Menu, settings, applications, USB settings, check on connection - checked.

    Restart phone and PROBLEM SOLVED!
  23. Got

    Got Newbie
    Thread Starter

    Anyone can confirm it work for them too.

    Up to now mine could be lost in the mail. Hard to admit but I've shipped via very cheap air mail without tracking and very under-insured by inadvertence. In future I will buy locally for such expensive item. My first move was to find service from Samsung Canada but they only deal with their product sold in Canada :(
  24. pmmusale

    pmmusale Lurker

    For me that never worked.

    As posted earlier, I flashed my phone 4 days ago...I got USB notification with my charger on same day. But surprisingly after that day I didn't get any such notification till now even after my charger so many times. At that time, I didn't do anything...It was gone on it's own.

    So I will do some more experiments if I get it again and will keep you posted.
    supercopvinja and Got like this.
  25. BTownBiz

    BTownBiz Lurker

    this also happened to me after a recent usb/mass storage connection with my pc..now is reoccurring problem after anytime is plugged into usb whether for charge or connecting to pc..sometimes the "usb connected" notifications are a second or so apart sometimes it is so soon it dosent have time to register on my slide down notification screen just on top home screen..

    teh only thing that has been able to stop this from continuing is to unplug battery but even that sometimes doesnt stop it and im sure once i charge or connect to pc will happen again..only thing i can think is there is some hardware problem activating this notification..but who knows..

    you would think after so many different people having this problem Samsung would make some sort of announcement or atleast acknowledge this as an issue

Samsung Galaxy S Forum

Features and specs are not yet known.

Release Date

Share This Page