1. Download our Official Android App: Forums for Android!

Root Theming question

Discussion in 'Android Devices' started by wowser, Feb 14, 2011.

  1. wowser

    wowser Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    112
    Joined:
    Sep 30, 2010

    Sep 30, 2010
    112
    11
    38
    Hi all,

    I have a question regarding theming the icons that show up in the menus. I've installed one of the themes from the XDA forums and the issue i have is that when i click the menu button, 4 out of the 6 icons show up with the themed icon. I've opened up the framework-res.apk for this theme and I do see the missing icons in \res\drawable-hdpi. (Icons in question are ic_menu_notificatons.png and ic_menu_preferences.png).

    What do i need to look at to see why these icons are not showing up? I'm on DJ05 and the theme was developed for this software. The developer of the theme has moved on to EB01 so i'm trying to reverse engineer and fix the problem myself.

    I've looked through all of the guides to theming found in the different threads, but at this point i'm stuck.
    Any pointers are appreciated.
    Thanks.
     

    Advertisement

  2. nitsuj17

    nitsuj17 Android Expert
    Rank:
    None
    Points:
    213
    Posts:
    4,648
    Joined:
    Aug 16, 2010

    Aug 16, 2010
    4,648
    654
    213
    NJ
    you mean the soft key menu at the bottom? yeah thats a pita...because some launchers have their own icons inside of them that replace the system ones...*generally* in ss we use adw or adw ex because it calls up on the framework-res icons...whereas stupid lpp uses it own (as does 2.2 touchwiz) so you would have to actually theme those launchers to make it work...

    just a pita
     
  3. wowser

    wowser Well-Known Member
    Thread Starter
    Rank:
    None
    Points:
    38
    Posts:
    112
    Joined:
    Sep 30, 2010

    Sep 30, 2010
    112
    11
    38
    Thanks Nit. That must be it since i'm using lpp.

    Well i messed around with framework-res.apk in system/framework trying to get it to work and totally screwed up my phone :(

    Been awake most of the night trying to fix it but no luck. At least now i have a reason to move to eb01! Flashing it now...
     

Share This Page

Loading...