1. Are you ready for the Galaxy S20? Here is everything we know so far!

"There are no Android phones associated with this account"

Discussion in 'Android Lounge' started by NewChinaHand, Sep 5, 2011.

  1. NewChinaHand

    NewChinaHand Newbie
    Thread Starter

    My friend recently bought a Samsung smartphone with Android 2.2.1.
    As I've been using one myself for the last few months, I tried to help him get started.
    I figured the first thing he should do is download the Android Market app for his phone.

    However, we encountered difficulties.
    When we went to download it, it asked for his google account name and password.
    This he provided.
    But when further prompted to hit the install button, it displayed an error message that "There are no Android phones associated with this account. Please sign in with a different account" while i can find no where i can change my phone number.
    What does this mean? Shouldn't it have been associated when he entered his google account name and password?
    When I first got my phone, I don't remember encountering this problem at all.
    What does he need to do to get his android device associated to his google account, and proceed with installing the android market and downloading apps?
     



    1. Download the Forums for Android™ app!


      Download

       
  2. Haggistech

    Haggistech Well-Known Member

    try this

    - Log on to http://market.android.com
    - Click on My Account
    - Click on Recovering Password
    - Enter password (to validate it
     
  3. karandpr

    karandpr Android Expert

    Official Android Market is a licensed app .
    Translation : It comes with devices in built
    There is no need to download it if you own an android from licensed vendor like Samsung .
    If you own a non-licensed phone ,you wont be able to install Market or any Google app (Known as Gapps) like gmail,maps, talk and so on .
    Yeah Android is Open source ,Gapps aren't :p

    If you own a licensed phone go to your care center and update the firmware .Market will be present in built

    If you dont ,try alternative market like Slideme.org.Gapps just wont run on the phone .

    What phone model does your "friend" own ?
     
    NewChinaHand likes this.
  4. NewChinaHand

    NewChinaHand Newbie
    Thread Starter

    karandpr, thanks for the feedback
    it definitely sounds like my friend might have gotten his hands on an unlicensed phone.

    now that i remember it, when i got my phone it had android market built in from the beginning. i never had to install it. the fact that his had so little software on it to begin with is awfully suspicious. and he only saved $50 or so by buying a cheaper model than mine.

    by the way, we both live in China. so the likelihood of an unlicensed phone is probably higher than in other locations

    I don't remember which model his was exactly, just know it's a Samsung and smaller and cheaper than my Samsung Galaxy Ace GTS5830

     
  5. oranabana

    oranabana Lurker

    actually it is unlikely to be anything to do with the 'unlisenced' issue. I have also just got a brand new Samsung Galaxy (GT-I9003), which I got from the offical China Mobile shop (the one at Chaoyangmen, Beijing). There is nothing wrong with the phone and after installing the offical Samsung phone software (KIES) it acutally told me there is newer software available.

    What is wrong however is that as mentioned here, none of the Google apps work, if they require a signin (Latitude, Gtalk, Gmail etc..). The reason for this is, that China Mobile has there own 'homecooked' version of the Samsung Android system, and have ensured that none of the Google functions work (in compliance with shady government regulations). A friend of mine had the same issue with their (also offically bought) Motorola.

    I think the way out and forward on this, is to install a new ROM version. I am looking for a new one for my own phone now, one that has Chinese characters, as I need those. Probably a Malyasian or Singaporian Android 2.3.5 should be fine....

    just my few pence worth!
     
  6. vjlord

    vjlord Lurker

    I've already created my gmail account but my android Galaxy S is not adding up the gmail account..

    Neither i could visit the page of market.android.com on my cell
    .

    i've already tried number of solutions. The firmware version is 2.2.1 when i tried to upgrade it said insufficient memory, it requires 3000MB free
     
  7. StanGetsIt

    StanGetsIt Newbie

    The issue is your friend's phone has the earliest version of Market. You need to wait a day or two for the device to OTA auto-update before other Gapps Auto-Update - which they do (you can manually go and find them, but they WILL update automatically without even checking the Update Automatically checkbox) There are also times when in , say , Android Market online that you will receive the same message ("There are no Android phones associated with this account. Please sign in with a different account."). With the NEWEST version of Market, you CAN change your default account. With the OLDEST version of Market you CAN NOT change your default account. Why would this matter? This matters for those people who BUY apps using Account A and have their phone registered under account B - when the OLD Market app is running things, your PHONE's registered gmail account is the control - NOT the gmail that you use with Google Wallet. So, you can NOT - unfortunate - update to the most recent Market app version manually in the market - that sucks. Instead, you must wait for it to happen. It will happen, but I had to wait 3 days for it one time. I have had this happen to me 4 times in 2 years; not bad odds I guess. Another alternative: If your phone is rooted (and NO, that is NOT why ths issue happens!) and you are using Titanium Backup (it would need to be Tit Backup and Tit Backup REQUIRES Root and Unknown Apps to be checked - for install) you can RESTORE the newer version currently at 3.4.4 - as of 1-12-2012 I WOULD HIGHLY RECOMMEND RESTORE "APP" ONLY, NOT "APP+DATA"! The reason being: the Data might not include apps installed recently, requiring you to re-download them - time consuming, but at least you won't be charged again for paid apps. Also, the data might carry all of your gmail accounts, and if not all there, you would have to also reboot your phone after manually restoring the Market app: more wasted time. Now try the Android Market again, online or phone, and you wont see that error! But, that might not work either! Oh no! If not, then in this order: 1. Power off the phone (put on battery only, no adapter) 2. PULL the battery 3. wait 5 seconds 4. PUT the battery back in 5. Power up the phone 6. Make sure you are in a cellualr coverage area - does not have to be 1x/2g/3g/4g/etc arrea, what matters most is cell coveerage area 7. GO to the Market 8. There WILL be updates, UPDATE at least one of those. 9. Check back online at Android Market - all should be well now. You are probably asking now, "Why did you have the old version?"; because I had to uninstall the current version whenever any app insists on installing apps to SD as "Preferred" rather than "Auto". The Dev Docs for Android Devs SUGGEST and soon will (thank goddess) REQUIRE that you use Auto for SD install . OK, sure, that means WE have to Move-to-SD manually or with some helper app, but that is better than going to the ,arlet and finding that half your app don't show up in the total count of apps - and dont tell me that no one in this forum hasn't had that happen to them!
     
  8. StanGetsIt

    StanGetsIt Newbie

    3000MB = 3GB So, no, it doesn't require that much. Try maybe 30MB - that sounds about right.
     
  9. nixe

    nixe Lurker


    hi there, did you manage to get your phone linked up with your andriod etc... as im having the very same problem , its starting to annoy me now.... ive made an account with the googlemail... ( altho i dont even know how i managed that now) and every time i try to install an app or even just link to the preinstalled andriod marketplace etc it asks me to log in to my google account.. i enter pw etc and get the same error msg .. and its been ages now. ive tried loggin in to the google acc on the pc and going through options, disabling the 2 link verification process etc.. ive had a code sent to the phone.. ive added my number in the andriod account bit... and now thats it.. still no luck at all.... my device doesnt show up on the andriod website... even tho its supported.. can anybody help PLEEEEEEEEEEEEEEEEEEEASE!!!.... im not exactly ultra techy when it comes to phones, but then again im not stupid.. just never had to bother with stuff like andriod or apps as most phones always did most of what i needed....... but surely i must be able to use andriod and log in.. on this phone.. ok heres some details.. :
    the phone is a SONY XPERIA MINI PRO
    VODAFONE NETWORK ( altho it came assigned to virgn if that matters?)
    MARKETPLACE AND GOOGLE S/WARES FOR MANY SERVICES PREINSTALLED

    I really hope someone can help now.. i see many ppl seem to be having this same basic problem.. which just doesnt make sense to me.. and someone must know whats goin on with it and how to fix it as its such a common problem......its never worked on this phone and ive had it over a year now or so.....the msg " cannot eslablish a reliable connection to server, contact blah blah " is the one im getting.. same one as on this origional post.... ive checked all the most obvious and visible things i can on my account thro the pc etc... so really need to find somone who can properly troobleshoot this issue with elimination etc....???... would be much appreciated...... im very disappointed and curious now to know what is causing this silly issue..... hope to become enlightened by all you techy ppl out there...
     
  10. Jepoy23

    Jepoy23 Lurker

    guys i cannot post a link, but on youtube search 'how to fix android market problem' and click the second video it is really helpful
     
  11. godalmighty

    godalmighty Newbie

     
Loading...
Similar Threads - are Android phones
  1. Cinque8
    Replies:
    4
    Views:
    615
  2. Second Chance
    Replies:
    6
    Views:
    1,573
  3. HarryC
    Replies:
    5
    Views:
    866
  4. DanCalling
    Replies:
    7
    Views:
    603
  5. AntiMorrisey
    Replies:
    2
    Views:
    1,945
  6. melani78
    Replies:
    0
    Views:
    621
  7. satimis
    Replies:
    8
    Views:
    1,371
  8. markdoc
    Replies:
    0
    Views:
    594
  9. aleislost
    Replies:
    3
    Views:
    1,895
  10. Brickmeister
    Replies:
    3
    Views:
    964

Share This Page

Loading...