1. Check out our companion app, Forums for Android! Download from Google Play

Tips TIP: Can not connect to wifi router? Check your SSID.

Discussion in 'Android Devices' started by Roadblock, Jun 29, 2010.

  1. Roadblock

    Roadblock Well-Known Member
    Thread Starter

    Jun 1, 2010
    I bought a HTC EVO 4G on launch day. Btw, I would like to mention my phone (hardware version 002) has had ZERO issues so far. No grounding issues, light leakage etc. The only issue I had was crap battery life which Fresh EVO Rom 0.3 seems to have fixed.

    Now, moving on to my router issue. I have been trying to connect to my home router since I got the dang phone and it simply would not connect. My phone would SEE my home network, ask for the password but it would just loop trying to connect and then simply wouldn't.

    I've tried changing my security from WPA2 to WPA, WEP, no network security etc and nothing worked.

    I tried resetting my router, nothing.

    I tried changing my channels, my DCHP settings, nothing.

    I was getting pretty freaking frustrated when I got to thinking about the Wifi Tether app for Root Users. When you setup a Wifi Hotspot the app/phone will NOT work if you try to use an SSID with a space in it.

    For example, the default name is "AndroidTether". I tried to change this to "My Hotspot" which would not work. I changed it to "MyHotspot" and it worked. At the time I wasn't sure if it was the comma or the space but whatever, my Wifi Hotspot worked.

    Anyway like a I said it got me to thinking about my home routers SSID which contains a space in the name. All the home computers and laptops could connect but could this be the issue? Like I said my EVO would see my home network and try to connect but it just wouldn't.

    I decided to give it a try, I logged into my Belkin N router and I removed the space from my network SSID name and tried to reconnect to it on my EVO 4G.

    SUCCESS!!!! Sucker instantly connected as soon as I put the password in. This whole time it it was something as simply as a space in the damn network SSID on my router.

    If your having issues connecting, check your SSID name.


    skpd likes this.
  2. mrzes454

    mrzes454 New Member

    Sep 3, 2011
    I'm having the same issues w/ my evo 4g. Tried what you did changing router security and finally changing ssid with no luck. I have a netgear wrn2000v2. Any suggestions. The sprint techs jumped right on a neighboring network at there store why can't I.
  3. mcl1981

    mcl1981 Well-Known Member

    Jun 20, 2010
    A space in the SSID name is not a problem. If it won't connect to your router, there is something up with your routers WiFi or security settings.
  4. samturner159

    samturner159 Member

    Dec 16, 2011
    Greetings I just registered to tell all of you with belkin router issues that I solved it very easily no messing about with static ips or anything. Have had a sensation xe for about a week and spent most of that time trying to get on my wifi. my router is about 4 years old so hope this will work for some of you.
    If your htc device has WPS(wi-fi protected setup) in the wireless settings enable it with the wireless on, now somewhere on the back of the router should be a small button with a padlock above it hold, that down for 5 seconds and the padlock symbol on the front will flash and then thats it you should be connected. no need to change any complicated settings. Hope this helps some of you guys out am in UK so dont know if it will be same in the US

Share This Page