1. Are you ready for the Galaxy S20? Here is everything we know so far!

Titanium Backup Batch Restore Hanging

Discussion in 'Android Apps & Games' started by Rachel A, Aug 14, 2012.

  1. Rachel A

    Rachel A Android Expert
    Thread Starter

    Got a new SIII today - yay!

    Slapped the SD card on from my Incredibly sick Incredible and fired up TB.
    Individual apps all restore just fine - no issues whatsoever.

    Batch restores? Ah, now there's the rub...
    It just hangs and does bugger all. Just sits there at zero percent. At that point I have to power off the phone in order to try any further use of TB.

    Phones rooted and I do have all my backups protected by a master key. When I do individual restores TB asks me for the pass phrase. When I try a batch it doesn't.

    Anyone any ideas?

    Edit : Wondering if it's the backup files that are the problem. Tried to restore 1 app on its own and it hangs aswell. Didn't ask me for the pass phrase either...

    May try another set of backups on my Incredible without the master key and see what happens then.

    Used BusyBox from both TB and external with no difference.
     



    1. Download the Forums for Android™ app!


      Download

       
  2. xxkid123

    xxkid123 Well-Known Member

    Yep, batch restore seems to be hanging pretty often with the latest update, although it does it in all versions.

    But, usually I get a few apps restored before something causes it to hang. If it does, you can just kill the app (settings>apps>running) (note, swiping away in ICS doesn't work, you have to force stop).

    I'm not sure why, but under a normal restore it will ask for superuser permissions to install an app. Then it'll ask for superuser permissions twice to restore data. For me it hangs when it should ask for permissions the first or second time. Instead of asking it'll just do nothing and stop there.
     
  3. Rachel A

    Rachel A Android Expert
    Thread Starter

    Odd. Mines not asked for SU permissions yet.

    Tried to kill it off that way but it's not happy. I have the old version of TB that uses a license key file on the SD card. If I try to fire TB back up again after stopping it then it just hangs there saying it's checking the license. That's why I have to reboot each time.

    Edit: OK its still hanging but I can now kill it off. However I'm still having various apps that will not restore, no matter how many times I try. Verification off the backup file works fine. It just won't restore is all.

    Going to have to try my theory out about the master key. The restores that hang don't even get as far as asking me for the pass phrase.
     
  4. lexluthor

    lexluthor Android Expert

    Sometimes changing app processing mode from direct to indict resolved hanging issues for me.
     
    Rachel A likes this.
  5. Rachel A

    Rachel A Android Expert
    Thread Starter

    Thank Lex!

    Wasn't able to make much use of the batch restore that way but it did allow me to restore all my apps.

    Your help was very much appreciated!
     
Loading...

Share This Page

Loading...