1. Are you ready for the Galaxy S20? Here is everything we know so far!

Titanium Backup stuck when converting Maps to user app

Discussion in 'Android Apps & Games' started by BadCash, Aug 21, 2012.

  1. BadCash

    BadCash Lurker
    Thread Starter

    Using Titanium, I tried to convert Maps to a user app. Titanium started doing it's thing, and after a short while a force close dialog came up telling me that Maps had crashed. After that I've been looking at the "Working, please wait..." dialog in Titanium for about 30 minutes now. When I go to Manage Apps, Maps is no longer there.

    Why did this happen, and what should I do? Is it safe to force close Titanium at this point and reinstall Maps? Surely it's not supposed to take this long??

    -UPDATE 1-
    So, I tried force closing Titanium (after 1 hour of waiting) and then reinstalling Maps from Google Play, but it then says that it couldn't install the app in the standard location. So then I tried restoring it from a backup I'd made previosly using Titanium, but now Titanium is stuck in the "Restoring..." dialog...


    -UPDATE 2-
    Changed default install location back to internal storage using the "adb shell pm setInstallLocation 0" command. Then installed Maps from Google Play without problems.


    After some further research, it seems that system apps aren't moveable to SD card on stock firmware, which I'm running. Still, you'd think Titanium would give you some sort of error information when you try to do something like this, instead of just telling me to "please wait..." for hours. Does this mean that Titaniums backups of system apps are useless on stock firmware, since I couldn't get it to restore Maps for me?
     



    1. Download the Forums for Android™ app!


      Download

       
Loading...

Share This Page

Loading...