1. Are you ready for the Galaxy S20? Here is everything we know so far!

titanium restore problems - help!!!

Discussion in 'Android Devices' started by spiffyjiff, May 28, 2010.

  1. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    ok, coming from fresh 1.1 to 2.1.2. did a titanium back up beforehand, wiped (factory + dalvik, but no others) and flashed. 2.1.2 loaded fine, and works fine as "stock" but now trying to re-setup/install all my apps. so i reinstalled titanium but when first opening the app, i only have "overview" as a choice of tabs, and i get the

    -----"ERROR: sorry i could not acquire root privileges. this application will *not* work! please verify that your ROM is rooted and includes BusyBox, and try again"----

    so i press OK, then i press "problems?" then i "yes, do it" to the auto-upgrade for Busybox...downloads to 99% or something, right up to the end, but then it force closes at the end of the download.

    without this titanium access, i cant restore anything!!! help???

    1. Download the Forums for Android™ app!


  2. Did you wipe your SD card perhaps? That is where TB keeps your backups. Without the backup file TB won't be able to do anything.
  3. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    nope, SD card still intact, and i can see the backups that i did under the titanium folder.
  4. Try uninstalling and reinstalling TB. Sounds like it is not reading your system properties.
  5. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    did that. twice. even went to titanium help site and tried to install busybox from the shell. no luck. even the "my backup pro" doesnt work. after trying to restore something, it says it's successful but nothing is changed and the app isnt reloaded. wtf???
  6. Mikiemon

    Mikiemon Newbie

    SlothyUK and Fenga Papit like this.
  7. Good thing you posted that because I haven't used 2.1.2 and didn't know about the patch.
  8. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    hmmm, thought that was for 2.1.1. thought i read that 2.1.2 included that fix so no need to flash the patch but will try it. thanks!
  9. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    well i guess i'm stupid (yes, yes) cuz the SU patch worked. one other (stupid) question which i cant seem to solve by searching on here or even the web:

    i take it there's no remedy for my free apps that have disappeared from "my downloads", other than the paid version of titanium which has market doctor, correct?
  10. 330D

    330D From My Cold Dead Hands

    I bought the paid version and love it. Totally worth it if you switch roms often... The free version doesn't do much, except back up your apps. It wont restore them.

    Sent from my HERO200 using Tapatalk
  11. Yep, I broke down and got the paid version of TB a few days ago because I might try out 2.1.2 and I didn't want to have to set everything up from scratch again.

    BTW, do you use the free or paid version of TapaTalk?
  12. 330D

    330D From My Cold Dead Hands

    I have no problem paying for worthwhile apps. Tapatalk is a paid app;)

    Sent from my HERO200 using Tapatalk
    Fenga Papit likes this.
  13. 330D

    330D From My Cold Dead Hands

    I actually paid 6.99 for an app today. I really like it, and just decided that I wanted to support the dev. I bought mixzing's paid music player and it is great! I use it with doubletwist, and it is easier than an ipod sync with itunes.

    Sent from my HERO200 using Tapatalk
  14. Yeah, I've donated to Flipz and have a couple of paid apps because they are worth it. What is the paid Mixzing app like? I use the free one occasionally, but didn't even know they have a paid app.
  15. chinkster

    chinkster Android Enthusiast

    if you reflash a rom, make sure you download all your free apps the first time you open the market. it will be there the first time you open the market but if you exit out of it, the free apps won't show under your downloads anymore. i've ran into this problem a few times so everytime i reflash a rom i just head straight into the market and download all the listed apps under my downloads all at once. i have about 30-40 of them.
  16. 330D

    330D From My Cold Dead Hands

    It truly isnt a whole lot different, except that you get the lockscreen widget, lose the ads, and get a couple other little features. I just like the mixzing app, and wanted to support them! Oh, and I downloaded doubletwist today, to rid myself of my ipod, and wanted the upgraded music player. :)

    Sent from my HERO200 using Tapatalk
  17. I don't use Mixzing that oten but when I have I was impressed with it. Nice, easy way to build play lists. I'm not familiar with doubletwist so I will look that up in the Market.
  18. 330D

    330D From My Cold Dead Hands

    It is actually a program for your pc. It takes all your music in itunes and syncs it with your phone. (At least all your paid music.) I have just started to use it, so I don't know everything about it, but it is easy, and seems to do a good job.
  19. OK, not for me then. I never was into iTunes.
  20. 330D

    330D From My Cold Dead Hands

    It may work for any media player you have. I don't really know all that it does. My wife got me an itouch for christmas last year (and I jailbroke it, of course:) and that is why I have itunes, with a bunch of music in it. I was really impressed with how easy it was to put the music onto my sdcard from itunes with it... Those guys are gonna get me to buy the full version when I get back to work!!!
  21. JDuc

    JDuc Well-Known Member

    So, I was running into the exact same issue after flashing. I even went to the support forum for TB and was told to manually install BusyBox.

    Then I came here and found this thread and noticed there was an update. Great. Flashed it, opened TB and it moved past the "Loading..." screen! Yippee!!

    Only, now it's telling me I don't have Root?!?!?!

    How in the world is that possible!?! I've now flashed my 3rd ROM yet TB doesn't think I have root?

    I did notice on the TB website he mentions that you may not have rooted 'properly'.


    When I open shell on my phone using ConnectBot, and I type in su, I am told: access denied.

    Ok, so just for shits and grins, let's go ahead and reroot...done.

    Opened TB back up and same thing.

    So I closed TB back down, ended the process using the built in Android process killer (just killed the backup task), then restarted TB. This time I clicked the 'Problems?' button, downloaded BB again.

    Now it's coming up and telling me the following:

    BusyBox works but the "su" command does not elevate to root: "whoami" reports "whoami: unknown uid 10066" instead of root/uid 0. I think your "Superuser Whitelist" system app does not work. Please check with your ROM provider.

    Anyone have any ideas?
  22. 330D

    330D From My Cold Dead Hands

    I know it is gonna sound stupid, but double check that usb debugging is enabled. A lot of su issues come from the debug not being enabled.

    I am running fresh 2.1.1 and have had a few root apps come up and say root not detected, or something like that. I can always get around it, though.

    Good Luck, JDuc
  23. JDuc

    JDuc Well-Known Member

    rebooted the phone and now everything seems to work fine. :)
  24. spiffyjiff

    spiffyjiff Newbie
    Thread Starter

    annnnnnnnnnd now all my mkt downloads are mysteriously back under "my downloads". literally i have done nothing to remedy the problem (of them not showing up) since my posts above. man, these things just have a mind of their own...

HTC Hero Forum

The HTC Hero release date was July 2009. Features and Specs include a 3.2" inch screen, 5MP camera, 288GB RAM, MSM7200A processor, and 1350mAh battery.

July 2009
Release Date

Share This Page