Apr 23, 2010
New Zealand
Have tried to download the uninstaller application but after trying it twice for 4 hours each I have given up.

Does anyone have any ideas why downloading this app takes so long - it is also the same for the Xpedia flashlight app which I have tried separately. In fact any application seems to take an eternity.

They apps say they are downloading but they are not very large apps so should be there is a flash but after 4 hours I am still waiting.

Have tried the switch off/on but still it takes ages - I have full signal (not 3G though) and it doesn't download.

Help please - this is driving me maddddddddd


How long did you wait? Sometimes it takes a very long time, one time, I had 4 downloads and just left it until it was downloaded and installed, took 5 min which should of just take less than 1min.

It is the market that is the problem, same thing happens when I had the htc hero. It has nothing to do with your connection, phone or the actual app, it is the market that is the problem.
  • Like
Reactions: Billy1036fm
Thanks Sleepless

I have tried doing them singularly or multiple and nothing happens.

I have waited 4 hours on 2 separate occasions and still no joy.

The apps are 70kb so small and still 4 hours does not land it!

This market really does need a shake up!!!
I've had that problem after I've bought an app. It just sits there saying "Authorizing" but isn't really doing anything. I've found if you exit from Market, go back in and download the app again, it does it straight away.
Thanks for the suggestions but I have so far:

1. Waited 12 hours and left the phone downloading overnight but still no app.
2. Switched off the phone for an hour, tried again but still nothing.
3. Tried other small apps - uninstaller is only 70kb so should download reasonably quickly - but doesn't.
4. Come out of market and back into it - same scenario.
5. Contacted SE for advise - they say it is either the market or Google that is the problem.

Checks completed include browsing to get a known operational web page - all OK. I have also downloaded emails OK which proves the net??

When I start to download it give 1% of 70kb then disappears, comes up with the stripey blue line and then says downloading. Clearly it doesn't do anything as I never get the app. Is there any way I can actually see what amount of the app has been dowloaded (without downloading an app to check this!!!!)?

I doubt everyone else everywhere is suffering the same problems but this is so frustrating.

For info I am on UK Vodafone and have a good signal.

Any further help appreciated.


I also get some problems with slow downloads and paused downloads from marketplace even when I've got a great signal but not problem with emails or web browsing.

I assume the marketplace servers are busy hence the delay or wait.

I usually exit and try later...a bit inconvienient I know but what can you do :rolleyes:
What is the full name of the app from the market your trying to install?
Did you follow a barcode, or link from the web or did you find it inside the market?

Also what network you using? 3G... 2G (EDGE) or WIFI?
Hi Fwipside

I am currently using UK Vodafone on 2G (Edge) as I cannot connect to 3G in my area. The latest update on time to download is now in excess of 14 hours - I left it running overnight and by this morning the downloads have been unsuccessful so need to start again.

I am trying to download

  • Quick Uninstaller (Appmanager) (B&B Tool) v2.2.3 @ 418KB size.
  • Yelp v1.4.2 @ 529KB size
SE are as much use as a chocolate fire guard when you have a technical query regarding market - they say they don't support it even though it on their phones!!

What would be good is instead of the stripey bar saying it is being downloaded would be a bar saying how much is actually downloaded and at what rate.

For the record, I can get internet, email, voice and text where I am so no ideas why I can't download these apps. In fact any app I try to download takes an eternity not just these 2!!

Any help you or anyone can offer would be welcomed as I am fast losing patience with both SE and the google market!!
i have the same problem mate been trying to update a couple off apps just says downloading,but nothing is happing i am with virgin mobile uk only been the last thew days that this seems to be happing,its driving me nuts too the sooner the x10 is rooted the better;)
I've just tried installing Quick Uninstaller (Appmanager) and it took less than a second to download. I'm on T-Mobile.

In fact, I've not had any issues with downloading any files.

So, as I see it, it's either a 2G problem, or a provider issue.
I've had a slightly different experience.

If I'm browsing the market on my wifi connection and I try to download an app it takes absolutely ages to start the download. If I disable wifi and swith to 3G the app starts to download immediately and downloads faster than I can navigate out of the market and back to the homescreen.
Wooks63 - Hi mate

Thanks for the update. I see you are in London - a known excellent reception area for almost everything and on any network.

Maybe living in the sticks and who knows possibly on reduced 2G we suffer somewhat so may have to go out of area to download (which does seem a bit of a drastic measure I know) if that is what is needed.

Less than a second to download - Wow, a day is not doing it here!!

I am still not comfortable with the market though - think it may need improvement as the time taken even in these parts is somewhat excessive.

I am facing the same issue on HTC desire for downloading from the Market. I have 6 apps downloaded (bot free and Paid) They are all just sitting there since last night.

I have downloded and installed copilot directly from the Co-Pilot site without any problem.

I live in London with 8 meg BB connection
I've been waiting about 30 minutes and mine hasn't moved from "Starting Download" i am on wireless provided by my broadband which has amazing signal,and i am on vodafone uk so i am getting perfect signal and i have credit for web access

What is the problem..i really want to download these apps,help!!!! :(((((
I know this is a three year old thread but I had this problem and followed the advice in the above Google link.
What worked for me was to open Application Manager, choose Google Play Store and uninstall all updates (reset to factory settings)
My phone then came to life, updated all existing apps and installed the app I had been unable to get.
Something was causing a log jam and this fixed it. Make sure you are on Wi-Fi or your bandwidth allocation will take a big hit!
Having same problem. ANYTHING I try to download from Google play takes way too long. I tried just about everything (even the above mentioned suggestion). Google play services even took 26 mins to update. At a loss with what to do.
Uninstalling updates to Google Play services worked for me on my Galaxy s3: Setting>More>Application manager>Google Play services>Uninstall updates