1. Are you ready for the Galaxy S20? Here is everything we know so far!

Transformer doesn't charge! More charging woes

Discussion in 'Android Devices' started by ballerusk, Sep 21, 2011.

  1. ballerusk

    ballerusk Lurker
    Thread Starter

    Ok, quick update; my Transformer stopped charging about a week ago. I did the normal tricks, unplugging for a while (including the freezer trick), checking cable, etc. I can trickle charge, so I'm assuming the cable is fine.

    I got on to support, sent them the power supply (thinking it the problem), and they just returned a brand new power supply, and it still doesn't charge. (I've tried to cahrge with battery low *and* when I've trickle charged it all the way to about 70%) I'm running out of ideas ;

    - cable seems to work (sync + trickle charge)
    - power supply seems to work (new replacement, plus it hums along)

    I've tried everything, with and without the dock. Could it be something software? I upgraded to the latest 3.2 a couple of weeks ago, but it was working fine for at least a week. Aaaaaargh! I want my life back!
     

    Advertisement

  2. AutobahnSHO

    AutobahnSHO Android Enthusiast

    Might be hardware issue, there's a circuit inside the tablet that manages the charging. I'd call customer support, you might have to send it in for repair.
     
  3. ballerusk

    ballerusk Lurker
    Thread Starter

    Is there any way to find out? I've tried charging with and without the dock, and surely there's two circuits at play. It seems a bit strange if *both* of them konked at the same time, however it's not impossible.

    I've also gone through the connectors really carefully with alcohol on a q-tip, done a cold restart (a couple of times), nothing. The last thing I'll try is to trickle charge both pad and dock to a respectable point, and try one more time. It's a shame, because otherwise I'm very happy with my pad. I really wish Asus could be a bit more forthcoming on these issues (like having cable spares would be a good start so that we could do some more self-troubleshooting to avoid the support delays ...)
     
  4. AutobahnSHO

    AutobahnSHO Android Enthusiast

    The tablet is or isn't charging from the dock?

    The dock is simply a rechargeable battery that charges the tablet when it senses the Tablet is 'hungry'...
     
  5. bfksc

    bfksc Android Expert

    It could be the cable...for charging, the TF uses another pin/wire to detect the 15 volt charger. If there is a problem it may fall back to 5 volts, which would explain the slow charging rate. Do you have a store nearby with a TF on display? If so, try plugging it in to that cable.

    Does the tablet charge normally from the dock when thedock has some charge? If not, then it could be the port on the tablet. Or it's software and you can try a factory reset.
     
  6. ballerusk

    ballerusk Lurker
    Thread Starter

    Yeah, I've suspected that. It's the same if I use the dock or not, it seems to make no difference.

    That's a good idea, although I suspect none are on display in my area, but I'll try.
     
  7. ballerusk

    ballerusk Lurker
    Thread Starter

    But I still assume the circuitry for detecting a charge must be on both the dock as well as the tablet?

    And no, no charging from a fresh power-supply, dock or no dock (except trickle). But the suggestion of something with the cable and pin 15 (wish someone had some schematics so that we could make our own cables, or get spares) might be a good idea, but I can't seem to find anywhere that sell that cable. Anyone?
     
  8. bfksc

    bfksc Android Expert

    I haven't seen the inside of the dock, but I'm guessing it's not much more than a basic charge circuit and battery. The tablet draws power from the dock battery when it drops to 95% and tops up again, and it handles the charge rate on its own. Each Li-Ion battery has a microchip in the pack that monitors voltage, current, charge level, temperature, etc., so all that info is already there.

    If the tablet won't charge normally from the dock battery, then I would presume something is wrong with the tablet or the software. Have you tried a factory reset yet?
    I haven't found a reliable place either. I'll have to contact ASUS here in Canada to see if I can get a second charger and cable as the one they include is a bit flimsy and I don't trust it to last forever.
    :D
     
  9. AutobahnSHO

    AutobahnSHO Android Enthusiast

    There are places that sell the cable- WITH the charger, and the cheapest I've seen online is $30 US. :(

    I want a backup too, I'm super-careful with mine but noticing a little bend on the end right near the USB plug end..
     
  10. ballerusk

    ballerusk Lurker
    Thread Starter

    I've called support, and I've sent them my cable. Bit of a crazy round-trip as the cable isn't available at any online shop, but support told me I could buy it from the company that did their supplies, so we wrote it down as a faulty cable (awaiting confirmation on that) and I called this company. Yes, I could buy the cable at 10AUD, but postage is flat rate of 15AUD (!!!), making it a 25AUD cable, unless I drove to Sydney to pick it up for 10AUD which is a two hour drive. What a crap policy, especially on small items like this. So instead of buying a new cable outright I opted for having the cable picked up here, couried to Sydney, confirmed, and couried back to me. What a stupid waste of money and time. Grumble. Surely in this modern age of computers and smart thinking you would think we could come up with better means of support and logistics. Grumble.

    Anyway, the cable is on its way to Sydney, so I'll await until I hear something, now completely without any means of charging my tablet. Bit stupid, really. I have an alternative power supply that serves both the voltage and amps to handle the charging, but since the 40-pin connector is proprietary and the pins unknown, I can't even hack together something myself in the mean time. I wish there were some companies out there who were a bit more hacker / advanced user friendly.

    Anyway, I'll let you know it it fixes my woes. (And yes, I did warm and cold reboot, factory reset, all the cable shuffling, pushing and prong pulling in the forums, the freezer trick, the trickle then try full charging, the tablet-completely-off charge, I've *replaced* the power supply completely [and got an upgrade from second generation supplies to third, so there's something], and probably more than I can't remember, including with / without dock, trickle a bit, charge a bit, blah, blah) It's really a shame that the charging is in such a mire, as the tablet is excellent and I have no other complaints. (And creating a less flimsy cable and charger would probably have saved them a ton of support)
     
  11. ballerusk

    ballerusk Lurker
    Thread Starter

    Ok, quick update. Got my cable back today, plugged it in, worked straight away. I had a dodgy cable, which, when you look at these cables, doesn't come as a big surprise. The funny part is that I could still trickle-charge and synchronise, but I guess the cable that gives signal for 12V charging (was it USB pin 9?) must have fallen off. ASUS really should have invested in a better cable, it's very flimsy.

    Anyway, thanks for all who helped, and sorry that it wasn't more exciting than this. :)
     
    Podivin likes this.
  12. Podivin

    Podivin Android Expert

    Thanks for telling us the results.
     
Loading...

Share This Page

Loading...