1. Check out our companion app, Forums for Android! Download from Google Play

Support tried to enable swap, now won't start

Discussion in 'Android Devices' started by benner, Dec 15, 2009.

  1. benner

    benner Well-Known Member
    Thread Starter
    16

    Oct 22, 2009
    93
    2
    16
    I am running GalaxHero 1.1. I tried to enable swap. First, I used the recovery mode and selected format ext. SD card with swap, then i restarted and enabled compcache and set it to 2 (now I see it should have been 0). Then I restarted and I just get the Android splash screen running forever. Can anyone suggest a solution?

    Thanks in advance,
     

    Advertisement

  2. Andronix

    Andronix Well-Known Member
    63

    Aug 31, 2009
    676
    16
    63
    adb logcat during boot might help.

    you may try this:

    enter recovery mode
    adb shell
    vi /system/etc/galaxo.conf
    compcache=no
    save
    sync
    reboot
     
  3. benner

    benner Well-Known Member
    Thread Starter
    16

    Oct 22, 2009
    93
    2
    16
    Not sure how to edit compcache. it appears to be coming up as read only.
     
  4. Andronix

    Andronix Well-Known Member
    63

    Aug 31, 2009
    676
    16
    63
    ah
    before adb shell,
    adb remount
     
  5. benner

    benner Well-Known Member
    Thread Starter
    16

    Oct 22, 2009
    93
    2
    16
    I can read through the conf. file but can't move up and down to change anything. I tried just typing the commands as you have them (compcache=no) into the shell and nothing happens. when i call up the conf file again there is no change. Am I doing something wrong? Can I find the file and open it with a text editor then save it back again after I edit? Thanks for your help so far...
     
  6. Andronix

    Andronix Well-Known Member
    63

    Aug 31, 2009
    676
    16
    63
    adb remount
    adb pull /system/etc/galaxo.conf . (it will copy galaxo.conf to your pc)
    edit galaxo.conf and change the line with compcache to no.
    adb push galaxo.conf /system/etc/galaxo.conf
    adb sync
    reboot phone
     
  7. benner

    benner Well-Known Member
    Thread Starter
    16

    Oct 22, 2009
    93
    2
    16
    Excellent! Took me a minute to realize that I had to add to the commands where I wanted to copy the file to on my computer, but then everything worked. Instead of turning off the compcache, I just changed it to 0 and then the phone restarted fine. I really appreciate your guidance. Thanks a lot.
     

Share This Page

Loading...