1. Check out our companion app, Forums for Android! Download from Google Play

Trouble connecting the phone

Discussion in 'App Inventor' started by asicengineer, Oct 19, 2010.

  1. asicengineer

    asicengineer New Member
    Thread Starter

    Oct 18, 2010
    Like many others trying to get started with App Inventor, I have been having trouble connecting the PC to my phone over USB. I have read lots of different scenarios and hints, but so far none have helped me.

    He is my situation.

    At first I didn't even try to connect a phone but just ran the app inventor and the blocks editor. Then a few days later I got serious and tried to connect the phone. No such luck. After read lots of hints on various forums I finally figured out I needed to download specific drivers for my Samsung Galaxy S, which I did, and now I can see the phone from an XP command window using the ADB devices command (it responds with a serial number, yea!) But still no connection from the Blocks editor (it just says no phone connected please connect a phone and go to a help page of App Inventor that is not particularly helpful.

    I put the adb command's directory into my PATH on the PC. Although I am not sure if there is something I must do to intialize this path command or if it is just active right away. I tried using the ADB command from outside it's own directory, and it worked fine.

    I see hints like be sure the phone is set for 'charge only' meaning to not have the phone report out storage disk over USB. The Galaxy S doesn't seem to have a 'charge only' setting, so I can see a drive F: is reported on the PC, but strangely it shows as empty even though the phone thinks there is some data there. It was suggest to disable that drive by doing an eject from the PC, but when I click on eject, nothing happens. And the empty device is still there.

    Regardless, the USB storage device isn't interfering with the ADB command.

    It was also suggested that once the Blocks Editor looks for the device and fails to find it, it needs some hand holding to relook for it and otherwise it just fails outright, but I would need guidance about how to get this relook started. I tried closing and reopening the blocks editor several times with no success.

    Any hints or suggestions would be greatly appreciated.


  2. ClassixUK

    ClassixUK Member

    Jan 8, 2011
    Make sure you are in debugging mode first.

    I had a similar problem, I found out that I needed to go into device manager and install the drivers manually.

    to do this, fire up device manager ,click on the name of your phone and select browse my computer for driver software.

    then point it to where you installed your android SDK Folders

    hope this helps
  3. davidloco

    davidloco New Member

    Feb 18, 2011
    Hi everybody, I'm in trouble when I want to connect my Galaxy S with App Inventor : drowdown indicates ??????????? instead of the name of my phone. What can I do ? I work on Linux Ubuntu 10.04 .

Share This Page