1. Check out our companion app, Forums for Android! Download from Google Play

Support Trouble Connecting to WiFi

Discussion in 'Android Devices' started by CriticalCritic, Nov 11, 2009.

  1. CriticalCritic

    CriticalCritic Well-Known Member
    Thread Starter
    213

    Nov 9, 2009
    1,872
    556
    213
    Cary, NC
    Using a Linksys wireless router with a WEP encryption at home. Every time I try to connect my phone says "Obtaining IP Address" and then after a short time it fails.

    -Yes, my phone recognizes the router.
    -Yes, I have the correct key.
    -Yes, I have reset my router and modem, no change.
    -Yes, I have restarted my phone.
    -Yes, my phone connects just fine to unsecured wireless routers.
    -No, I cannot find another thread that has solved this issue.

    Anyone know how to fix this?:eek:
     

    Advertisement

  2. prot0type

    prot0type Member
    15

    Nov 5, 2009
    22
    0
    15
    When you're typing in the key, make sure ALL of it is there, but by that I mean the very last letter/number. My Dlink router's WPA2 key was a digit too long and when I copy/pasted that into my phone, I didn't realize the last digit was cut off and couldn't connect. Even after trying to type it in, no go.
     
  3. CriticalCritic

    CriticalCritic Well-Known Member
    Thread Starter
    213

    Nov 9, 2009
    1,872
    556
    213
    Cary, NC
    I have the correct key. It's still not working.
     
  4. dkjones96

    dkjones96 Well-Known Member
    36

    Nov 2, 2009
    258
    7
    36
    Albuquerque, NM
    What strength of WEP are you using?

    I've got 0 issue so far on 64-bit, haven't tried 128 but will when I get home.
     
  5. momentoid

    momentoid Well-Known Member
    53

    Nov 11, 2009
    367
    62
    53
    US of A
    I have an Access Point of different make. Took me some time to finally connect to the AP with 128-bit WEP. On Moment, I used Settings > Wireless Controls > Wi-Fi Settings > "Add Wi-Fi Network" and enabled "Show Password" to make sure I was typing it right. And, I left the key type to "Auto". Hope this helps.
     
  6. williamsck1

    williamsck1 Member
    5

    Nov 6, 2009
    9
    0
    5
    I have a different issue. It connects but does not pass data. I double checked the settings against my Hero and even swapped IP's but still no data passed. Any Ideas?
     
  7. chibucks

    chibucks Well-Known Member
    43

    Nov 3, 2009
    412
    48
    43
    i'd try unsecuring your router and try to connect to it just to make sure it's not your router. i haven't had any issue with mine - WPA-PSK secured...

    also, make sure you don't have any sort of security set within the router itself (allowing only devices that it recognizes to connect).

    i guess that's just a few thoughts...
     
  8. AndroidSPCS

    AndroidSPCS Well-Known Member
    183

    Nov 12, 2009
    3,222
    478
    183
    geek
    USA
    With all these issues, troubleshoot one step at a time.

    Remove all security on the routers, make it an open wifi network, and see if the Moment can connect. Then add on a simple security password, and try that and see if it will connect. If it connects with a very simple security password, chances are your passwords are entered wrong in the Moment.

    You're going to have to take it one step at a time to connect.

    And ditch WEP, it's virtually no security. I'm connected to my WPA2 personal AES secured network with my Moment and I connected on the first try.
     
  9. williamsck1

    williamsck1 Member
    5

    Nov 6, 2009
    9
    0
    5
    I have checked the settings and found when my Moment logs onto the router, the MAC shows up but not the IP. Its blank. When the Hero logs on I can seep the IP. I believe it to be a 128b issue.
     
  10. AndroidSPCS

    AndroidSPCS Well-Known Member
    183

    Nov 12, 2009
    3,222
    478
    183
    geek
    USA
    sounds like MAC filter is applied? If so turn it off.
     
  11. williamsck1

    williamsck1 Member
    5

    Nov 6, 2009
    9
    0
    5
    Nope, it does not like WEP. changed to WPA2-PSK [AES] and worked like a champ
     
  12. AndroidSPCS

    AndroidSPCS Well-Known Member
    183

    Nov 12, 2009
    3,222
    478
    183
    geek
    USA
    Great to hear. WEP is crap any way.
     
  13. williamsck1

    williamsck1 Member
    5

    Nov 6, 2009
    9
    0
    5
    Just to clarify for everyone. The HTC Hero would not connect unless I broadcast the SSID, which I hate. I already have an ACL in place because I was still using WEP and have DHCP disabled so no one could jump on my network unless their MAC was on the ACL, had an IP in my range and the code. When I added the Moments MAC to the ACL and assigned an IP to it, it would log-on but not pass data. When I looked at my router, it would see the MAC and the connection but couldnt display the IP. For whatever reason the Moment wouldnt or couldnt broadcast the IP given, thus no data would pass. Changed the router to WPA2-PSK [AES] and it worked like a champ. I still hate broadcasting my SSID but its needed for the phones.
     
  14. dkjones96

    dkjones96 Well-Known Member
    36

    Nov 2, 2009
    258
    7
    36
    Albuquerque, NM
    Weird. I use WEP at work and my Moment is okay(Linksys). It's unfortunately required since we run a lot of computers on W2K but not a concern since our wireless can't penetrate the outside walls of our building anyways.

    What firmware are you running on your routers? I'm using Tomato at home and had zero issues on all settings but I normally run that WiFi open.
     
  15. williamsck1

    williamsck1 Member
    5

    Nov 6, 2009
    9
    0
    5
    Running the standard OS for a Netgear WPN824 extended range. Have not hacked this router. No need to, the Setup was easy and the range is awesome and easy to setup ACL's. Coming from an old Cisco 4000 from work, I like this one.
     
  16. dkjones96

    dkjones96 Well-Known Member
    36

    Nov 2, 2009
    258
    7
    36
    Albuquerque, NM
    I had to change out the firmware. The factory stuff was a joke. Nice to have the print server on the router but the stupid thing would lock up within 10 minutes of starting a torrent and I couldn't have that.

    I just use the USB on the router for network mass storage.
     
  17. honzyboy

    honzyboy New Member
    5

    Apr 27, 2011
    3
    0
    5
    I had trouble connecting to the Linksys n-series at my workplace. I added my phone to the Dmz and now it connects perfectly. I have a new Samsung nexus s and I have had no other connection problems anywhere else. Anyone see any problem with being in the dmz?
     

Share This Page

Loading...