1. Download our Official Android App: Forums for Android!

Trouble sending mail with K-9

Discussion in 'Android Apps & Games' started by Forts, Oct 3, 2010.

  1. Forts

    Forts Member
    Thread Starter

    Aug 6, 2010
    Hi all,

    I've got an issue I'm hoping someone can help me with. I have an HTC Magic running the stock Roger's 2.1 rom, using K9 mail with MobileMe. I find if I compose an email from scratch, no problems. But if I reply to a message it won't send... it just sits in the Outbox. If I manually force it to send from the Outbox it will usually go... but not always. Has anyone come across anything like this before? Seems pretty weird that a 'fresh' email will send, but not a reply (the only different seemingly being that K9 is filling in the To field itself).

    I guess in the meantime I could give another email app such as MailDroid a spin, but I'm rather fond of K9.

    Many thanks!


  2. jimdroid

    jimdroid Android Expert

    Oct 31, 2009
    SF Bay Area
    Haven't seen this. If I were in your shoes, I'd first try creating a new mail account for the same account and seeing if new account behaves the same way. If it does, I'd uninstall/reinstall K9.
  3. YarnGirl

    YarnGirl Lurker

    May 21, 2010
    Same problem on the Samsung Moment, though sometimes I can't send new emails either. Seems to have only started after the last update my phone got automatically about a week or so ago. I can reply to emails with no problem from the stock email application.
  4. ethanlifka

    ethanlifka Lurker

    Oct 13, 2010
    I am having the exact same problem on Saymsung Vibrant. I did do the Update, but this was the first time sending an email so I do not know if it was because of the 2.1 Update or not.

    However it seems to work if I don't use SSL, but the SSL should work.
    These are the same settings as what I used for the default mail app and my PC on Outlook.

    I am using IMAP

    Please any help would be great. I really like the k-9 Mail and would like to get the SSL Working.
  5. obdave

    obdave Lurker

    Nov 1, 2010
    Found this thread on Google, but same issue here. Verizon Droid X, K-9 Mail 3.202, Android 2.2.
  6. nyc0007

    nyc0007 Lurker

    Jun 26, 2013
    I had the same problem with my Samsung G2. I noticed that each problem had a different solution. My situation was that I was able to receive incoming msgs just fine but unable to send. K9 gave me all kinds of error msgs, from password, to negative SMTP sent "some messages", "failed to send messages".
    I uninstalled and installed k9 about 4 times. Still same msg.
    Then I did what Jim Droid indicated, just add another email fresh account to k9. And bingo that email was able to send from my phone using wifi(wifi=the same denominator throughout). However when I tried to send from my original yahoo address it still did not send. So I went to settings, then Mail Accounts, on my Yahoo.com computer account, then filled out the portion where it asked for sending name and reply-to address(which was blank for some reason), and tried to send via K-9 again and it worked on my original email as well! Could be a coincidence but it seems as if you have to make sure that when you send and receive mail from "other services" you fill out the info on your computer Yahoo account before you can expect things to work right.

    I have been working on this problem for a month. The kicker was that many people say check with your server, which helped, but its not always apparent where to go to fix the problem on YOUR PARTICULAR server(in this case YAHOO) since they are all a little different format-wise.
    Hopefully this fix works for all of you!

Share This Page